autopkgtests fail with openjdk 11~28-3ubuntu1 in cosmic-proposed

Bug #1796361 reported by Olivier Tilloy on 2018-10-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Medium
Olivier Tilloy
Cosmic
Undecided
Unassigned

Bug Description

libreoffice 6.1.2 autopkgtests pass with openjdk 10.0.2+13-1ubuntu1 that's currently in cosmic. When upgrading openjdk to 11~28-3ubuntu1 in cosmic-proposed, the test called odk-build-examples reliably fails. I'm attaching the log of the failed test, ran separately in an up-to-date amd64 cosmic VM with cosmic-proposed.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 4.18.0-8.9-generic 4.18.7
Uname: Linux 4.18.0-8-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.10-0ubuntu11
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Oct 5 17:55:10 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-07-02 (824 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: libreoffice
UpgradeStatus: Upgraded to cosmic on 2018-09-14 (21 days ago)

Olivier Tilloy (osomon) wrote :
Olivier Tilloy (osomon) wrote :

I was able to get the tests passing with the following change:

--- odk/examples/DevelopersGuide/OfficeDev/DesktopEnvironment/Makefile.orig 2018-10-05 18:45:40.169292599 +0200
+++ odk/examples/DevelopersGuide/OfficeDev/DesktopEnvironment/Makefile 2018-10-05 18:45:46.417351542 +0200
@@ -66,7 +66,6 @@
 APP1_CLASSFILES = $(patsubst %.java,$(OUT_APP_CLASS)/%.class,$(APP1_JAVAFILES))
 APP1_CLASSNAMES = $(patsubst %.java,%.class,$(APP1_JAVAFILES)) \
   CustomizeView$(QUOTE)$$ClickListener.class \
- DocumentView$(QUOTE)$$1.class \
   DocumentView$(QUOTE)$$Reactor.class

But I'm not sure what that change really involves, functionally speaking.

Olivier Tilloy (osomon) wrote :

DocumentView$1.class is supposed to hold an anonymous inner class, and it looks like with the updated openjdk this file is not generated. I wonder whether that's an openjdk regression, or a change in how the jdk compiles java classes.

Olivier Tilloy (osomon) wrote :

This could possibly be a consequence of http://openjdk.java.net/jeps/181.

Olivier Tilloy (osomon) wrote :

I'm not fluent in java, but reading the source (DocumentView.java) I cannot see any anonymous inner class definitions. And indeed if I disassemble DocumentView$1.class that was generated with OpenJDK 10, it looks pretty much empty:

$ javap out/sdk/LINUXexample.out/class/OfficeDevDesktopEnv/DocumentView\$1.class
Compiled from "DocumentView.java"
class DocumentView$1 {
}

I also successfully ran the corresponding tests with OpenJDK 10 after removing DocumentView$(QUOTE)$$1.class from odk/examples/DevelopersGuide/OfficeDev/DesktopEnvironment/Makefile, so it looks like this could be safely removed.

Matthias Klose (doko) wrote :

Is this still seen once you rebuild LO with OpenJDK 11?

Olivier Tilloy (osomon) wrote :

Rebuilding libreoffice against OpenJDK 11 shouldn't make any difference.

The failing test invokes /usr/lib/jvm/default-java/bin/javac to compile java files in /usr/lib/libreoffice/sdk/examples/DevelopersGuide/OfficeDev/DesktopEnvironment/, and then tries to bundle the resulting class files into a jar by invoking /usr/lib/jvm/default-java/bin/jar with the list of expected class files. One of those files is not being generated (DocumentView$1.class) when compiled with javac in OpenJDK 11.

Olivier Tilloy (osomon) wrote :

Change submitted upstream for discussion: https://gerrit.libreoffice.org/#/c/61607/

Adolfo Jayme (fitojb) on 2018-10-11
Changed in libreoffice (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Olivier Tilloy (osomon) wrote :

The autopkgtest failures were temporarily ignored to allow openjdk 11 to enter the archive: https://bazaar.launchpad.net/~ubuntu-release/britney/hints-ubuntu/revision/3296

This still needs fixing in libreoffice.

Tiago Stürmer Daitx (tdaitx) wrote :

Thanks Olivier,

I confirm your test results: ignoring the DocumentView$1.class is fine with both openjdk-10 and openjdk-11.

I agree that JEP-181 is the most probable cause as to why this access bridge class is no longer generated - there's a small discussion on why access bridge classes were necessary at https://github.com/immutables/immutables/issues/1#issuecomment-31525561.

Thanks for driving this.

Olivier Tilloy (osomon) wrote :
Changed in libreoffice (Ubuntu):
status: Triaged → In Progress

Hello Olivier, or anyone else affected,

Accepted libreoffice into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:6.1.2-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libreoffice (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Olivier Tilloy (osomon) wrote :

autopkgtests for libreoffice 1:6.1.2-0ubuntu1.1 in cosmic-proposed all passed (see http://autopkgtest.ubuntu.com/packages/libreoffice).

Based on this, marking verified.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.1.2-0ubuntu1.1

---------------
libreoffice (1:6.1.2-0ubuntu1.1) cosmic; urgency=medium

  * Make LibreOffice under the LXQt desktop environment use the Breeze theme
    as the default (LP: #1799001).
  * Backport a patch from upstream which fixes testcases with OpenJDK 11
    (LP: #1796361).

 -- Simon Quigley <email address hidden> Sat, 03 Nov 2018 15:14:37 -0500

Changed in libreoffice (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.