[upstream] Writer hangs for over 20 minutes loading a 3MB, 450-page DOCX

Bug #1796187 reported by Asaf Bartov on 2018-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to load the attached DOCX results in a hang. I force-quit after 20 minutes. The DOCX was created in MS Word (2013 I think), and is about 450 pages, thousands of footnotes, but no graphics AFAIK.

I am using the latest package provided by snap. LibreOffice 6.1.2.1. Ubuntu 18.04.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libreoffice-writer (not installed)
ProcVersionSignature: Ubuntu 4.15.0-34.37-generic 4.15.18
Uname: Linux 4.15.0-34-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Oct 4 23:50:54 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-06-03 (488 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: Upgraded to bionic on 2018-06-06 (119 days ago)

Asaf Bartov (asaf-bartov) wrote :
Olivier Tilloy (osomon) wrote :

I can observe the issue in an up-to-date bionic amd64 VM. Opening the attached document and rendering it completely took 32 minutes. This is an insane amount of time to load a 516 pages document (153316 words, 927209 characters), but it eventually completed and once done the document can be navigated and edited just fine, as far as I can tell.

If there isn't one already, can you please report a bug upstream at https://bugs.documentfoundation.org/enter_bug.cgi?product=LibreOffice&format=guided, and share the link to that bug here? Thanks!

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

Note that I also tested libreoffice 6.0.6 that's installed by default in Ubuntu 18.04 (the deb packages, not the snap), and it took over 20 minutes to load the same document, so it's not a snap-specific problem.

Description:
Trying to load the attached DOCX results in a hang. I force-quit after 20 minutes. The DOCX was created in MS Word (2013 I think), and is about 450 pages, thousands of footnotes, but no graphics AFAIK.

I am using the latest package provided by snap. LibreOffice 6.1.2.1. Ubuntu 18.04.

Olivier Tilloy from Canonical confirmed the bug and added:

"I can observe the issue in an up-to-date bionic amd64 VM. Opening the attached document and rendering it completely took 32 minutes. This is an insane amount of time to load a 516 pages document (153316 words, 927209 characters), but it eventually completed and once done the document can be navigated and edited just fine, as far as I can tell."

"Note that I also tested libreoffice 6.0.6 that's installed by default in Ubuntu 18.04 (the deb packages, not the snap), and it took over 20 minutes to load the same document, so it's not a snap-specific problem."

Steps to Reproduce:
1. Open the attached DOCX file.
2. Observe time passing.
3. Observe more time passing. :)

Actual Results:
as described above, it took literally half an hour of 100% CPU effort to open.

Expected Results:
I expect it to open in under 30 seconds.

Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 6.1.2.1
Build ID: libreoffice-6.1.2.1-snap1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); Calc: group threaded

Created attachment 145419
the docx that hangs Writer on opening.

Asaf Bartov (asaf-bartov) wrote :

Thank you very much for the quick triage, Mr. Tilloy! Much appreciated.

I have now submitted the same report upstream, and referenced this ticket and reproduced your comments:

https://bugs.documentfoundation.org/show_bug.cgi?id=120351

Confirmed on windows 7 x64 with Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 3; OS: Windows 6.1; UI render: default

and

ubuntu 16.04 x64 with Version: 6.2.0.0.alpha0+
Build ID: ad6adb1bfadf49af3187a0bb3ceffbf355e9eed1
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2;
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-29_02:45:20
Locale: en-US (en_US.UTF-8); Calc: threaded

and

Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default;
Locale: en-US (en_US.UTF-8); Calc: single

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

Cold be a duplicate of Bug 76260. Please compare console errors.

summary: - Writer hangs for over 20 minutes loading a 3MB, 450-page DOCX
+ [upstream] Writer hangs for over 20 minutes loading a 3MB, 450-page DOCX
Changed in df-libreoffice:
status: Confirmed → In Progress

László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7dd8f8aace536a8e60e87e61ee1d90d61fba15eb

tdf#120351 DOCX import: fix slow endnote import

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Changed in df-libreoffice:
status: In Progress → Fix Released

After the fix it takes

real 0m16,431s
user 0m15,568s
sys 0m0,683s

to open the attached document, before it, I takes

real 6m53,672s
user 6m51,205s
sys 0m2,290s

wow, super nice improvement.

@László Németh, thanks for fixing this issue!!

*** Bug 139211 has been marked as a duplicate of this bug. ***

*** Bug 137938 has been marked as a duplicate of this bug. ***

@Xisco: According to your data, loading the test document is not only 25 times faster, but we finally have a reasonable load time. :) Many thanks for verifying and closing the duplicates!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.