libreoffice triggers very many AppArmor complaints

Bug #1780162 reported by David A. Cobb on 2018-07-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Starting even the splash screen, and starting an application, and openning a file, and even moving the mouse(!!) fills my screen with AppArmor complaints.

It appears to me, the problem is in the packaged /etc/apparmor.d/usr.library.libreoffice.program.* files have "flags="(complain) everywhere.

I cannot even seem to aa-disable these profiles; the complaints just keep coming.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libreoffice 1:6.0.3-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-24.26-generic 4.15.18
Uname: Linux 4.15.0-24-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Jul 4 18:23:51 2018
InstallationDate: Installed on 2018-06-05 (29 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

David A. Cobb (superbiskit) wrote :
Seth Arnold (seth-arnold) wrote :

Hello,

Your logs indicate that some of the libreoffice files have changed:
libreoffice-common 1:6.0.3-0ubuntu1 [modified: usr/lib/libreoffice/share/basic/dialog.xlc usr/lib/libreoffice/share/basic/script.xlc]

Does this sound like something you would have done intentionally? This is strange. What is changed with these files?

What specific things is apparmor logging?

Which profiles are in complain mode?

Thanks

Olivier Tilloy (osomon) wrote :

By default the following profiles are in complain mode:

    libreoffice-oopslash
    libreoffice-soffice

This is intentional and inherited from Debian, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=886548.

You should be able to disable the profiles (although not permanently) like that:

    sudo apparmor_parser -R /etc/apparmor.d/usr.lib.libreoffice.program.oosplash /etc/apparmor.d/usr.lib.libreoffice.program.soffice.bin

Changed in libreoffice (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.