libreoffice FTBFS with liborcus 0.13.3

Bug #1750982 reported by Olivier Tilloy on 2018-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
High
Olivier Tilloy

Bug Description

The following unit test is failing:

subsequent_filters-test.cxx:2398:Assertion
Test name: ScFiltersTest::testOrcusODSStyleInterface
equality assertion failed
- Expected: Color: R:254 G:255 B: 204
- Actual : Color: R:255 G:255 B: 255

This is most likely caused by that upstream change: https://gitlab.com/orcus/orcus/commit/f821995022df8dd1e580dd22cf131584b2b1ac4f

Olivier Tilloy (osomon) on 2018-02-22
Changed in libreoffice (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: New → In Progress
Olivier Tilloy (osomon) wrote :

With that patch, the failure becomes:

subsequent_filters-test.cxx:2398:Assertion
Test name: ScFiltersTest::testOrcusODSStyleInterface
equality assertion failed
- Expected: Color: R:254 G:255 B: 204
- Actual : Color: R:254 G:255 B: 204

puzzling…

Olivier Tilloy (osomon) wrote :

https://gitlab.com/orcus/orcus/commit/f7953a814d6a43205791b6cc01c528ef5d4b1ce3 probably explains this. I guess the two colors are not equal because of the alpha component.

Olivier Tilloy (osomon) on 2018-02-27
Changed in libreoffice (Ubuntu):
status: In Progress → Fix Committed
Olivier Tilloy (osomon) on 2018-03-12
Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.