LO 6.0 autopkgtest failures (uicheck: test_text_direction)

Bug #1750335 reported by Olivier Tilloy on 2018-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
High
Rico Tzschichholz

Bug Description

autopkgtests for libreoffice 6.0.1-0ubuntu1 (currently in bionic-proposed) are consistently failing:

======================================================================
ERROR: test_text_direction (pageDialog.WriterPageDialog)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/tmp/autopkgtest.zEJ7dp/build.U4P/src/uitest/uitest/framework.py", line 46, in tearDown
    self.connection.tearDown()
  File "/tmp/autopkgtest.zEJ7dp/build.U4P/src/uitest/libreoffice/connection.py", line 192, in tearDown
    self.connection.tearDown()
  File "/tmp/autopkgtest.zEJ7dp/build.U4P/src/uitest/libreoffice/connection.py", line 152, in tearDown
    raise Exception("Exit status indicates failure: " + str(ret))
Exception: Exit status indicates failure: 1

======================================================================
FAIL: test_text_direction (pageDialog.WriterPageDialog) (i=1)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/tmp/autopkgtest.zEJ7dp/build.U4P/src/uitest/writer_tests/pageDialog.py", line 220, in test_text_direction
    get_state_as_dict(xTextDirectionList)["SelectEntryText"], lTextDirection[i])
AssertionError: 'Left-to-right (horizontal)' != 'Right-to-left (horizontal)'
- Left-to-right (horizontal)
+ Right-to-left (horizontal)

======================================================================
FAIL: test_text_direction (pageDialog.WriterPageDialog) (i=2)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/tmp/autopkgtest.zEJ7dp/build.U4P/src/uitest/writer_tests/pageDialog.py", line 220, in test_text_direction
    get_state_as_dict(xTextDirectionList)["SelectEntryText"], lTextDirection[i])
AssertionError: 'Left-to-right (horizontal)' != 'Right-to-left (vertical)'
- Left-to-right (horizontal)
+ Right-to-left (vertical)

======================================================================
FAIL: test_text_direction (pageDialog.WriterPageDialog) (i=3)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/tmp/autopkgtest.zEJ7dp/build.U4P/src/uitest/writer_tests/pageDialog.py", line 220, in test_text_direction
    get_state_as_dict(xTextDirectionList)["SelectEntryText"], lTextDirection[i])
AssertionError: 'Left-to-right (horizontal)' != 'Left-to-right (vertical)'
- Left-to-right (horizontal)
? ^^ ^^^^
+ Left-to-right (vertical)
? ^^ + ^

Olivier Tilloy (osomon) wrote :

I can reproduce the failure locally.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :

It appears the xTextDirectionList dropdown is not really visible in the page dialog:

    (Pdb) xTextDirectionList.State[8].value.Name
    'ReallyVisible'
    (Pdb) xTextDirectionList.State[8].value.Value
    'false'

In writer, that dropdown is not visible until the "Asian" checkbox is checked in the Language Settings (and it's not checked by default).

Olivier Tilloy (osomon) wrote :

https://salsa.debian.org/libreoffice-team/libreoffice/libreoffice/commit/ef1bd99104bb40e1605ceee9ec336456c2a5d74d supposedly fixed that issue, but it obviously didn't, at least not on ubuntu.

I am going to disable that test for now to unblock the transition, and we can revisit later based on future feedback on the upstream bug report.

Changed in libreoffice (Ubuntu):
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :
Changed in libreoffice (Ubuntu):
status: In Progress → Fix Committed
Olivier Tilloy (osomon) wrote :

It turns out this is due to missing files in the l10n packages:

> I see (at least) /usr/lib/libreoffice/share/registry/ctl_he.xcd
> missing on a first glance.

Changed in libreoffice (Ubuntu):
status: Fix Committed → Confirmed
Olivier Tilloy (osomon) wrote :

And manually installing the missing files makes the tests pass.

Olivier Tilloy (osomon) wrote :
Changed in libreoffice (Ubuntu):
assignee: Olivier Tilloy (osomon) → Rico Tzschichholz (ricotz)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.0.1-0ubuntu3

---------------
libreoffice (1:6.0.1-0ubuntu3) bionic; urgency=medium

  [ Olivier Tilloy ]
  * debian/patches/uitest-skip-test_text_direction.patch: removed

  [ Rene Engelhard ]
  * debian/patches/orcus-0.13.3.diff: backport patches to fix build/tests
    against orcus 0.13.3

  [ Rico Tzschichholz ]
  * debian/patches/solenv-Update-gb_PackageInfo_emit_l10n_for_one_lang.patch:
    Update gb_PackageInfo_emit_l10n_for_one_lang to add cjk_*, ctl_* and
    ctlseqcheck_$LANG.xcd files to install list (LP: #1750335)
  * Fix libvisio and libqxp shlibs dependency (Thanks Rene)

 -- Olivier Tilloy <email address hidden> Fri, 23 Feb 2018 13:33:59 +0100

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.