[SRU] libreoffice 5.4.2 for artful

Bug #1728072 reported by Olivier Tilloy on 2017-10-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned
libreoffice-l10n (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

[Impact]

 * LibreOffice 5.4.2 is the second bugfix release of the fresh 5.4 line, after 5.4.1 (currently in 17.10).
   For a list of fixed bugs compared to 5.4.1 see the list of bugs fixed in RC1 and RC2:
     https://wiki.documentfoundation.org/Releases/5.4.2/RC1#List_of_fixed_bugs
     https://wiki.documentfoundation.org/Releases/5.4.2/RC2#List_of_fixed_bugs

 * Given the nature of the project, the complexity of the codebase and the high level of quality assurance upstream, it is preferable to SRU a minor release rather than cherry-pick selected bug fixes.

 * Libreoffice 5.4.2 (RC2, which is effectively the final release) has been available for users to test since 2017-10-04 in the official "LibreOffice Pre-Releases" PPA (https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-prereleases/+packages).

[Test Case]

 * No specific test case, bugs fixed upstream hopefully come with unit/regression tests, and the release itself is extensively exercised upstream (both in an automated manner and manually) by a community of testers. The release went through 2 release candidates.

 * The libreoffice packages include autopkgtests, those should be run and verified to pass.

 * General smoke testing of all the applications in the office suite should be carried out.

[Regression Potential]

 * A new release with more than 100 bug fixes always carries the potential for introducing regressions, even though it's a bugfix-only release, meaning that no new features were added, and no existing features were removed.

 * A combination of autopkgtests and careful smoke testing as described above should provide reasonable confidence that no regressions sneaked in.

Łukasz Zemczak (sil2100) wrote :

Libreoffice 5.4.2 is in bionic-proposed and will be migrating shortly.

Changed in libreoffice (Ubuntu):
status: New → Fix Committed

Hello Olivier, or anyone else affected,

Accepted libreoffice into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:5.4.2-0ubuntu0.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libreoffice (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed verification-needed-artful
Changed in libreoffice-l10n (Ubuntu Artful):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Olivier, or anyone else affected,

Accepted libreoffice-l10n into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice-l10n/1:5.4.2-0ubuntu0.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Olivier Tilloy (osomon) on 2017-11-21
Changed in libreoffice-l10n (Ubuntu):
status: New → Fix Committed
Olivier Tilloy (osomon) wrote :

Tested libreoffice and libreoffice-l10n version 1:5.4.2-0ubuntu0.17.10.1 from artful-proposed.
Did some smoke testing of all applications in the suite, everything looks fine.

tags: added: verification-done-artful
removed: verification-needed-artful

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of libreoffice from artful-proposed was performed and bug 1733849 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1733849 (not this bug). Thanks!

tags: added: verification-failed
Łukasz Zemczak (sil2100) wrote :

Olivier, could you take a look at the mentioned bug by the bot? I would like to make sure this does not introduce any regression.

Olivier Tilloy (osomon) wrote :

@Łukasz: I'm looking into it. It appears that the reporter still experiences the crash after downgrading to 1:5.4.1-0ubuntu1, so in that regard it wouldn't be a regression.
In any case, I asked for more details to continue investigating the issue.

Olivier Tilloy (osomon) wrote :

After some back and forth with the reporter, bug #1733849 has been confirmed to be a duplicate of bug #1699772, so not a regression.

tags: removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.4.2-0ubuntu0.17.10.1

---------------
libreoffice (1:5.4.2-0ubuntu0.17.10.1) artful; urgency=medium

  [ Rico Tzschichholz ]
  * New upstream release (LP: #1728072)
  * Drop debian/patches/java9.diff, included upstream

  [ Rene Engelhard ]
  * debian/rules:
    - move images_helpimg.zip to usr/share like the others; remove obsolete
      helpimg mangling in the "other" images_*.zip

 -- Olivier Tilloy <email address hidden> Tue, 14 Nov 2017 16:38:24 +0100

Changed in libreoffice (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice-l10n - 1:5.4.2-0ubuntu0.17.10.1

---------------
libreoffice-l10n (1:5.4.2-0ubuntu0.17.10.1) artful; urgency=medium

  [ Rico Tzschichholz ]
  * New upstream release (LP: #1728072)
  * Drop debian/patches/java9.diff, included upstream

  [ Rene Engelhard ]
  * debian/rules:
    - move images_helpimg.zip to usr/share like the others; remove obsolete
      helpimg mangling in the "other" images_*.zip

 -- Olivier Tilloy <email address hidden> Tue, 14 Nov 2017 16:38:24 +0100

Changed in libreoffice-l10n (Ubuntu Artful):
status: Fix Committed → Fix Released

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of libreoffice from artful-proposed was performed and bug 1734132 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1734132 (not this bug). Thanks!

tags: added: verification-failed
Olivier Tilloy (osomon) wrote :

Bug #1734132 has been confirmed not to be a regression, it was already present in libreoffice 5.4.1.

tags: removed: verification-failed
Olivier Tilloy (osomon) on 2018-03-12
Changed in libreoffice-l10n (Ubuntu):
status: Fix Committed → Fix Released
Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers