FTBFS on i386: dbaccess_RowSetClones unit test segfaults

Bug #1700692 reported by Olivier Tilloy
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Critical
Olivier Tilloy

Bug Description

That unit test has been consistently failing in i386 builds for the past few days (at least since 2017-06-20 which is when 5.3.3-0ubuntu2 was uploaded to -proposed, maybe longer). I've tried building 5.3.4 in a PPA, and it's failing in the same manner.

Attaching a full build log.

Revision history for this message
Olivier Tilloy (osomon) wrote :
Revision history for this message
Olivier Tilloy (osomon) wrote :

I wonder if that could be linked to bug #1699772 ?

Revision history for this message
Olivier Tilloy (osomon) wrote :
Download full text (10.9 KiB)

Full stack trace:

Thread 1 "cppunittester" received signal SIGSEGV, Segmentation fault.
0xab9cc965 in _expand_stack_to(unsigned char*) () from /usr/lib/jvm/java-8-openjdk-i386/jre/lib/i386/server/libjvm.so
(gdb) bt
#0 0xab9cc965 in _expand_stack_to(unsigned char*) () at /usr/lib/jvm/java-8-openjdk-i386/jre/lib/i386/server/libjvm.so
#1 0xab9cf174 in os::Linux::manually_expand_stack(JavaThread*, unsigned char*) ()
    at /usr/lib/jvm/java-8-openjdk-i386/jre/lib/i386/server/libjvm.so
#2 0xab9d96b8 in os::create_main_thread(JavaThread*) () at /usr/lib/jvm/java-8-openjdk-i386/jre/lib/i386/server/libjvm.so
#3 0xabb1bece in Threads::create_vm(JavaVMInitArgs*, bool*) () at /usr/lib/jvm/java-8-openjdk-i386/jre/lib/i386/server/libjvm.so
#4 0xab7c8635 in JNI_CreateJavaVM () at /usr/lib/jvm/java-8-openjdk-i386/jre/lib/i386/server/libjvm.so
#5 0xb27a57d1 in jfw_plugin_startJavaVirtualMachine(JavaInfo const*, JavaVMOption const*, long, JavaVM_**, JNIEnv_**) (pInfo=<optimized out>, arOptions=<optimized out>, cOptions=<optimized out>, ppVm=<optimized out>, ppEnv=<optimized out>)
    at ./jvmfwk/plugins/sunmajor/pluginlib/sunjavaplugin.cxx:845
#6 0xb27b5e94 in jfw_startVM(JavaInfo const*, JavaVMOption*, long, JavaVM_**, JNIEnv_**) (pInfo=<optimized out>, arOptions=<optimized out>, cOptions=<optimized out>, ppVM=<optimized out>, ppEnv=<optimized out>) at ./jvmfwk/source/framework.cxx:340
#7 0xad1f7ad0 in stoc_javavm::JavaVirtualMachine::getJavaVM(com::sun::star::uno::Sequence<signed char> const&) (this=0x80b15b28, rProcessId=uno::Sequence of length 17 = {...}) at ./stoc/source/javavm/javavm.cxx:759
#8 0xaf40cc97 in gcc3::callVirtualMethod(void*, long, void*, _typelib_TypeDescription*, bool, long*, long) (pAdjustedThisPtr=0x80b15b58, nVtableIndex=3, pRegisterReturn=0xbfff21f0, pReturnTypeDescr=0x8009a5f8, bSimpleReturn=false, pStackLongs=0xbfff2210, nStackLongs=3)
    at /home/ubuntu/build/libreoffice-5.3.3/bridges/source/cpp_uno/gcc3_linux_intel/callvirtualmethod.cxx:102
#9 0xaf40c249 in (anonymous namespace)::cpp_call(bridges::cpp_uno::shared::UnoInterfaceProxy*, bridges::cpp_uno::shared::VtableSlot, typelib_TypeDescriptionReference*, sal_Int32, typelib_MethodParameter*, void*, void**, uno_Any**) (pThis=pThis@entry=0x80b1f058, aVtableSlot=..., pReturnTypeRef=<optimized out>, nParams=<optimized out>, pParams=<optimized out>, pUnoReturn=<optimized out>, pUnoArgs=<optimized out>, ppUnoExc=<optimized out>) at ./bridges/source/cpp_uno/gcc3_linux_intel/uno2cpp.cxx:161
#10 0xaf40c85b in bridges::cpp_uno::shared::unoInterfaceProxyDispatch(_uno_Interface*, _typelib_TypeDescription const*, void*, void**, _uno_Any**) (pUnoI=0x80b1f058, pMemberDescr=0x80b14310, pReturn=0xada109c0, pArgs=0xada109e0, ppException=0xada10a3c)
    at ./bridges/source/cpp_uno/gcc3_linux_intel/uno2cpp.cxx:360
#11 0xada13f11 in s_dispatcher_v(va_list*) (pParam=0xada10988) at ./cppu/source/helper/purpenv/helper_purpenv_Proxy.cxx:384
#12 0xb77e2c9c in s_environment_invoke_v(uno_Environment*, uno_Environment*, uno_EnvCallee*, va_list*) (pCurrEnv=0x0, pTargetEnv=<optimized out>, pCallee=0xada13ee0 <s_dispatcher_v(va_list*)>, pParam=0xada10988) at ./cppu/source/uno/EnvStack.cxx:293
#13 0xa...

Revision history for this message
Olivier Tilloy (osomon) wrote :

If that is indeed bug #1699772, then updating the kernel on the launchpad builders should fix it.

I just did a (failed) build in a PPA, and the kernel version was:
    Kernel reported to sbuild: 4.4.0-81-generic #104-Ubuntu SMP Wed Jun 14 08:17:06 UTC 2017 i686

Supposedly kernel 4.4.0-83.106 has the fix.

Olivier Tilloy (osomon)
Changed in libreoffice (Ubuntu):
status: New → Triaged
Revision history for this message
Olivier Tilloy (osomon) wrote :

I am seeing a different unit test failure when building i386 snap packages for libreoffice, but I am suspecting this is caused by the same issue:

   [build CUT] dbaccess_hsqldb_test
   Segmentation fault (core dumped)

(attaching full build log)

Revision history for this message
Olivier Tilloy (osomon) wrote :

An i386 build of libreoffice 5.3.4 in a PPA (with -proposed enabled) still fails on the same unit test. In fact, two unit tests fail:

    dbaccess_hsqldb_test.test
    dbaccess_RowSetClones.test

Which is consistent with the snap build, except that the snap build fails on the first one and bails out, whereas the PPA build appears to be running more tests before it bails out.

Revision history for this message
Olivier Tilloy (osomon) wrote :

And both builds (snap and PPA) were performed with kernel 4.4.0-83-generic #106.

Revision history for this message
Olivier Tilloy (osomon) wrote :

It’s been reported in debian that libreoffice writer is crashing at startup with java enabled, on 32 bits only with their latest kernel update. This smells like the same issue, and one that is affecting the actual application, not just the unit tests. See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=865303 for details.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.3.4-0ubuntu1

---------------
libreoffice (1:5.3.4-0ubuntu1) artful; urgency=medium

  * New upstream release: 5.3.4
  * debian/rules: temporarily ignore unit test failures on i386 (LP: #1700692)

 -- Olivier Tilloy <email address hidden> Thu, 13 Jul 2017 18:30:32 +0200

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.