Please hide Start Center and Math

Bug #1696250 reported by Jeremy Bicha
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libreoffice (Debian)
Won't Fix
Unknown
libreoffice (Ubuntu)
Medium
Heather Ellsworth

Bug Description

From GNOME Shell, open the Applications Overview and click the Show Applications button to see the list of apps. Currently, LibreOffice takes up a whole row on my computer (6 icons) which seems excessive with GNOME Shell's current design.

I suggest that we do like Fedora and hide the LibreOffice Start Center and LibreOffice Math.

Instead of opening a Start Center, it makes more sense for a user to just open the app they want directly.

I don't think users want to create a mathematical formula just to create one, but to insert into a document so it makes more sense to start Math from within the other app.

Revision history for this message
Olivier Tilloy (osomon) wrote :

That can be achieved by changing the NoDisplay key to true in the corresponding desktop files (/usr/share/applications/libreoffice-*.desktop).

However, doing that will completely and always hide those applications from the applications view, so they will effectively become very hard to find for a user.

Consider this: I might want math and startcenter to be hidden by default when I search "libreo" in the applications view, because they are less likely to be useful to the majority of users, but if I search "math" I would expect the app to be found. With NoDisplay=true it won't.

@Jeremy: are you aware of another mechanism to hide some apps from the applications list by default, without making them completely invisible to the user?

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Why would you want to run Math separately?

> @Jeremy: are you aware of another mechanism to hide some apps from the applications list by default, without making them completely invisible to the user?

No.

Well, I mean there is a bit of a hack. You could move the .desktop and appstream metadata for LibreOffice Math into a separate binary package installable from the GNOME Software app. LO Math would still technically be installed because it's needed by the core LO apps Ubuntu ships but without a .desktop it is not very visible. This is similar to how Fedora ships Epiphany by default (discussed in LP: #1689317 ). Ping me on chat if you want more explanation of how that works.

But once again, I'm not sure people care that much to want to run LO Math separately instead of from inside LO Writer or whatever app they want the formula in.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

If you want custom search results, you could write a GNOME Shell search provider. I think it's overkill here though.

https://developer.gnome.org/SearchProvider/

Revision history for this message
Olivier Tilloy (osomon) wrote :

> Why would you want to run Math separately?

I personally wouldn't, but it might be a valid use case for some users.
It feels a bit harsh to be hiding the application from them.

> You could move the .desktop and appstream metadata for LibreOffice Math
> into a separate binary package installable from the GNOME Software app.

If I understand correctly, the intent is that users who really want Math will go and install that package from the GNOME Software app, thinking that they are installing the actual application when in fact they are merely adding a desktop file for the already installed app?
That sounds like a clumsy hack, not a real solution (and additional maintenance).

> But once again, I'm not sure people care that much to want to run
> LO Math separately instead of from inside LO Writer or whatever app
> they want the formula in.

Ideally we would gather some stats on that kind of usage before making a decision. Given the potentially low impact though, I don't mind going the NoDisplay=true route and see how that goes for users.

> If you want custom search results, you could write a GNOME Shell
> search provider. I think it's overkill here though.

Definitely overkill here.

Revision history for this message
Olivier Tilloy (osomon) wrote :

For completeness: grouping all the libreoffice icons into an app folder¹ was considered, but dismissed as going against the upstream GNOME trend.

¹ https://wiki.gnome.org/HowDoI/AppFolders

Changed in libreoffice (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: New → Confirmed
importance: Undecided → Medium
Changed in libreoffice (Debian):
status: Unknown → New
Revision history for this message
Olivier Tilloy (osomon) wrote :

Given the discussion on the debian bug, I chose to implement this using "NotShowIn=GNOME;" for the startcenter and math desktop files.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Olivier Tilloy (osomon) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:6.0.1-0ubuntu3

---------------
libreoffice (1:6.0.1-0ubuntu3) bionic; urgency=medium

  [ Olivier Tilloy ]
  * debian/patches/uitest-skip-test_text_direction.patch: removed

  [ Rene Engelhard ]
  * debian/patches/orcus-0.13.3.diff: backport patches to fix build/tests
    against orcus 0.13.3

  [ Rico Tzschichholz ]
  * debian/patches/solenv-Update-gb_PackageInfo_emit_l10n_for_one_lang.patch:
    Update gb_PackageInfo_emit_l10n_for_one_lang to add cjk_*, ctl_* and
    ctlseqcheck_$LANG.xcd files to install list (LP: #1750335)
  * Fix libvisio and libqxp shlibs dependency (Thanks Rene)

 -- Olivier Tilloy <email address hidden> Fri, 23 Feb 2018 13:33:59 +0100

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Changed in libreoffice (Debian):
status: New → Fix Committed
Changed in libreoffice (Debian):
status: Fix Committed → Won't Fix
Revision history for this message
John W. Brown, Jr. (brownboyjohn) wrote :

This was not a "bug", but more so a preference. It makes more sense to have 1 icon that represents the entire suite than separate ones for each application IMO. Not a fan of the M$ way. This should have been put to some kind of vote first. Hoping we can reverse this. It's pretty annoying to have to undo just because Oliver didn't like it. A user can add as little or as much to their favorites as they like. Dealer's choice.

Revision history for this message
Olivier Tilloy (osomon) wrote :

This is not just my personal preference, this was requested by actual users.
Not everything can be put to some kind of vote first, or we'd have brexits all over the place. More seriously this is open to reconsideration if you can make a strong case for it (other than just « I prefer it the other way »). Maybe start a discussion on https://community.ubuntu.com/c/desktop and see if it gets traction?

Revision history for this message
Adolfo Jayme (fitojb) wrote :

The Yaru team didn’t create icons for Math because this bug caused them to miss it. Congratulations on being unhelpful.

Revision history for this message
Lei Zhao (leeijaw) wrote :

Genius! This is not a bug. I am very flabbergasted to find out there is a line of "NotShowIn=GNOME;" in the desktop file since I try to debug why the start center simply don't show up in the gnome app search results. When you edit multiple kinds of office files, the start center is extremely useful. It shows up a aggregated list of recently opened office files. To access the file through the methods you proposed, I have to click multiple times and don't have a top picture of recently edited files.

If start center is not useful, why have it in the first place? Why not remove it completely from the codebase?

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

The decision to hide the LO startcenter launcher was recently questioned in a thread at the ubuntu-devel-discuss mailing list:

https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2021-March/018966.html

I too would like that launcher become visible again. It's not only about the visual impression in the "Start Applications" view, but the technique for hiding the LO startcenter launcher prevents you from having it among the "Favorites" in the Dock. Myself was in the habit of replacing the Writer/Impress/Calc icons in the Dock with the startcenter one.

Also, as pointed out in comment #12 above, there are use cases where the LO startcenter plays a role on its own merits.

Debian didn't hide it, btw. While they hid Math, they chose to keep startcenter visible.

Please consider to drop hide-startcenter-desktop-file.patch.

Changed in libreoffice (Ubuntu):
status: Fix Released → Triaged
Revision history for this message
Heather Ellsworth (hellsworth) wrote :

After reading through everything, sounds like there are more folks that want these icons back than not. And I completely see the use case of having these icons so I've added this fix:

https://git.launchpad.net/~hellsworth/+git/libreoffice/commit/?h=bring-back-startcenter-math-icons-LP1696250&id=bc615536a4c460c885e5e0056bf6a667091a0b97

It will be cherry-picked and available in a future release.

Changed in libreoffice (Ubuntu):
assignee: Olivier Tilloy (osomon) → Heather Ellsworth (hellsworth)
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:7.1.2~rc2-0ubuntu2

---------------
libreoffice (1:7.1.2~rc2-0ubuntu2) hirsute; urgency=medium

  [ Heather Ellsworth ]
  * Re-enable startcenter and math application icons. (LP: #1696250)

 -- Rico Tzschichholz <email address hidden> Fri, 09 Apr 2021 16:05:03 +0200

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.