[Snap] Open/Save dialogue not easy-to-use

Bug #1665112 reported by Ads20000
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Low
Olivier Tilloy

Bug Description

In the Deb package, LibreOffice uses the Nautilus/Nautilus-style Open/Save/ dialogue with a clickable directory bar and all your bookmarks from Nautilus. In the Snap package, it has a text-based directory bar, doesn't use you Nautilus bookmarks and doesn't use the native theming.

Maybe it would be hard to integrate the Snap version of LibreOffice properly but this is still a usability bug and needs to be fixed, even if this has to be fixed on Snapcraft's end rather than the LibreOffice Snap's end.

Ads20000 (ads20000)
tags: added: snap xenial yakkety
Adolfo Jayme (fitojb)
Changed in libreoffice (Ubuntu):
importance: Undecided → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Revision history for this message
Olivier Tilloy (osomon) wrote :

Attaching a screenshot of the ugly dialogs currently used by the LO snap.

Revision history for this message
Olivier Tilloy (osomon) wrote :

The native dialogs were disabled in a patch that was being applied when building the snap. I’ve just testing removing that patch with my refactored version of the snap (that uses the desktop-gtk3 launcher), and the native dialogs just work.

Changed in libreoffice (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon)
Changed in libreoffice (Ubuntu):
status: In Progress → Fix Committed
Olivier Tilloy (osomon)
Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Ads20000 (ads20000) wrote :

I don't think this is Fix Released. I don't have the Deb installed at the moment (and my Internet is too slow to download it within any reasonable length of time) but I thought the dialogue with the Deb packaged version was much easier to use (folder buttons to navigate, not a directory text field, links to common locations by default etc)

Revision history for this message
Ads20000 (ads20000) wrote :

The screenshot if from the snap and it is LibreOffice 5.3.4.2 (21)

Revision history for this message
Olivier Tilloy (osomon) wrote :

@Ads20000: I'm not seeing that with the libreoffice snap. Tested on artful and zesty, attaching a screenshot of the open dialog I'm seeing in zesty.

Revision history for this message
Olivier Tilloy (osomon) wrote :

Also tested on xenial (in a VM) and same result, I'm getting the standard open dialog with folder buttons to navigate and links to common locations.

Revision history for this message
Rico Tzschichholz (ricotz) wrote :

Make sure *not* to use the internal Libreoffice Open/Save dialogues boxes.

Revision history for this message
Ads20000 (ads20000) wrote :

Thanks Rico! I don't change those options though, seems like on a fresh 5.3.4.2-snap1 install the options are set correctly but on upgrade from a previous version the options are not (I've got a fresh install on a new laptop and an upgraded install from my old laptop so I can see this is the case). Is there any way to do something to fix the bug for people updating from previous releases? Can you somehow pass a variable just for those updating to 5.3.4.2-snap1 so that the issue is fixed for them? Is this even possible with snappy? Ideally we don't want people running into this bug (I don't know how many got 5.3.4.2-snap1 by updating but all those people are probably affected by this bug, though by now they've probably all updated so I don't know if we can fix the bug for them...)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers