Error with command "apt-get update" when using versioned "Provides:" (apt is too old to support that case)

Bug #1662227 reported by Carlos Estrada on 2017-02-06
274
This bug affects 59 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

I'm getting this error every time I do "apt-get update"

Ign http://ni.archive.ubuntu.com trusty/multiverse Translation-en_US
Ign http://ni.archive.ubuntu.com trusty/restricted Translation-en_US
Ign http://ni.archive.ubuntu.com trusty/universe Translation-en_US
Reading package lists... Done
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
...
...
...
...
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: You may want to run apt-get update to correct these problems

This error started to show after I upgraded LibreOffice form 5.2 to 5.3 with the LibreOffice PPA: ppa:libreoffice/ppa.

The thing is that everything is working fine. I can update/upgrade the system, I can install packages, delete packages, etc. The problem is just with the error.

I tried: "apt-get autoclean". "apt-get clean", "apt-get autoremove", apt-get install -f", and a lot of other things and nothing removes that ugly error.

If I remove all PPA packages and remove the PPA itself the error goes away.

This has been reported in askubuntu.com:

http://askubuntu.com/questions/880447/ubuntu-14-04-error-with-apt-get-update-w-ignoring-provides-line-with-depcom

http://askubuntu.com/questions/879497/apt-spewing-warnings-after-libreoffice-update

Help please. Thank you.

Carlos Estrada (chemnic) on 2017-02-06
tags: added: apt ppa
affects: juju → ubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Stefano Ghignone (sghignone) wrote :

getting same error-

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty

$ apt-cache policy libreoffice
libreoffice:
  Installed: 1:5.3.0~rc3-0ubuntu1~trusty1.1
  Candidate: 1:5.3.0~rc3-0ubuntu1~trusty1.1
  Version table:
 *** 1:5.3.0~rc3-0ubuntu1~trusty1.1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     1:4.2.8-0ubuntu4 0
        500 http://it.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
     1:4.2.3~rc3-0ubuntu2 0
        500 http://it.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

Martin Wildam (mwildam) wrote :

I also had a partial upgrade warning using the graphical software updater.

dino99 (9d9) wrote :

Go to the ppa archive, and you can see yourself that 'l10n' is only generated for 'en'
As your language is not 'en' you indeed get the error. Either switch your system to 'en' or simply ignore that cosmetic problem (its only a ppa, not a genuine ubuntu archive)

Changed in ubuntu:
status: Confirmed → Incomplete
Carlos Estrada (chemnic) wrote :

$ locale
LANG=en_US.UTF-8
LANGUAGE=en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=es_NI.UTF-8
LC_TIME=es_NI.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=es_NI.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=es_NI.UTF-8
LC_NAME=es_NI.UTF-8
LC_ADDRESS=es_NI.UTF-8
LC_TELEPHONE=es_NI.UTF-8
LC_MEASUREMENT=es_NI.UTF-8
LC_IDENTIFICATION=es_NI.UTF-8
LC_ALL=

The system language is "en".

When using the Software Updater it displays an error after it updates the repositories. So, it's more than cosmetic.

Anyway, this was intended for the maintainers of the PPA. Maybe this is not the place to report this bug?

Roberto Costa (braselectron) wrote :

I have the same problem and my locale is LANG=en_US.UTF-8 / LANGUAGE=en_US.

My system:
Ubuntu 14.04.5 LTS 32bits
Kernel~3.13.0-108-generic i686

libreoffice 1:5.3.0~rc3-0 ubuntu1~trusty i386

Changed in ubuntu:
status: Incomplete → Fix Released
Roberto Costa (braselectron) wrote :

I believe the status is wrong. I could not find the fix.

Same for me - I also have system language set to english but in
LibreOffice I have the german language pack installed also.
I wonder why this problem suddenly occurs. And I don't understand why
it mentions libreoffice-l10n where I only have packages with
additional language abbrevation suffix libreoffice-l10n-<language>.
... But I am not a package maintainer so I am probably missing some
basic knowledge here.

My locale:
LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=de_AT.UTF-8
LC_TIME=de_AT.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=de_AT.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=de_AT.UTF-8
LC_NAME=de_AT.UTF-8
LC_ADDRESS=de_AT.UTF-8
LC_TELEPHONE=de_AT.UTF-8
LC_MEASUREMENT=de_AT.UTF-8
LC_IDENTIFICATION=de_AT.UTF-8
LC_ALL=

Best regards, Martin.

axel (axel334) wrote :

Still not fixed for 14.04

3.13.0-108-generic #155-Ubuntu SMP Wed Jan 11 16:58:52 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Carlos Estrada (chemnic) wrote :

There is no released fix.

Changed in ubuntu:
status: Fix Released → Confirmed
Stan Williams (stanwmusic) wrote :

+1 Still getting the warnings

I confirm, that the bug is not still been fixed for Ubuntu 14.04.5.
Martin Wildam, the advised method (sudo apt-get install -f) doesn't help.

Did you try disabling the ppa and fixing the old version before
retrying to update?
Martin Wildam

http://martin.wildam.org/

On Fri, Mar 24, 2017 at 10:02 AM, Vitaliy Yeresko
<email address hidden> wrote:
> I confirm, that the bug is not still been fixed for Ubuntu 14.04.5.
> Martin Wildam, the advised method (sudo apt-get install -f) doesn't help.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1662227
>
> Title:
> Error with command "apt-get update" when using libreoffice PPA
>
> Status in Ubuntu:
> Confirmed
>
> Bug description:
> I'm getting this error every time I do "apt-get update"
>
> Ign http://ni.archive.ubuntu.com trusty/multiverse Translation-en_US
> Ign http://ni.archive.ubuntu.com trusty/restricted Translation-en_US
> Ign http://ni.archive.ubuntu.com trusty/universe Translation-en_US
> Reading package lists... Done
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> ...
> ...
> ...
> ...
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: You may want to run apt-get update to correct these problems
>
> This error started to show after I upgraded LibreOffice form 5.2 to
> 5.3 with the LibreOffice PPA: ppa:libreoffice/ppa.
>
> The thing is that everything is working fine. I can update/upgrade the
> system, I can install packages, delete packages, etc. The problem is
> just with the error.
>
> I tried: "apt-get autoclean". "apt-get clean", "apt-get autoremove",
> apt-get install -f", and a lot of other things and nothing removes
> that ugly error.
>
> If I remove all PPA packages and remove the PPA itself the error goes
> away.
>
> This has been reported in askubuntu.com:
>
>
> http://askubuntu.com/questions/880447/ubuntu-14-04-error-with-apt-get-update-w-ignoring-provides-line-with-depcom
>
> http://askubuntu.com/questions/879497/apt-spewing-warnings-after-
> libreoffice-update
>
>
> Help please. Thank you.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+bug/1662227/+subscriptions

After ppa disabling and running "sudo apt-get update" the notification "Ignoring Provides line with DepCompareOp for package libreoffice-l10n" didn't disapire. The diffirence is that after theese actions this notifications displays only one time (one string).
I think, if i disable ppa and donwgrade LibreOffice to the version 5.2, there will be no notifications. But I want to use the latest version of LibreOffice and to get updates from ppa. We cannot say, that the problem is solved, if we have enabled ppa and installed LibreOffice 5.3 and we still get these notifications.

Download full text (3.3 KiB)

Uninstall the libreoffice-l10n then reactivate the repository and try
updating and only then do reinstall the libreoffice-l10n. I think to
remember, that I did it that way. However, since then I already go
another LibreOffice-Update not showing up with that error any more.
Martin Wildam

http://martin.wildam.org/

On Fri, Mar 24, 2017 at 12:13 PM, Vitaliy Yeresko
<email address hidden> wrote:
> After ppa disabling and running "sudo apt-get update" the notification "Ignoring Provides line with DepCompareOp for package libreoffice-l10n" didn't disapire. The diffirence is that after theese actions this notifications displays only one time (one string).
> I think, if i disable ppa and donwgrade LibreOffice to the version 5.2, there will be no notifications. But I want to use the latest version of LibreOffice and to get updates from ppa. We cannot say, that the problem is solved, if we have enabled ppa and installed LibreOffice 5.3 and we still get these notifications.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1662227
>
> Title:
> Error with command "apt-get update" when using libreoffice PPA
>
> Status in Ubuntu:
> Confirmed
>
> Bug description:
> I'm getting this error every time I do "apt-get update"
>
> Ign http://ni.archive.ubuntu.com trusty/multiverse Translation-en_US
> Ign http://ni.archive.ubuntu.com trusty/restricted Translation-en_US
> Ign http://ni.archive.ubuntu.com trusty/universe Translation-en_US
> Reading package lists... Done
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> ...
> ...
> ...
> ...
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
> W: You may want to run apt-get update to correct these problems
>
> This error started to show after I upgraded LibreOffice form 5.2 to
> 5.3 with the LibreOffice PPA: ppa:libreoffice/ppa.
>
> The thing is that everything is working fine. I can update/upgrade the
> system, I can install packages, delete packages, etc. The problem is
> just with the error.
>
> I tried: "apt-get autoclean". "apt-get clean", "apt-get autoremove",
> apt-get install -f", and a lot of other things and nothing removes
> that ugly error.
>
> If I remove all PPA packages and remove the PPA itself the error goes
> away.
>
> This has been reported in askubuntu.com:
>
>
> http://askubuntu.com/questions/880447/ubuntu-14-04-error-with-apt-get-update-w-ignoring-provides-line-with-depcom
>
> http://askubuntu.com/questions...

Read more...

My system didn't have any libreoffice-l10n packages installed and I also get these errors. I'd tried the suggestions above and none worked so tried the following:-

~$ sudo apt-get install libreoffice-l10n
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libreoffice-l10n is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libreoffice-l10n' has no installation candidate

This implies to me that there is an installed package referring to libreoffice-l10n so tried installing one:-

~$ sudo apt-get install libreoffice-l10n-en-gb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  hunspell-dictionary-en-gb myspell-dictionary-en-gb hyphen-en-gb
  libreoffice-grammarcheck-en-gb libreoffice-help-en-gb
The following NEW packages will be installed
  libreoffice-l10n-en-gb
0 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade.
Need to get 484 kB of archives.
....... All installed fine and check:-

~$ dpkg -l libreoffice-l10n-en-gb
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii libreoffice-l1 1:5.3.1-0ubu all office productivity suite -- Engl

~$ sudo apt-get update
.........................
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
....

Seems that there's a libreoffice package explicitly looking for libreoffice-l10n rather than libreoffice-l10n-xx-xx or should not look for one at all as there is no requirement to have one on your system.

Is there a way to figure out which existing package is looking for libreoffice-l10n?

Thanks, Nick

Hi,
you are right - I checked situation on my system. Interestingly back
then I also had the errors using GUI like Software updater or synaptic
to install the updates. Looks like I also only removed the
libreoffice-l10n package and installed libreoffice-l10n-en-gb and
libreoffice-l10n-de instead - or if I remember right, those were
already installed anyway.

A sudo apt-get update on the commandline still brings up the same
warnings also for me.

So frankly, in the GUI I do not get warnings any more, but on the
commandline I do (or I did overlook them somehow in the GUI).

Best regards, Martin.

Yes, an error presents only in command line. It disappears only then the repository is deactivated and the package libreoffice-l10n-xx is not installed. After this package installing we'll have an error again. One string with an error - seems it's because only one package libreoffice-l10n-xx will be installed. And after activating the repository we'll get many strings with the same error, `cause there are many versions of libreoffice-l10n-xx for different languages in repository.

This whole thing happens because the libreoffice 5.3 packages use versioned "Provides:", but apt in Ubuntu 14.04 is too old and does not support these yet.

According to the changelog, "versioned provides" where added in apt 1.0.7, but Ubuntu 14.04 ships with apt 1.0.1.

To solve this issue, the libreoffice packages for Trusty must either stop using versioned provides, or apt in Trusty must be updated.

I have successfully built apt 1.0.10.2 (taken from http://snapshot.debian.org/package/apt/1.0.10.2/) for Ubuntu 14.04 and the problem is gone!

rich painter (painterengr) wrote :

I'm getting the very same problem in Ubuntu 14.04.1 LTS 64 bit.
I still get it when I uninstall every libreoffice component.
I have tried all the suggested fixes except removing the repo...
How about a solution?

Vitaliy Yeresko (vint1988) wrote :

If You've fully removed libreoffice, disabling the repository will solve the problem for You.

As long as any package with a versioned provides is in apt's database, either because it is installed or because it's part of an enabled repository, you get these warnings.
So either install a newer apt or disable the repository and run apt-get update twice.

They're still only warnings though.

dino99 (9d9) on 2017-04-01
summary: - Error with command "apt-get update" when using libreoffice PPA
+ Error with command "apt-get update" when using versioned "Provides:"
+ (apt is too old to support that case)
tags: added: upgrade-software-version
Julian Andres Klode (juliank) wrote :

Old APT and dpkg releases, and associated tools, do not support versioned provides.

Changed in apt (Ubuntu):
status: New → Invalid
Changed in ubuntu:
status: Confirmed → Invalid
Jeremy Bicha (jbicha) on 2017-04-01
no longer affects: ubuntu
affects: apt (Ubuntu) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: Invalid → Triaged
Rico Tzschichholz (ricotz) wrote :

This should be fixed with the upcoming 5.3.2~rc2 packages from https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-prereleases/+packages

Vitaliy Yeresko (vint1988) wrote :

All libreoffice conponents have successfully updated to 5.3.2~rc2 from ppa:libreoffice/ppa. All components except libreoffice-l10n-xx... A log is in an attachment. I have to notice that libreoffice-core 5.3.2~rc2 and libreoffice-common 5.3.2~rc2 are installed.

Currently using the GUI software updater I get a package dependencies
cannot be resolved error and the updater crashes completely with the
following message:
update-manager crashed with libreoffice-common in _show_transaction():
Depends: libreoffice-style but is a virtual package.

On commandline with apt-get upgrade I get this:
The following packages have been kept back:
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core
  libreoffice-base-drivers libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk2
  libreoffice-gtk3 libreoffice-help-de libreoffice-help-en-gb
  libreoffice-help-en-us libreoffice-impress libreoffice-java-common
  libreoffice-l10n-de libreoffice-l10n-en-gb libreoffice-math
  libreoffice-ogltrans libreoffice-pdfimport libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-sdbc-hsqldb libreoffice-style-breeze libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer python3-uno

Using:
Ubuntu 14.04.5 LTS
Kernel: 4.4.0-71-generic #92~14.04.1-Ubuntu SMP Fri Mar 24 15:22:50 UTC 2017

Best regards, Martin.

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
pointer (marnyh) wrote :

I have almost the same during libreoffice upgrade from 1:5.3.1-0ubuntu1~trusty0 to 1:5.3.2~rc2-0ubuntu1~trusty1:
Currently using the GUI software updater I get a package dependencies
cannot be resolved error and the updater crashes completely with the
following messages:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/defer/__init__.py", line 483, in _inline_callbacks
    result = gen.throw(excep)
  File "/usr/lib/python3/dist-packages/UpdateManager/backend/InstallBackendAptdaemon.py", line 92, in commit
    _("Installing updates…"), True)
  File "/usr/lib/python3/dist-packages/defer/__init__.py", line 483, in _inline_callbacks
    result = gen.throw(excep)
  File "/usr/lib/python3/dist-packages/UpdateManager/backend/InstallBackendAptdaemon.py", line 159, in _show_transaction
    yield trans.run()
aptdaemon.errors.TransactionFailed: Transaction failed: package dependencies can not be resolved
libreoffice-common: Depends: libreoffice-style but is a virtual package.

Using:
Ubuntu 14.04.5 LTS
Kernel: 3.13.0-116-generic #163-Ubuntu SMP Fri Mar 31 14:13:22 UTC 2017 x86_64

Thank you, Sergey

Amr Ibrahim (amribrahim1987) wrote :

Me too. I can't upgrade to 5.3.2 in Trusty. The crash report of update-manager is attached.

Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python3/dist-packages/defer/__init__.py", line 483, in _inline_callbacks
     result = gen.throw(excep)
   File "/usr/lib/python3/dist-packages/UpdateManager/backend/InstallBackendAptdaemon.py", line 92, in commit
     _("Installing updates…"), True)
   File "/usr/lib/python3/dist-packages/defer/__init__.py", line 483, in _inline_callbacks
     result = gen.throw(excep)
   File "/usr/lib/python3/dist-packages/UpdateManager/backend/InstallBackendAptdaemon.py", line 159, in _show_transaction
     yield trans.run()
 aptdaemon.errors.TransactionFailed: Transaction failed: Package dependencies cannot be resolved
  The following packages have unmet dependencies:

 libreoffice-common: Depends: libreoffice-style but it is a virtual package

Using:

Ubuntu 14.04.5 LTS x86_64
Kernel: 3.13.0-116-generic

---

Problem:

LibreOffice 5.3.2.2 (1:5.3.2~rc2-0ubuntu1~trusty1)

1. PPA package libreoffice-common
DEBIAN/control -> Conflicts: ..., libreoffice-l10n-5.2, ...

2. PPA package libreoffice-l10n-ru
DEBIAN/control -> Provides: libreoffice-l10n-5.2

3. PPA package libreoffice-help-ru
DEBIAN/control -> Provides: libreoffice-help-5.2

May be -ru or -de or -it etc.

"Transaction failed: Package dependencies cannot be resolved"
The update to 5.3.2.2 (1:5.3.2~rc2-0ubuntu1~trusty1) is interrupted.

---

My temporary solution (example for -ru):

1. my-libreoffice-langpack-ru-reinstall.sh:

#!/bin/bash

sudo apt-get purge libreoffice-help-ru libreoffice-l10n-ru
sudo apt-get update
sudo apt-get upgrade

mkdir /var/tmp/my-libreoffice-l10n-ru
cd /var/tmp/my-libreoffice-l10n-ru
apt-get download libreoffice-l10n-ru
dpkg --extract *.deb .
dpkg --control *.deb .
sed -i 's/libreoffice-l10n-5.2/libreoffice-l10n-5.3/g' control
fakeroot tar czf data.tar.gz usr
fakeroot tar czf control.tar.gz control md5sums
echo 2.0 > debian-binary
ar -r my-libreoffice-l10n-ru_1%3a5.3.2~rc2-0ubuntu1~trusty1_all.deb debian-binary control.tar.gz data.tar.gz
sudo dpkg -i my-libreoffice-l10n-ru_1%3a5.3.2~rc2-0ubuntu1~trusty1_all.deb

mkdir /var/tmp/my-libreoffice-help-ru
cd /var/tmp/my-libreoffice-help-ru
apt-get download libreoffice-help-ru
dpkg --extract *.deb .
dpkg --control *.deb .
sed -i 's/libreoffice-help-5.2/libreoffice-help-5.3/g' control
fakeroot tar czf data.tar.gz usr
fakeroot tar czf control.tar.gz control md5sums
echo 2.0 > debian-binary
ar -r my-libreoffice-help-ru_1%3a5.3.2~rc2-0ubuntu1~trusty1_all.deb debian-binary control.tar.gz data.tar.gz
sudo dpkg -i my-libreoffice-help-ru_1%3a5.3.2~rc2-0ubuntu1~trusty1_all.deb

2. my-libreoffice-langpack-ru-list.sh:

#!/bin/bash

sudo sed -i 's/: libreoffice-l10n-5.2/: libreoffice-l10n-5.3/g' /var/lib/apt/lists/ppa.launchpad.net_libreoffice_ppa_ubuntu_dists_trusty_main_binary-amd64_Packages
sudo sed -i 's/: libreoffice-help-5.2/: libreoffice-help-5.3/g' /var/lib/apt/lists/ppa.launchpad.net_libreoffice_ppa_ubuntu_dists_trusty_main_binary-amd64_Packages

---

Alas, after each command 'apt-get update' run my-libreoffice-langpack-ru-list.sh again.
Not yet fixed in ppa.

pointer (marnyh) wrote :

I've successfully upgraded libreoffice from 1:5.3.1-0ubuntu1~trusty0 to 1:5.3.2~rc2-0ubuntu1~trusty1 via Synaptic Package Manager.
Please try, no system changes required.(except install of "synaptic"-package)
Mark for upgrade "libreoffice"-package, other packages will be marked for upgrade automatically.
Sergey

Vitaliy Yeresko (vint1988) wrote :

Sergey, please check what version of libreoffice-l10n do You have now? I marked in Synaptic package libreoffice for upgrade and libreoffice-l10n wasn't automatically marked for upgrade.

pointer (marnyh) wrote :

Vitaliy,
You're right, this package was't updated
This package has unresolved dependencies in my system:
-----------------
LANG=C apt-cache policy libreoffice-l10n-ru
libreoffice-l10n-ru:
  Installed: 1:5.3.1-0ubuntu1~trusty0
  Candidate: 1:5.3.2~rc2-0ubuntu1~trusty1
  Version table:
     1:5.3.2~rc2-0ubuntu1~trusty1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ trusty/main amd64 Packages
 *** 1:5.3.1-0ubuntu1~trusty0 0
        100 /var/lib/dpkg/status
-----------------
LANG=C sudo apt-get install libreoffice-l10n-ru
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libreoffice-l10n-ru : Depends: libreoffice-common (>= 1:5.3.2~rc2-0ubuntu1~trusty1) but it is not going to be installed
                       Recommends: libreoffice-core (> 1:5.3.2~rc2) but it is not going to be installed or
                                   language-support-translations-ru but it is not installable
E: Unable to correct problems, you have held broken packages.
-----------------
LANG=C sudo apt-get install language-support-translations-ru
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package language-support-translations-ru is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'language-support-translations-ru' has no installation candidate
-----------------

Amr Ibrahim (amribrahim1987) wrote :

The same. 'apt full-upgrade' had to remove these two packages to be able to upgrade:
libreoffice-help-en-gb
libreoffice-l10n-en-gb

ajkain (ajkain) wrote :

This is my fix on Ubuntu 14.04.5 LTS x86_64 (kernel 3.13.0-116-generic).

script "fix-libreoffice.sh":

#!/bin/bash

mkdir /tmp/fix
cd /tmp/fix
apt-get download libreoffice-l10n-ru # <<< YOUR LANGUAGE PACKAGE
DEBNAME=$(basename $(ls -1|head -n1) .deb)
dpkg-deb -x $DEBNAME.deb $DEBNAME/
dpkg-deb --control $DEBNAME.deb $DEBNAME/DEBIAN
sed -i 's/libreoffice-l10n-5.2/libreoffice-l10n-5.3/g' $DEBNAME/DEBIAN/control
sed -i 's/\(Version:.*\)/\1-fixed/' $DEBNAME/DEBIAN/control
dpkg -b $DEBNAME ${DEBNAME}_fixed.deb
dpkg -i ${DEBNAME}_fixed.deb

Vitaliy Yeresko (vint1988) wrote :

ajkain, it seems Your fix works, thanks a lot!

pointer (marnyh) wrote :

ajkain, thank you!
your fix works for me too

Changed in libreoffice (Ubuntu):
assignee: Björn Michaelsen (bjoern-michaelsen) → nobody
Amr Ibrahim (amribrahim1987) wrote :

This is fixed in the PPA now.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers