LibreOffice in Xubuntu should use Elementary as installation default not just live session

Bug #1569968 reported by Kev Bowring on 2016-04-13
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
libreoffice (Ubuntu)
Medium
Unassigned
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

(for previous slightly different issue see bug 1548647)

We appear to have Elementary default on the live session (screenshot livelibre)

Once installed and booting to installation - libreoffice is defaulting to Galaxy.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Apr 13 16:23:36 2016
InstallationDate: Installed on 2016-04-13 (0 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160413)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Kev Bowring (flocculant) wrote :
Kev Bowring (flocculant) wrote :
Kev Bowring (flocculant) wrote :
summary: - LibreOffice in Xubuntu should use Elementary as default
+ LibreOffice in Xubuntu should use Elementary as installation default not
+ just live session
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1569968

tags: added: iso-testing
Changed in libreoffice (Ubuntu):
status: New → Confirmed
Simon Steinbeiß (ochosi) wrote :

@sweetshark: Since you fixed that for the live-session, is there any way to fix the install as well?

Sean Davis (bluesabre) wrote :

This does not seem to be always reproducible. Using today's 32-bit Xubuntu image, I am seeing the Elementary theme as default both in the live session and after being installed.

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Kev Bowring (flocculant) wrote :

Alberto - why do you keep adding hundredcuts to xubuntu bugs and then doing nothing - all that happens is your project ends up screwing up the xubuntu tracker as they are never ever marked as anything but affecting.

In addition please do not mark the importance of our bugs - we've asked you not to do so previously.

Does the xubuntu make sure to install libreoffice-style-elementary? If not, that would need to be fixed first (not in LibreOffice packaging), but in the Xubuntu installer. After all, the description says the Live Session does use elementary just well, so the same should be possible _without_ patching LibreOffice (unless the Live Session does evil things like create a pre-populated non-default profile for the user).

Sean Davis (bluesabre) wrote :

We (Xubuntu) are installing the libreoffice-style-elementary package in both live and desktop. Sometimes, the default ends up being Galaxy, other times Elementary, it really does seem to be random.

I've uploaded a new xubuntu-default-settings that does include a default profile (only setting the default theme to elementary). There are no other defaults in there so it should not change the default experience. This should likely be a sufficient enough fix to close this bug report once verified.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 16.04.6

---------------
xubuntu-default-settings (16.04.6) xenial; urgency=medium

  * etc/skel/.config/libreoffice/4/user/registrymodifications.xcu
    - Set elementary as the default icon theme (LP: #1569968)

 -- Sean Davis <email address hidden> Sun, 17 Apr 2016 08:01:57 -0400

Changed in xubuntu-default-settings (Ubuntu):
status: New → Fix Released

Anything needed from LibreOffice here still?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints