BlendFrameCache isnt cleared before de-initing vital VCL parts

Bug #1560328 reported by Swierzewski on 2016-03-22
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Committed
Undecided
Unassigned
libreoffice (Ubuntu)
High
Björn Michaelsen
Xenial
Undecided
Unassigned
Yakkety
High
Björn Michaelsen

Bug Description

It did pop up after using office.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: libreoffice-core 1:5.1.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-14.30-generic 4.4.5
Uname: Linux 4.4.0-14-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Mar 22 06:39:37 2016
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationDate: Installed on 2016-03-20 (1 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160307)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin --writer --splash-pipe=5
ProcEnviron:
 LANGUAGE=fr_FR
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 OutputDevice::GetGraphics() const () from /usr/lib/libreoffice/program/libmergedlo.so
 OpenGLContext::getVCLContext(bool) () from /usr/lib/libreoffice/program/libmergedlo.so
 OpenGLContext::makeVCLCurrent() () from /usr/lib/libreoffice/program/libmergedlo.so
 ?? () from /usr/lib/libreoffice/program/libmergedlo.so
 ?? () from /usr/lib/libreoffice/program/libmergedlo.so
Title: soffice.bin crashed with SIGSEGV in OutputDevice::GetGraphics()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 OutputDevice::GetGraphics (this=0x0) at /build/libreoffice-_8jjLy/libreoffice-5.1.1/vcl/source/outdev/outdev.cxx:291
 OpenGLContext::getVCLContext (bMakeIfNecessary=bMakeIfNecessary@entry=true) at /build/libreoffice-_8jjLy/libreoffice-5.1.1/vcl/source/opengl/OpenGLContext.cxx:1465
 OpenGLContext::makeVCLCurrent () at /build/libreoffice-_8jjLy/libreoffice-5.1.1/vcl/source/opengl/OpenGLContext.cxx:1484
 OpenGLVCLContextZone::OpenGLVCLContextZone (this=<optimized out>) at /build/libreoffice-_8jjLy/libreoffice-5.1.1/vcl/source/opengl/OpenGLHelper.cxx:948
 ImplOpenGLTexture::Dispose (this=this@entry=0x544a7d0) at /build/libreoffice-_8jjLy/libreoffice-5.1.1/vcl/opengl/texture.cxx:164

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
importance: Medium → High

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

In vcl/source/app/svmain.cxx:519, mpBlendFrameCache is deleted, which causes various dtors to fire, some need a default window. The default window has already been disposed at vcl/sourcw/app/svmain.cxx:437 with: pSVData->mpDefaultWin.disposeAndClear(); -- so this blows up.

Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
summary: - soffice.bin crashed with SIGSEGV in OutputDevice::GetGraphics()
+ BlendFrameCache isnt cleared before de-initing vital VCL parts
Changed in df-libreoffice:
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
assignee: Björn Michaelsen (bjoern-michaelsen) → nobody
status: New → Fix Committed

Hello Swierzewski, or anyone else affected,

Accepted libreoffice into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice/1:5.1.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libreoffice (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of libreoffice from xenial-proposed was performed and bug 1586497 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1586497 (not this bug). Thanks!

tags: added: verification-failed

As per https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1586497/comments/2 remove verification-failed.
Hard to reproduce, no known reports of this one on 5.1.3 => setting this to verification-done.

tags: added: verification-done
removed: verification-failed
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.1.3-0ubuntu1

---------------
libreoffice (1:5.1.3-0ubuntu1) xenial; urgency=medium

  * new upstream bugfix release
  * fix crash with nullptr SdrObjList (LP: #1569500)
  * fix crash with ScCsvGrid living beyond VCL shutdown (LP: #1566050)
  * fix crash with non-empty BlendFrameCache in late VCL shutdown (LP: #1560328)

 -- Bjoern Michaelsen <email address hidden> Thu, 12 May 2016 11:35:38 +0200

Changed in libreoffice (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.1.3-0ubuntu4

---------------
libreoffice (1:5.1.3-0ubuntu4) yakkety; urgency=medium

  * use internal copy of mdds and orcus on yakkety for 5.1 series now

 -- Bjoern Michaelsen <email address hidden> Tue, 24 May 2016 14:25:58 +0200

Changed in libreoffice (Ubuntu Yakkety):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers