[MIR] ucpp for LibreOffice

Bug #1524638 reported by Samuel Mehrbrodt on 2015-12-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Björn Michaelsen
ucpp (Ubuntu)
Undecided
Unassigned

Bug Description

[Availability]
Package is currently in universe.

[Rationale]
While building LibreOffice with the gcc preprocessor, the sdk of the result fails to work properly. We need ucpp to properly allow the sdk to be used. Debian is using ucpp for LibreOffice too.

[Security]
this MIR request is the first issue filed against the package on Ubuntu ever.

[Quality assurance]
Excellent test suite upstream

[Dependencies]
ucpp binary depends only on libc6. ucpp source depends only on debhelper.

[Standards compliance]
Package at 3.9.3 -- maintained by Debian LibreOffice team

[Maintenance]
maintained by Debian LibreOffice team

[Background information]

Original bug report:
Ubuntu 15.10, LibreOffice 5.0.2.2 (no ppa)

Try compiling the following attachment using:

/usr/lib/libreoffice/sdk/bin/idlc XAbc.idl

You get the following errors:
Compiling: XAbc.idl
<command-line>:1 [62:62] : Statement can not be parsed: syntax error, unexpected $undefined
XAbc.idl:8 [3:3] : Statement can not be parsed: definitions
XAbc.idl:10 [2:2] : Statement can not be parsed: syntax error, unexpected '}', expecting $end
XAbc.idl:10 [3:3] : Statement can not be parsed: definitions
XAbc.idl:10 [5:5] : Statement can not be parsed: syntax error, unexpected '}', expecting $end
XAbc.idl:10 [6:6] : Statement can not be parsed: definitions
XAbc.idl:10 [8:8] : Statement can not be parsed: syntax error, unexpected '}', expecting $end
XAbc.idl:10 [9:9] : Statement can not be parsed: definitions
/usr/lib/libreoffice/sdk/bin/idlc.bin: detected 8 errors/usr/lib/libreoffice/sdk/bin/idlc.bin Version 1.1

Samuel Mehrbrodt (sam92) wrote :
description: updated
Changed in libreoffice (Ubuntu):
status: New → Invalid
Samuel Mehrbrodt (sam92) wrote :

> You receiving a syntax error isn't considered a software bug of LibreOffice in Ubuntu.

?
What else?

This is a problem in the libreoffice package in Ubuntu, not a general LibreOffice problem.

Changed in libreoffice (Ubuntu):
status: Invalid → Triaged
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

LibreOffice 5.1 is in xenial and uses ucpp now.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
summary: - idlc doesn't compile anything
+ [MIR] ucpp for LibreOffice
description: updated
Michael Terry (mterry) wrote :

Sure. Seems fine, small, and only used in builds. It has a bunch of compile warnings like "variable may be used uninitialized" but again, since this is only used in builds, such bugs are of lower importance.

But it does need a team bug subscriber for whomever is looking after this in Ubuntu.

Changed in ucpp (Ubuntu):
status: New → Incomplete

> But it does need a team bug subscriber for whomever is looking after this in Ubuntu.
Done, thus setting back to InProgress as comment #5 seems to be fine with it otherwise.

Changed in ucpp (Ubuntu):
status: Incomplete → In Progress
Michael Terry (mterry) on 2016-02-17
Changed in ucpp (Ubuntu):
status: In Progress → Fix Committed
Matthias Klose (doko) wrote :

Override component to main
ucpp 1.3.2-1 in xenial: universe/misc -> main
libucpp-dev 1.3.2-1 in xenial amd64: universe/libdevel/extra/100% -> main
libucpp-dev 1.3.2-1 in xenial arm64: universe/libdevel/extra/100% -> main
libucpp-dev 1.3.2-1 in xenial armhf: universe/libdevel/extra/100% -> main
libucpp-dev 1.3.2-1 in xenial i386: universe/libdevel/extra/100% -> main
libucpp-dev 1.3.2-1 in xenial powerpc: universe/libdevel/extra/100% -> main
libucpp-dev 1.3.2-1 in xenial ppc64el: universe/libdevel/extra/100% -> main
libucpp-dev 1.3.2-1 in xenial s390x: universe/libdevel/extra/100% -> main
ucpp 1.3.2-1 in xenial amd64: universe/interpreters/extra/100% -> main
ucpp 1.3.2-1 in xenial arm64: universe/interpreters/extra/100% -> main
ucpp 1.3.2-1 in xenial armhf: universe/interpreters/extra/100% -> main
ucpp 1.3.2-1 in xenial i386: universe/interpreters/extra/100% -> main
ucpp 1.3.2-1 in xenial powerpc: universe/interpreters/extra/100% -> main
ucpp 1.3.2-1 in xenial ppc64el: universe/interpreters/extra/100% -> main
ucpp 1.3.2-1 in xenial s390x: universe/interpreters/extra/100% -> main
15 publications overridden.

Changed in ucpp (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments