Change default Theme for LibreOffice to Breeze for Ubuntu 16.04

Bug #1506544 reported by Björn Michaelsen on 2015-10-15
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Wishlist
Björn Michaelsen
ubuntu-meta (Ubuntu)
Undecided
Björn Michaelsen

Bug Description

Breeze has a much more pleasing appearance and is better maintained than the human theme.

The “Human” theme is so named because it is derived from Humanity, an icon theme originally developed for Ubuntu as a derivation of the original elementary theme. Nowadays, this LibreOffice theme is unmaintained, highly incomplete, and visually obsolete.

The Shimmer Project (known for Xubuntu and the Numix GTK+ theme) is creating an updated icon theme, based on Human, but including the newest elementary icons as well as creating original new ones.

@Michael: I added you to the CC list because of a licensing question: Simon, one of the Shimmer Project developers, asked me if it is necessary to put together a list of the individual icons and their license (à la icon-themes/human/CopyrightsHuman). [1] Based on what I understand of [2], that would mean “attribution bloat”, right?

-----

[1]: https://github.com/shimmerproject/libreoffice-style-elementary/issues/1#issuecomment-117154479
[2]: https://wiki.documentfoundation.org/License_Policy

Sigh - if we can possibly avoid it - I'd -really- prefer to avoid having masses of copies of new licenses with un-necessary individual (or corporate) copyright claims in them. Then again - if you're going to do the work - its good to poke Andras with the changes to the license language you want.

Of course - crediting the authors of the icons is best done by people committing them to git and getting credited in our credit page - that's something we're enthusiastic about =)

Does that help ? either way upgrading Human sounds sensible to me if people want to work on that. Thanks !

Though the human theme isnt bundled by default with libreoffice, it is the default icon theme used for LO in Ubuntu and its flavours, except Kubuntu, so i'd assume it would be good to make sure that Canonical doesnt have an issue with this. I believe Ubuntu uses the human theme as its default icon theme for its unity desktop, so it maybe important to them to keep that consistency. CCing Bjoern for his thoughts.

During my work on tango, i have copied a few of human icons into tango that looked suitable, when tango was falling back on industrial or galaxy. Human should really be falling back on tango rather than industrial with the amount of improvements that are going into tango.

(In reply to Yousuf (Jay) Philips from comment #2)
> Though the human theme isnt bundled by default with libreoffice, it is the
> default icon theme used for LO in Ubuntu and its flavours, except Kubuntu,
> so i'd assume it would be good to make sure that Canonical doesnt have an
> issue with this.

Right. I would really not enjoy killing the Human theme, as likely it would just mean that I would need to carry it as a cumbersome vendor patch anyway, just creating lots of pointless work along the way.

What is the point/goal of this anyway? The human theme can be turned off by a configure switch and IIRC isnt even enabled by default. If the goal is to make Ubuntu ship a different default, this certainly isnt the way towards that goal (see above).

If you want a different default in Ubuntu, the way to go about that is filing a request on launchpad at Ubuntu and get that nodded of by Ubuntus design team.

(As a general note this bug doesnt seem to be too well scoped: it describes no clear goal and mixes too many things: removing themes, adding themes, changing defaults with the latter being off-topic here beyond TDF builds.)

@Björn: Honestly, Canonical’s design team is so embroiled in the phone project that they would ignore my bug report anyway.

I’m dropping the Human theme from this to make you more comfortable.

(In reply to Björn Michaelsen from comment #5)
> Done with:
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=2b383d19e716863134087fe83d0aa5ba156006bd

All of the icons are in elementary/src/... when they should be in elementary/...

Will these icons be available in daily master builds, as it would be good to test them and help the elementary team improve it. Would also be useful to have human in the daily builds as well to test against it for ubuntu, just like we have tango_testing, but these shouldnt be available in releases.

Would be good to optimize the size of the elementary zip file by removing duplicates from galaxy and likely tango and also to set its fallback icon theme.

(In reply to Yousuf (Jay) Philips from comment #6)
> All of the icons are in elementary/src/... when they should be in
> elementary/...

moved in 7949ca85c526f2f22367900b5213e8df806ce873.

> Will these icons be available in daily master builds, as it would be good to
> test them and help the elementary team improve it. Would also be useful to
> have human in the daily builds as well to test against it for ubuntu, just
> like we have tango_testing, but these shouldnt be available in releases.

Having them in the daily build is up to the tinderbox owners.

> Would be good to optimize the size of the elementary zip file by removing
> duplicates from galaxy and likely tango and also to set its fallback icon
> theme.

Yeah maybe, but thats not part of this bug. Lets not featurecreep the scope here ...

Changed in libreoffice (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Fix Released

Was reading through another bug report and it mentioned that icon themes have entries in officecfg/registry/schema/org/openoffice/Office/Common.xcs under 'SymbolStyle' and one wasnt added for elementary, so should this have been added as part of the integration?

(In reply to Yousuf (Jay) Philips from comment #8)
> Was reading through another bug report and it mentioned that icon themes
> have entries in officecfg/registry/schema/org/openoffice/Office/Common.xcs
> under 'SymbolStyle' and one wasnt added for elementary, so should this have
> been added as part of the integration?

Good question. It seems to work happily without that. The constraints on the config provide two possible benefits:
- having longer descriptions for the values -> but we dont seem to use those anywhere
- limiting to a known set of values

The second seems questionable with new themes popping up quite often (and initially out-of-tree), while I see no benefit of the first.

@Stephan: Given the above, how about killing the constraint in officecfg altogether now?

(In reply to Björn Michaelsen from comment #9)
> @Stephan: Given the above, how about killing the constraint in officecfg
> altogether now?

yes, done with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=5ab2bb87d9039e7c3f2dde87698df065967a731e> "Clean up documentation of SymbolStyle prop" (those constraints are not used anyway nowadays and effectively only serve as documentation for readers of the .xcs source files)

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.0.2-0ubuntu5

---------------
libreoffice (1:5.0.2-0ubuntu5) xenial; urgency=medium

  * No-change rebuild against libglew1.13.

 -- Steve Langasek <email address hidden> Thu, 12 Nov 2015 03:21:58 +0000

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released

Adding ubuntu-meta for switching libreoffice-style-human to libreoffice-style-breeze ...

Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

reopen in LibreOffice, patch got lost in bump to LibreOffice 5.1.x

Changed in libreoffice (Ubuntu):
status: Fix Released → In Progress

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c0da1080b61a1d51654fc34fdaeba373226065ff

lp#1506544 tdf#92458: default to breeze theme on unity desktops

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Simon Déziel (sdeziel) wrote :

I just noticed that the breeze theme is in universe while human is in main. Sounds like the opposite of what it should be.

$ apt-cache policy libreoffice-style-breeze libreoffice-style-human
libreoffice-style-breeze:
  Installed: 1:5.1.1~rc2-0ubuntu1
  Candidate: 1:5.1.1~rc2-0ubuntu1
  Version table:
 *** 1:5.1.1~rc2-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     1:5.1.0-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
libreoffice-style-human:
  Installed: (none)
  Candidate: 1:5.1.1~rc2-0ubuntu1
  Version table:
     1:5.1.1~rc2-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
     1:5.1.0-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

@Simon: Thanks for the hint, was stuck in xenial-proposed should be fixed RSN (thanks seb128).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:5.1.1~rc2-0ubuntu1

---------------
libreoffice (1:5.1.1~rc2-0ubuntu1) xenial; urgency=medium

  * new upstream rc
  * update patches, remove upstreamed ones
  * reenable unity-default-breeze, which wasnt reenabled on 5.1 yet (LP: #1506544)
  * update Ubuntu palette, add main colors to standard palette (LP: #753627)

 -- Bjoern Michaelsen <email address hidden> Mon, 29 Feb 2016 13:54:54 +0100

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released

Elementary is implemented but not used (if not used on the system). So the question is whether or not we make it the default for Gnome (proposal was done in patch 3/5 at https://gerrit.libreoffice.org/#/c/51959/3)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.