[upstream] EDITING: Background Color button from Table toolbar should change cell background instead of paragraph background

Bug #1485955 reported by Norbert on 2015-08-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Wishlist
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
   1. Launch LibreOffice Writer
   2. Insert table to the new document (Table -> Insert -> Table)
   3. Write some multirow text in table cells
   4. Try to change cell background:
      4.1. place cursor on desired cell
      4.2. select color from palette from "Background Color" drop-down (located on Table toolbar).
      4.3. click "Background Color" button on Table toolbar.

Expected results:
   background color of TABLE CELL (where cursor was) is changed to desired color.

Actual results:
   background color of TEXT PARAGRAPH (where cursor was) is changed to desired color.

Workaround:
   There is slow non-intuitive background - select whole cell, select color from palette from "Background Color" drop-down (located on Table toolbar), click "Background Color" button on Table toolbar.

Affected versions:
   LibreOffice 3.5.7.2 Build ID: 350m1(Build:2) = pre-installed Ubuntu 12.04.5 LTS version;
   LibreOffice 4.2.7.2 Build ID: 420m0(Build:2) = pre-installed Ubuntu 14.04.2 LTS version;
   LibreOffice 4.4.2.2 Build ID: 40m0(Build:2) = pre-installed Ubuntu 15.04 version.

Comment:
   I can't believe how this bug is possible. It is inherited from OO.org (I saw it on OO.org 3.2 in Ubuntu 10.04.4 LTS too).
   Microsoft Word 2003 and 2007 of course have normal behaviour with cell background.
   I attached pdf document with screenshots.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice 1:3.5.7-0ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-61.100~precise1-generic 3.13.11-ckt22
Uname: Linux 3.13.0-61-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.9
Architecture: amd64
Date: Tue Aug 18 11:45:50 2015
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MarkForUpload: True
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Steps:
1) Open Writer
2) Create a table
3) While in a cell, click on the background color icon in the table toolbar
4) It will not fill the cell background but the paragraph background

Tested in 3.3.0, 4.3.2 and master. This is quite confusing because the background color icon in calc fills the cell background and the background color icon even in the table toolbar in writer fills the paragraph background.

Hi Jay,

(In reply to comment #0)

> 3) While in a cell, click on the background color icon in the table toolbar

Isn't that the icon with 'ab', iow, bacjground color for text ?
One would indeed wish that that is an icon for the cell's background, that one currently can set by selecting a cell (or more) and then Table properties, tab Background..
So If this is true, this should be an enhancement for another icon on the toolbar :)
Ciao!
Cor

Hi Jay, for me this is neither a bug nor an enhancement:
- background of the paragraph --> just as you did
- background of the cell --> select the cell and click on the background color icon.
The background icon reacts depending on the mode your are, if you are in edit mode in the table, that will affect the paragraph, if you're in selection mode, that will affect the cell. Closing as works for me. Please reopen if you disagree :) Sophie

After both Cor and Sophie's comments, its hard decide which of these two options to go forward with for this issue.

1) that the default behaviour of the background icon should always be to set a cell's background color if inside a cell.

2) that a cell background color icon be created for the table toolbar and the formatting toolbar be used exclusively for paragraph background color.

One of the benefits i see with a dedicated cell background color icon is that it would work correctly whenever a table properties section comes in the sidebar.

(In reply to comment #2)

> - background of the cell --> select the cell and click on the background
> color icon.

For me it does not in master (where I initially tested ;) > new bug.

(In reply to comment #3)

> One of the benefits i see with a dedicated cell background color icon is
> that it would work correctly whenever a table properties section comes in
> the sidebar.

It's also not correct that the Icon shows 'ab' when it's supposed to do the cells background..

(In reply to comment #5)

> For me it does not in master (where I initially tested ;) > new bug.

   see bug 82555

Not sure what you mean by 'ab'. A screenshot would be good.

*** Bug 85540 has been marked as a duplicate of this bug. ***

(In reply to Jay Philips from comment #3)
> 1) that the default behaviour of the background icon should always be to set
> a cell's background color if inside a cell.

I think this is the best choice, as users in coming from calc are used to clicking the same background color icon to fill the cell.

See attachment 108550 for a Sample table demonstrating the issue

Steps to reproduce
1) In Writer create a table
2) In one Cell use Table Toolbar->Background->green
3) In another cell, Table->Table Properties->Background->green

Expected Results:
Cell from 2) looks like Cell from 3)

Actual Results:
Cell 2) is just partially filled with a white border

Created attachment 108560
picture with to be changed button and the one to stay

Hi Jay, *

> I think this is the best choice, as users in coming from calc are used to
> clicking the same background color icon to fill the cell.

Yes, that's by far best. Add since change paragraph background is still on the standard toolbar, people can choose.
I would suggest another icon too when changing the behaviour..

Setting this to enhancement.

(In reply to Luke from comment #14)
> This issue was addressed by
> https://issues.apache.org/ooo/show_bug.cgi?id=125163

Unfortunately, that is a different issue and is fixed in LO as it is fixed in 4.3 daily and master.

*** Bug 88806 has been marked as a duplicate of this bug. ***

Norbert (nrbrtx) wrote :

Created attachment 117994
Screenshots to demonstrate cell background bug

Dear all. I have the same problem. I was going to report new bug and went to this report. I reported a bug to Ubuntu Launchpad (https://bugs.launchpad.net/bugs/1485955) too.
Here are my bug report and screenshots.

> Steps to reproduce:
> 1. Launch LibreOffice Writer
> 2. Insert table to the new document (Table -> Insert -> Table)
> 3. Write some multirow text in table cells
> 4. Try to change cell background:
> 4.1. place cursor on desired cell
> 4.2. select color from palette from "Background Color" drop-down (located on Table toolbar).
> 4.3. click "Background Color" button on Table toolbar.
>
> Expected results:
> background color of TABLE CELL (where cursor was) is changed to desired color.
>
> Actual results:
> background color of TEXT PARAGRAPH (where cursor was) is changed to desired color.
>
> Workaround:
> There is slow non-intuitive background - select whole cell, select color from palette from "Background Color" drop-down (located on Table toolbar), click "Background Color" button on Table toolbar.
>
> Affected versions:
> LibreOffice 3.5.7.2 Build ID: 350m1(Build:2) = pre-installed Ubuntu 12.04.5 LTS version;
> LibreOffice 4.2.7.2 Build ID: 420m0(Build:2) = pre-installed Ubuntu 14.04.2 LTS version;
> LibreOffice 4.4.2.2 Build ID: 40m0(Build:2) = pre-installed Ubuntu 15.04 version.
>
> Comment:
> I can't believe how this bug is possible. It is inherited from OO.org (I saw it on OO.org 3.2 in Ubuntu 10.04.4 LTS too).
> Microsoft Word 2003 and 2007 of course have normal behaviour with cell background.
> I attached pdf document with screenshots.

Bug exists in LibO 5 too.

So please confirm this bug. For me it seems that priority should be Normal. This is a very often used functionality. Thank you!

Hi Norbert,

Thanks for posting that information here and for reminding that..

(In reply to Norbert X from comment #17)

> So please confirm this bug. For me it seems that priority should be Normal.

The bug is confirmed, proposed solution in comment #12. So I'll change settings accordingly.

Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Confirmed

(In reply to Cor Nouws from comment #12)
> Created attachment 108560 [details]
> picture with to be changed button and the one to stay

The 'ab' icon is limited to sifr.

> Yes, that's by far best. Add since change paragraph background is still on
> the standard toolbar, people can choose.
> I would suggest another icon too when changing the behaviour..

Paragraph background is no longer by default in the standard toolbar since 4.4. There isnt a need for a new icon as a new UNO command isnt being created, but the behaviour of the command is acting the same as when you select a cell as when you are inside a cell as using the button.

Bug exists in LibreOffice 5.0.1.2 (Ubuntu 12.04.5 with PPA, 1:5.0.1~rc2-0ubuntu1~precise1.1).

Migrating Whiteboard tags to Keywords: (needsDevEval, topicUI)
[NinjaEdit]

*** Bug 101090 has been marked as a duplicate of this bug. ***

This problem still exists in LO 5.3.3.2.

My opinion is, that it is very illogical and distracting that the background button in the table toolbar sets the paragraph background color and not the cell background color.

In this bug report in comment 2 from sophie I found in the first place the ability to resolve this issue: That I have to select the cell first and can then do the backgound operations with the button in the table toolbar. It should be enough, to put the cursor in a cell to change its background color.

I think in the table toolbar should be only functions which deal with table- and not with paragraph-settings.

In the breeze-icon-set there should be two different icons for the buttons for cell- and paragraph-background, too.

It would be useful too, if the functionality would be the same in "table-toolbar -> background color" and in the table-properties-dialogue->Background-settings.

I'm agree with you.
And I think is a pity, so long time and no fix for a simple think.
And it's the kind of think lot of people don't want LibreOffice because they don't understand the logical of some options or bugs.

@Maxim, @Gulsah: Either of you want to take this on?

There was few years long, I said it.
And there aren't the older one I mentioned.
There are lot of strange or messing think in LibreOffice :
- The background color for table is background paragraph (this bug)
- The warning for missing fonts
- The change background when you click on slide in Impress
- The field "Author" is missing in "File Proprieties"
- The Addon manager is bugged on LibreOffice for MacOS since long time
- The access to "Start menu" is not accessible when a file is open
- There is none feature for invisible update like in Firefox (I know there was a old GSOC)
- …

This also the excuses of the major part of users who don't want use LibreOffice in main office software.

(In reply to shunesburg69 from comment #26)

You forgot to mention that diagonal lines are not supported in table cells, in contrast with MS Word, which supports diagonal lines. Actually, I'll open a ticket about this, although I remember opening such a ticket for OpenOffice.

*** Bug 61866 has been marked as a duplicate of this bug. ***

Bug exists in

Version: 5.4.1.2
Build ID: 1:5.4.1~rc2-0ubuntu0.16.04.1~lo0
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2;
Locale: en-US (en_US.UTF-8); Calc: group

Ubuntu 16.04 LTS with PPA.

*** Bug 114315 has been marked as a duplicate of this bug. ***

Bug still exists in 6.0.0.3 on Windows 10 pro.

With all the interest and dupes this would make a good 100 paper cuts project.

Hi All,

To set a single table cell background the Table Properties dialog Background tab page can be used.

Currently the Background Color button will only set the cell background color for multi-selected table cells. For non multi-selected cells the paragraph background color is set for the cell with the cursor.

Here is a patch that makes the Background Color button set cell background color, not paragraph color, for the cell with the cursor:

https://gerrit.libreoffice.org/#/c/65195/

Testing and comments appreciated.

Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/47e9db9c8490167e265b17ae44bb790a160703b5%5E%21

tdf#82504 writer table cell background color SvxColorItem uno function

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Changed in df-libreoffice:
status: Confirmed → Fix Released

Created attachment 148529
Please see video, it is fixed?

Tested on 6.3 from 21.01.2019 but I think it is not fixed. Please see my video.

I tested 3 different options which a user could think is a background (as the tooltip says). But it is not a backgroud, just a paragraph background.

Version: 6.3.0.0.alpha0+
Build ID: 1e38d5b976dacd8b42b8330b4b9635a058ffe20b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-21_21:44:37
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

(In reply to BogdanB from comment #35)
> Created attachment 148529 [details]
> Please see video, it is fixed?

Well, it's not fixed. The first option should fill with colour the entire cell.

(In reply to BogdanB from comment #35)
> Created attachment 148529 [details]
> Please see video, it is fixed?
>
> Tested on 6.3 from 21.01.2019 but I think it is not fixed. Please see my
> video.
>
> I tested 3 different options which a user could think is a background (as
> the tooltip says). But it is not a backgroud, just a paragraph background.
>
> Version: 6.3.0.0.alpha0+
> Build ID: 1e38d5b976dacd8b42b8330b4b9635a058ffe20b
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2019-01-21_21:44:37
> Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
> Calc: threaded

Hmm, looks partially fixed.. Fine with the Table toolbar, but not working in tabbed mode.

Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win;
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

"ab" button in standard layout is changeing the background indeed, the same as contextual menu.

But I wait for the tabed toolbar to be fixed to mark this as fixed...

Changed in df-libreoffice:
status: Fix Released → Confirmed

Hello All,

From Jay's original post:

Step 3: While in a cell, click on the background color icon in the table toolbar

IMHO, since this bug report is specific to the background color icon in the table toolbar I believe the status of this bug report should be changed to Fixed and that other related bugs should be opened in new bug reports.

Right, one report per issue. Please someone create new reports and mention them in a comment.

Changed in df-libreoffice:
status: Confirmed → Fix Released
Changed in libreoffice (Ubuntu):
status: New → Fix Committed

Upstream fix is scheduled for 6.3.0 (Week 32)

Changed in libreoffice (Ubuntu):
status: Fix Committed → In Progress
Changed in libreoffice (Ubuntu):
status: In Progress → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.