LibreOffice 4.4 (PPA): Extension can't be installed: Message: com.sun.star.uno.RuntimeException) "unknown error!"

Bug #1419836 reported by cpina on 2015-02-09
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

Hello,

Both Mendeley and Zotero LibreOffice plugins are having problems with LibreOffice 4.4:
Mendeley:
http://support.mendeley.com/customer/portal/questions/11325906-mendeley-plugin-not-working-in-libreoffice-4-4-

Zotero, for example:
https://forums.zotero.org/discussion/46297/
(there is a comment saying "solved" but I think that the person reverted to 4.3 or used upstream)

(I've seen some other plugin with the same error message in LibreOffice 4.4, not sure if it was the PPA one or not)

Disclaimer: I work for Mendeley, but both plugins are very similar (Mendeley one is a fork from Zotero one in 2008 before i joined and they use the same technologies and approach: Python-uno for communication and then LibreOffice Basic to update the plugin).

The problem is that, if using LibreOffice 4.4 from the PPA and doing this:
unopkg add -v Mendeley-1.13.3.oxt
it shows an error such as:
"(com.sun.star.uno.RuntimeException) { { Message = "unknown error!", Context = (com.sun.star.uno.XInterface) @0 } }"

Then it gets incorrectly installed, I just do:
rm -rf .config/libreoffice # to delete the broken installation
soffice # to re-create .config/libreoffice
unopkg add -v Mendeley-1.13.3.oxt # to try again if you wish

The Mendeley plugin is available here
https://www.dropbox.com/s/83isrvr82p2qsvh/Mendeley-1.13.3.oxt?dl=0
(or download and install Mendeley from http://www.mendeley.com/download-mendeley-desktop/ , then it's available in /opt/mendeleydesktop/share/mendeleydesktop/openOfficePlugin/Mendeley-1.13.3.oxt -we don't support OpenOffice but we still need to change the name of the directory, apologies).
Or attached in this bug report.

Anyway, using LibreOffice 4.4 from libreoffice.org works correctly, but using the ppa is not working correctly.

We use the Python pyuno technology that maybe is broken there for some reason?

Tags: ppa Edit Tag help
cpina (carles-pina) wrote :

Juan José Magaña Redondo on Feb 05, 2015 09:47AM GMT at http://support.mendeley.com/customer/portal/questions/11325906-mendeley-plugin-not-working-in-libreoffice-4-4- claims:
"I have Libreoffice 4.4 (ppa:libreoffice-4-3/ppa) and Mendeley 12.4. I had problems with Mendeley 13 plugin, so I decided to downgrade Mendeley instead of Libreoffice. Everything's working fine. I had to tweak things a bit, though."

If so, it would be great to know what change in mendeley 12->13 broke the extension on Ubuntu. If Mendeley is in proper version control, that should be trivial to identify with the information above.

Changed in libreoffice (Ubuntu):
status: New → Incomplete
cpina (carles-pina) wrote :

Hi - Find attached Mendeley 1.12.3 file, I can reproduce the exact problem with it as well.

We haven't changed anything relevant to the plugin in 1.12 -> 1.13 (just a minor VBA code change). I've found that when intalling and re-installing sometimes the plugin gets correctly installed but I don't have steps to reproduce. My guess is that Juan José Magaña Redondo might have had this.

The Mendeley openoffice plugin code is available here: https://github.com/Mendeley/openoffice-plugin

I've attached the Mendeley-1.12.3.oxt extension to make it easier to test in case that you want to try.

Sebastian Karcher (karcher-b) wrote :

In case that helps, the same bug appears in Zotero, which hasn't changed it's LibreOffice add-on in more than a year. It also appears to affect the language toolbar, the third add-on that I'm aware of that relies on LO's Java. Zotero's .oxt is here:
https://github.com/zotero/zotero-libreoffice-integration/tree/master/install

@karcher-b: Please dont mix multiple issues or scope-creep this one. To resolve a bug, it helps to boil it down to the _smallest_ change that breaks the product.

Any information that does not help in that regard should better be filed in a bug report on its own.

cpina (carles-pina) wrote :
Sebastian Karcher (karcher-b) wrote :

I'm not sure I understand. As cpina (who e-mailed me about this) notes in his original bug report, Zotero and Mendeley use the same technology and approach (and significant code overlaps) in their LibreOffice add-ons. With the arrival of LibreOffice 4.4 in the Ubuntu repositories, both products received multiple, identical bug reports with identical error messages in short order, all from Ubuntu users.
I understand you want to narrow down problems to the smallest change possible. The reason I posted here is that you seem to be suggesting to look for a change in Mendeley's plugin, whereas what cpina and I describe very strongly suggests that said change occured somewhere between the last version of LO 4.3 (which works fine with all versions of both products) and 4.4 on the Ubuntu repositories.
It's your product, you know best, but given that Zotero is mentioned multiple times in the original bug report, I think claims of scope creep aren't warranted.

Confirming the same problems with mendeley 1.12.3 from comment 3.

@karcher-b: The rules are simple: Unless you have triaged a bug down to really _know_ that it is same root issue, it isnt. This clearly hasnt happened here and guesswork simply based on "identical", but very, very generic error messages dont help.

commenting out the Scripts/MendeleyDesktopAPI.py in the manifest makes the error go away, so the issue is clearly in that file.

Changed in libreoffice (Ubuntu):
status: Incomplete → New

FWIW, TuesdayPython from https://gerrit.libreoffice.org/gitweb?p=sdk-examples.git;a=summary also fails to install. Thus some generic problem with application/vnd.sun.star.uno-component;type=Python in extensions.

However, internal letter and fax wizard (also Python) seem to work.

I have finally been able to have Libreoffice 4.4 (via ppa) and Mendeley 13.3 working. The same as the user shaneonabike comments on https://forums.zotero.org/discussion/46297/ , by completely uninstalling the plugin, then updating and then reinstalling the plugin, the problem seems to be sorted when you open Libreoffice. I hope it might help others!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

Works in the installation directory during the build, so we are either missing parts when installing or some paths are off.

Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
shaneonabike (shanebill) wrote :

For what it's worth I believe the issue comes when the old items are removed and then the new ones are attempted to be installed. If I didn't remove them manually first this failed every time.

Then when you restart LibreOffice they are actually there, but not functioning go figure.

This should be fixed in package libreoffice-1:4.4.0-1ubuntu2~vivid1 which is now in the LibreOffice fresh ppa at: https://launchpad.net/~libreoffice/+archive/ubuntu/ppa/

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed
cpina (carles-pina) wrote :

Excellent Björn! I'll test in about 12 hours and report it here.

cpina (carles-pina) wrote :

Hi - I've tested and it works as expected (Ubuntu 15.05 and libreoffice-1:4.4.0-1ubuntu2~vivid1 fresh PPA). Out of interest: do you have any plans to fix this problem for users who use https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-4-4 repostiory and Ubuntu 14.10?

Regards,

@cpia: I copied the package over to the libreoffice-4-4 ppa. As for other builds: 4.4.1 will be released real soon now, so I guess I will update along with that.

miro marchi (miro-marchi) wrote :

Hi, I just want to share that with today release - LibreOffice 4.4.1.2 40m0(Build:2) - the problem with mendeley (I have version 1.13.4) is solved. Thanks so much!
PS: I updated with ppa uri: http://ppa.launchpad.net/libreoffice/ppa/ubuntu

Adolfo Jayme (fitojb) on 2015-02-27
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
cement_head (andorjkiss) wrote :

The plugin work with Mendely 1.13.5-dev1 and LO 4.4.1-rc2 on Ubuntu 12.05 LTS, however, the font colours on the plug-in toolbar are incorrect. They are all white/transparent and not like the other toolbars. See attached.

@cement_head: a/ Please dont mix multiple issues into one bug report. b/ Please ensure bugs are indeed LibreOffice fault, not a bug in the extension itself, then file a bug c/ Note that PPA backport versions are not Canonical-supported.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.4.1-0ubuntu1

---------------
libreoffice (1:4.4.1-0ubuntu1) vivid; urgency=medium

  * new upstream release, fixes printing bug (LP: #1419521)
  * adapt/kill ure-link for upstream changes (LP: #1419836)
 -- Bjoern Michaelsen <email address hidden> Thu, 05 Mar 2015 19:28:08 +0100

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers