[upstream] Draw exporting .odg to .svg renders text invisible importing .svg back into Draw

Bug #138141 reported by Jouke on 2007-09-08
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Low
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Draw via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/138141/+attachment/2144240/+files/p0p1p2.odg && unoconv --listener && unoconv -f svg p0p1p2.odg && lodraw -nologo p0p1p2.odg p0p1p2.svg

the two files should look the same.

4) What happen instead is the text is gone in the p0p1p2.svg file. The problem is that in the svg file the 'fill' attribute of the text is set to 'none' while it should have the color of the text.

WORKAROUND: replace fill:none with fill:#000000 in the xml code of the svg file and text will be rendered black. Until bug is solved, users can do this with a replace all command in a text editor.

Alex Lopez (alfitovdkiv) wrote :

Hello, I confirm the error, same to me.
Ubuntu feisty, openoffice 2.2.0-1ubuntu4

Alex Lopez (alfitovdkiv) on 2007-09-11
Changed in openoffice.org:
status: New → Confirmed
Chris Cheney (ccheney) wrote :

Confirmed on upstream's openoffice.org 2.4.0~rc2

Changed in openoffice.org:
importance: Undecided → Low
Chris Cheney (ccheney) on 2008-03-18
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged

In 2.4.1 (Ubuntu OOo) svg does not render properly. Test case is:
http://en.wikipedia.org/wiki/Image:Protractor.svg#file
  http://upload.wikimedia.org/wikipedia/en/f/fc/Protractor.svg

Protractor.svg renders improperly.

Thorsten Behrens (upstream) has apparently fixed several bugs regarding this since 2.4.1 so you might want to check those out & determine if they can be added as an update to (U)OOo 2.4.1 or wait until 3.0.

Schmirrwurst (schmirrwurst) wrote :

I'm using openoffice 3 from jaunty, and still experiencing the same problem

description: updated
summary: - [Upstream] [hardy] export of openoffice draw to svg renders text
- invisable in the svg file
+ export of openoffice draw to svg renders text invisable in the svg file

Yes... this bug is still open for a reason. I just hadn't gotten around to changing the title of the bug report yet.

summary: - export of openoffice draw to svg renders text invisable in the svg file
+ [upstream] export of openoffice draw to svg renders text invisable in
+ the svg file
lionz (thp069) wrote :

Still observed in OO 3.2.0 (Build 9483), downloaded 2010-03-06:

Text (whose color is set to "Automatic" in OO Draw) appears with "fill:none" in the exported svg and is thus rendered invisible by standard svg viewers.

Replacement of these phrases (near "<text" tag) by "fill:#000000" works around the problem.

ubeagle (fun-stuff) wrote :

Still the same in OpenOffice.org 3.2.1 (OOO320m19, Build:9505).

  • p0p1p2.odg Edit (46.3 KiB, application/vnd.oasis.opendocument.graphics)
description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Created attachment 47203
p0p1p2.odg

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/138141

OOo bug may be found at:
http://openoffice.org/bugzilla/show_bug.cgi?id=52605

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Draw via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/138141/+attachment/2144240/+files/p0p1p2.odg && unoconv --listener && unoconv -f svg p0p1p2.odg && lodraw -nologo p0p1p2.odg p0p1p2.svg

the two files should look the same.

4) What happen instead is the text is gone in the p0p1p2.svg file. The problem is that in the svg file the 'fill' attribute of the text is set to 'none' while it should have the color of the text.

WORKAROUND: replace fill:none with fill:#000000 in the xml code of the svg file and text will be rendered black. Until bug is solved, users can do this with a replace all command in a text editor.

summary: - [upstream] export of openoffice draw to svg renders text invisable in
- the svg file
+ [upstream] Draw exporting .odg to .svg renders text invisible in .svg
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed

NOT reproducible with "LibreOffice 3.4.0 – WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:12)]" and reporter's sample "p0p1p2.odg" Export looks fine with Seamonkey (at least big table at the left shows text).

But indeed, IE8 shows table without text (after first open, furthermore IE always opened .svg in Seamonkey). And LibO SVG import also shows empty text fields.

May be I can't see the bug because Seamonkey is too tolerant?

Rainer Bielefeld, thanks for testing LO 3.4.0 for this bug. However, this bug is only focusing on importing the exported svg file back into LO Draw, not seamonkey. Let us avoid "scope creep" and remain focused on this. :)

@Christopher:
The question is: SVG syntax error or not (I have no knowledge concerning SVG syntax)? Is the workaround also the base for the fix or really only a workaround?
The export/reimport effect (please excuse me, it seems I stopped reading subject line with word "invisible ") has been reproduced with WIN, so I modify OS to ALL.

summary: - [upstream] Draw exporting .odg to .svg renders text invisible in .svg
+ [upstream] Draw exporting .odg to .svg renders text invisible importing
+ .svg back into Draw
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

Reproducible in:
LOdev 3.5.0beta2
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002

[Reproducible] with Parallel Dev-Installation of "LibreOffice 3.5.0 Beta2- WIN7 Home Premium (64bit) German UI [Build-ID : 8589e48-760cc4d-f39cf3d-1b2857e-60db978]

Steps how to reproduce:
1. open p0p1p2.odg from file menu
2. Menu 'File -> Export -> "p0p1p2.SVG"' as .SVG
3. Menu 'File -> Open-> "p0p1p2.SVG"'
   Expected: lots of text in the drawing
   Actual: no text as all
Seamonkey (for example ) shows the text

We have some similar bugs with text import problems
Bug 39554 - Insert->Picture->From File... *.SVG not correctly
Bug 32248 - FILEOPEN SVG no TEXT visible
Bug 39599 EDITING, FILEOPEN SVG TEXT INKSCAPE
Bug 37994 - Wrong import of SVG files

Might be Fileopen + Filesave problem

@Thorsten:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.

Changed in df-libreoffice:
status: Incomplete → Confirmed

Apologies for not having gotten around fixing this bug yet; unfortunately in future I'll have even less time at my disposal for this, so I'm freeing up ownership for other volunteers to take over.

Hedley Finger (hedley-finger) wrote :

Bug still present in LibreOffice 4.2.4.2 Write Draw save selected as SVG

Created attachment 121893
p0p1p2.odg

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/138141

OOo bug may be found at:
http://openoffice.org/bugzilla/show_bug.cgi?id=52605

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:5.0.2-0ubuntu1
  Candidate: 1:5.0.2-0ubuntu1
  Version table:
 *** 1:5.0.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status

What is expected to happen in Draw via a terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/138141/+attachment/2144240/+files/p0p1p2.odg

open the file > export to svg > open the svg in Draw and the two files should look the same.

What happen instead is the text is gone in the p0p1p2.svg file. The problem is that in the svg file the 'fill' attribute of the text is set to 'none' while it should have the color of the text.

WORKAROUND: replace fill:none with fill:#000000 in the xml code of the svg file and text will be rendered black. Until bug is solved, users can do this with a replace all command in a text editor.

Changed in df-libreoffice:
importance: Low → Unknown
status: Confirmed → Unknown
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.