LibreOffice does not start in a KDE 4 session

Bug #1300283 reported by Kubuntu CI Bot on 2014-03-31
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Critical
Björn Michaelsen

Bug Description

It seems that the latest RC of LO is completely broken on KDE 4.

Launching the LO center causes nothing to come up ( I can see a window title, but nothing inside the window itself ), launching writer causes a window to come up, which immediately hangs.

Multiple users have brought this up on the Kubuntu Devel mailing list too.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Mar 31 17:22:08 2014
InstallationDate: Installed on 2014-03-18 (12 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140318)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Kubuntu CI Bot (kubuntu-ci-bot) wrote :
Paul White (paulw2u) wrote :

I'm seeing slightly different here -

Main LO window displayed normally the first time I started it. Now, the window contents are black.

The Writer window displays but the window contents are black so the application is unusable.

For what it's worth, Calc starts normally.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) wrote :

Further to comment #2, Writer opened correctly when I double mouse-clicked on a .odt file. Now Writer opens from both the main menu and Alt-F2.

The LO main window still starts up with black contents and needs to be terminated after it appears to hang.

Mark Fraser (launchpad-mfraz) wrote :

In my case I could get the start center to launch properly, but nothing else, but it would work properly by going into Konqueror and opening an ods or odt file.

tags: added: kubuntu
Changed in libreoffice (Ubuntu):
milestone: none → ubuntu-14.04

On my system, launching from the icon seems to be failing with an uninitialized window. If I launch it from a console, sometime I see that same problem, sometime I get the black window Paul described, and occasionally it works properly.

So I think we're all seeing the same issue, it's just that the symptoms can vary.

George Dvorak (gldvorak-gmail) wrote :

I have startcenter as a panel icon and it does not work as the original poster says. From the Application Launcher Writer also fails in the dame way. Calc works. When clicking on a libreoffice file that works correctly. I have attached the /home/gld/.local/share/applications/ desktop files for anyone who wants to inspect them.

Well, I can only attach one file, So this is fir Writer which has the problem.

If you remove libreoffice-kde package, it will start working again. It'll just be ugly. ;)

On Fri, Apr 4, 2014 at 1:55 PM, Jason Straight <
<email address hidden>> wrote:

> libreoffice

Thankyou that fixed my problems!

George Dvorak

Mark Fraser (launchpad-mfraz) wrote :

Bit of a hack, but I copied libkde4be1lo.so and libvclplug_kde4lo.so from 4.2.1 into /usr/lib/libreoffice/programs and LibreOffice loads again.

Mark Fraser (launchpad-mfraz) wrote :

Odd that the same version of LO seems to work OK in 13.10.

It has a severe impact on a large portion of Ubuntu users.

Changed in libreoffice (Ubuntu):
importance: Undecided → Critical
Mark Fraser (launchpad-mfraz) wrote :

My mistake, LibreOffice 4.2.3 rc3 does not work in Kubuntu 13.10 either, but copying the 2 files I mentioned earlier also fix it. One thing I have noticed is that all LibreOffice windows now appear behind the currently focused window.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1300283

tags: added: iso-testing

@Mark Fraser: How can these files be missing on your install? Checking the libreoffice-kde 1:4.2.3~rc2-0ubuntu1 deb files for trusty from:

 http://launchpadlibrarian.net/170943415/libreoffice-kde_4.2.3%7Erc2-0ubuntu1_i386.deb
 http://launchpadlibrarian.net/170938878/libreoffice-kde_4.2.3%7Erc2-0ubuntu1_amd64.deb

clearly contain both.

And since some users (e.g. comment 13) mention 4.2.3~rc3 (which as of now is only available from the PPAs) to miss the files too, I also checked the *.debs in the PPA and the libs are there on both i386 and amd64.

Mark Fraser (launchpad-mfraz) wrote :

@Björn Michaelsen They are not missing, but the versions of libkde4be1lo.so and libvclplug_kde4lo.so in 4.2.3-rc2 and rc3 seem to be the cause of the problem, coping those files from 4.2.1 allows LibreOffice to run.

@Mark Fraser: libkde4be1lo.so seems essentially unchanged since the last release, could you check if only copying the old libvclplug_kde4lo.so helps?

There have been KDE fixes for fdo#73115, fdo#45935 and fdo#74416 on vcl/unx/kde4 since libreoffice-4-2-1 which might be responsible.

From downstream bug lp#1300283:
It seems that the latest RC of LO is completely broken on KDE 4.

Launching the LO center causes nothing to come up ( I can see a window title, but nothing inside the window itself ), launching writer causes a window to come up, which immediately hangs.

Multiple users have brought this up on the Kubuntu Devel mailing list too.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Mar 31 17:22:08 2014
InstallationDate: Installed on 2014-03-18 (12 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140318)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

This comment https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1300283/comments/10 reports that copying the KDE plugin from 4.2.1 in solves this.

There are commits in vcl/unx/kde4 about fdo#73115, fdo#45935 and fdo#74416 -- one of them is likely causing this regression.

copying the file from 4.2.1(!) (as your commment) fixes the bug in 4.1.2(!) (as Version) says?!

either one is incorrect I assume...

Mark Fraser (launchpad-mfraz) wrote :

@Björn Michaelsen: Yes, I reinstalled the newer libreoffice-kde package and then just copied libvclplug_kde4lo.so from 4.2.1 and it works.

... or it is fixed in 4.2.x and needs to be backported to 4.1.x (but 4.1.x without jmux' branch is broken per se)

nope, fumbled when setting the version -- this is a recent regression on the 4.2 branch.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

It's http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dba6e0a71d090f06a6a1a39e87572674593b48a&h=libreoffice-4-2. See Bug 73115 comment 9. It was solved by later commits, which unfortunately didn't go to 4.2.3.

(In reply to comment #4)
> It's
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=7dba6e0a71d090f06a6a1a39e87572674593b48a&h=libreoffice-4-2. See Bug
> 73115 comment 9. It was solved by later commits, which unfortunately didn't
> go to 4.2.3.

Confirmed, reverting 7dba6e0a71d090f06a6a1a39e87572674593b48a makes 4.2.3~rc3 starts at least on kde.

@Jan-Marek: Any plans to backport the fixes for 4.2.4 (or are they already?)

@Björn: See http://lists.freedesktop.org/archives/libreoffice/2014-March/060260.html. Those fixes are already in libreoffice-4-2 branch.

reverting 7dba6e0a for now, to at least let LibreOffice start on KDE4 (see upstream bug for details)

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
status: Confirmed → In Progress

Ok, marking as resolved/fixed then and assigning to Jan-Marek as he did the work on this one.

LibreOffice users on KDE4 are thus encouraged to test the 4-2 nightlies from:
 http://dev-builds.libreoffice.org/daily/libreoffice-4-2/
to see if there are remaining issues on the upcoming 4.2.4.

Paul White (paulw2u) wrote :

LO 4.2.3.3 installed and all seems to be working fine now. Thanks Björn.

I'm still having the same issues.

Mikael Bergqvist (mikaelb) wrote :

Rename /usr/lib/libreoffice/program/libvclplug_kde4lo.so to /usr/lib/libreoffice/program/libvclplug_kdelo.so fixes the problem with 4.2.3~rc3-ubuntu1

The name seems to be changed in this way in 4.2.3.2 and onwards

Mikael Bergqvist (mikaelb) wrote :

Oops, my suggestion probably just hides the problem, libreoffice starts, but looking closer, it seems to lack KDE integration.

@Paul White: Fix Committed is not Fix released. FWIW, this is the (still unreleased) hotfix:
http://anonscm.debian.org/gitweb/?p=pkg-openoffice/libreoffice.git;a=commit;h=a5f78a1e5b81756cf924be311e3a4cb6bad934f0

Changed in df-libreoffice:
status: Confirmed → Fix Released

A hotfixed version is currently building in trusty-proposed:

 https://launchpad.net/ubuntu/+source/libreoffice/1:4.2.3~rc3-0ubuntu2

It actually finished on amd64 and i386, so you are invited to download the libreoffice-kde debs and test them.

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Committed
Paul White (paulw2u) wrote :

Further to my comment in #25 where the problem *disappeared*, yes, I did realise the fix has not been released, I can confirm that the latest build also works here. Calc, Writer, Base, Impress and the main LO application all open correctly.

Although I am not sure that my input is valid at this point as the fix doesn't actually fix anything here because the initial release of 4.2.3.3 also worked correctly. </confused>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.2.3~rc3-0ubuntu2

---------------
libreoffice (1:4.2.3~rc3-0ubuntu2) trusty; urgency=medium

  * revert 7dba6e0a, to at least let LibreOffice start on KDE4 (LP: #1300283)
 -- Bjoern Michaelsen <email address hidden> Wed, 09 Apr 2014 14:07:13 +0200

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released

*** Bug 77446 has been marked as a duplicate of this bug. ***

*** Bug 77303 has been marked as a duplicate of this bug. ***

*** Bug 77400 has been marked as a duplicate of this bug. ***

*** Bug 77463 has been marked as a duplicate of this bug. ***

@Björn: Turns out that it was actually fixed by Luboš Luňák with http://cgit.freedesktop.org/libreoffice/core/commit/?id=71f2aff7a56cef4e133abad3c2e447c76c5ee1fe. Unfortunately it's not in 4.2 yet, so I submitted a request to gerrit:

https://gerrit.libreoffice.org/9079/

Of course I verified that it fixes the bug for 4.2.

*** Bug 78595 has been marked as a duplicate of this bug. ***

Isaac Mercer (nos-developer) wrote :

I am experiencing this bug with the Libreoffice package version 4.2.3~rc3-0ubuntu2. The window borders launch but there is no window content except my desktop.

I am running Ubuntu 14.04 64bit. According to apt-cache I am using 4.2.3~rc3-0ubuntu2 but libreoffice says 4.2.4.2

Mark Fraser (launchpad-mfraz) wrote :

it has stopped working here as well. The only part of LibreOffice I can launch now is the launch center as it was when it broke last time.

August Karlstrom (fusionfile) wrote :

I use latest Lubuntu 14.04 and the only thing that comes up is the start window where I can select what kind of document I want to create. Nothing happens when I click on the Create buttons.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.