soffice.bin crashed with SIGSEGV in rtl_uString_acquire()

Bug #1291221 reported by Walter Garcia-Fontes on 2014-03-12
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

I had libreoffice session open with the computer idle, when I wok up the computer from the lock screen I saw this crash.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: libreoffice-core 1:4.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Uname: Linux 3.13.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Mar 12 08:23:34 2014
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationDate: Installed on 2010-10-25 (1233 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin --calc file:///home/username/Dropbox/hostname/Girlshare/girlpaper_february_2014_10.xls --splash-pipe=5
SegvAnalysis:
 Segfault happened at: 0x7f054a9b3a80 <rtl_uString_acquire>: testl $0x40000000,(%rdi)
 PC (0x7f054a9b3a80) ok
 source "$0x40000000" ok
 destination "(%rdi)" (0x2300b1000) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 rtl_uString_acquire () from /usr/lib/libreoffice/program/../ure-link/lib/libuno_sal.so.3
 PhysicalFontFace::PhysicalFontFace(ImplDevFontAttributes const&, int) () from /usr/lib/libreoffice/program/libmergedlo.so
 ?? () from /usr/lib/libreoffice/program/libmergedlo.so
 ?? () from /usr/lib/libreoffice/program/libmergedlo.so
 X11SalGraphics::GetDevFontList(ImplDevFontList*) () from /usr/lib/libreoffice/program/libvclplug_genlo.so
Title: soffice.bin crashed with SIGSEGV in rtl_uString_acquire()
UpgradeStatus: Upgraded to trusty on 2014-03-07 (4 days ago)
UserGroups: adm admin audio cdrom dialout lp lpadmin plugdev sambashare video www-data

StacktraceTop:
 rtl_uString_acquire (pThis=0x2300b1000) at /build/buildd/libreoffice-4.2.1/sal/rtl/strtmpl.cxx:1087
 OUString (str=..., this=0x7f050c0fe108) at /build/buildd/libreoffice-4.2.1/include/rtl/ustring.hxx:106
 ImplFontAttributes (this=0x7f050c0fe108) at /build/buildd/libreoffice-4.2.1/vcl/inc/outfont.hxx:54
 ImplDevFontAttributes (this=0x7f050c0fe108) at /build/buildd/libreoffice-4.2.1/vcl/inc/outfont.hxx:95
 PhysicalFontFace::PhysicalFontFace (this=0x7f050c0fe100, rDFA=..., nMagic=521472540) at /build/buildd/libreoffice-4.2.1/vcl/source/gdi/outdev3.cxx:682

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Bryan Quigley (bryanquigley) wrote :

From private bug "Crashed when trying to change font of a table column."

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers