Cross-references are broken, when copied to other document or part of the document

Bug #1284377 reported by Jean-Sebastien Gosselin on 2014-02-24
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
High
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Michael Stahl committed a patch related to this bug that has been pushed to "libreoffice-4-1-5". Please, see for more details:

https://bugs.freedesktop.org/show_bug.cgi?id=63553

The bug has been reported to be solved in libreoffice-writer 4.1.5.2 on 2014-02-02.

I am using libreoffice-writer 1:4.2.1-0ubuntu1~saucy1 on Ubuntu 13.10 64 bit from http://ppa.launchpad.net/libreoffice/ppa/ubuntu.

The bug is still present.

Thank you very much. If there is anything I can do to help, or if it is not the proper way to report this kind of issue, please tell.

Jean-Sebastien

Created attachment 77991
Example showing broken cross-references

The problem appeared after application of solution for somehow disturbed cross-reference dialogue (https://bugs.freedesktop.org/show_bug.cgi?id=50139, https://bugs.freedesktop.org/show_bug.cgi?id=50144, https://bugs.freedesktop.org/show_bug.cgi?id=45049, https://bugs.freedesktop.org/show_bug.cgi?id=46714, https://bugs.freedesktop.org/show_bug.cgi?id=47042). When creating text document with several captions, it happens from time to time, that cross references are disappearnig, showing instead 'Error: Reference source not found' message; for instance, when new caption is inserted somewhere in the middle of the document, the cross-references to other captions following to the inserted caption disappearor are misplaced. The same happens if part of the document containing captions and cross-references is copied to other document or other part of the same document.

The sample file is attached to this report. Steps to reproduce the problem:
1. open attached file and besides create blank writer file
2. in attached file select text starting from cross-references to Table 2 and Illustration 2 to the end of document
3. press Ctrl+C to copy text block
4. move to blank file and press Ctrl+V

You will see instead of cross-reference to Table 2 and Illustration 2 'Error: Reference source not found' message. If you will select the whole content and copy / paste it to blank, cross-references will survive in this case.

I guess it is quite annoing bug.

This affects me as well. And I have to admit it, it's quite annoying, when I need to copy around parts of my thesis.

It looks like very few people uses cross-references in LibreOffice or this is very specific issue. I would say it is serious regression in Writer, one of the biggest since moving to OpenOffice.org 3 version.

The error still exists in 4.0.1.2 on 64-bit Linux.

I was able to reproduce also by selecting from Table 3 reference to end of document. In other words, even while selecting less text.

This regression is still in Version: 4.1.4.2, Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72. For me it appears also in Version: 4.2.0.0.beta2, Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d. The problem is not appearing in Apache OpenOffice.org (AOO401m5(Build:9714) - Rev. 1524958).

I have Ubuntu 13.04, 32 bit system with Mate desktop environment.

It is one of the worth regressions in writer module since I use StarOffice, which means a bit more 10 years. I'm very suprised for passivity in solving or at least investigating it, because it destroys basic function of text processor and it is nearly impossible to use libreoffice writer in group work without speding huge amount of work to restore cross-references.

It's very copmlicated not to give up to pressure of colleges and to switch to another office suite, if I don't have any idea, when the situation will be solved. At least now it looks like 4.2 also will have this regression.

Hi Andis,

the version field is to show the _FIRST_ version with the problem.
Do you know if that was from 3.5.x to 3.6.x ?

(I hope to do some testing soon and will set the field accordingly)

(In reply to comment #5)
> Hi Andis,
>
> the version field is to show the _FIRST_ version with the problem.
> Do you know if that was from 3.5.x to 3.6.x ?
>
> (I hope to do some testing soon and will set the field accordingly)

I think it was introduced simultaneously into 3.5.5 and 3.6.x. I don't remember version of 3.6. I guess it was introduced together with some very welcome functions in the insert caption dialogue, like visible reference text for tables and graphics in cross-reference dialogue and solving of problem of non-standard captions, which didn't appeared at all or partially in 3.5-3.5.4 and in first versions of 3.6.

The regression still exists in 4.2.0.2.
One more major release with broken basic functionality in Writer?

working in 3.5.0.3, broken in 3.5.1.1

regression from:

commit 44f971506c0ed37928c48e55d8007f24b0c43a5f
Author: Cédric Bosdonnat <email address hidden>
AuthorDate: Wed Feb 8 14:06:09 2012 +0100

    fdo#35669: Update the references even if nothing uses them here

    Merge the references with the other document even if there is no field
    using them as this may break the sequence and references in other parts
    of a master document.

The problem is still in 4.2.0.3. I hope that this terrible regression will be solved until the major release.

fixed on master

Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb665affbd8870652ade3951d626d76e99143f67

fdo#63553: sw: fix copy/paste of cross references

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f72af83f3a68e0683f8d48dd02c90306b8b2d6f8&h=libreoffice-4-2

fdo#63553: sw: fix copy/paste of cross references

It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=139342a9ad5995058081a47a24818b14581735a5&h=libreoffice-4-1

fdo#63553: sw: fix copy/paste of cross references

It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=718524619bf8cc96325aed87b72735741fe93912&h=libreoffice-4-1-5

fdo#63553: sw: fix copy/paste of cross references

It will be available already in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Excellent!!!

It's solved in 4.1.5.2

Thank you a lot!!!

FWIW, downstream bug at:

 https://bugs.launchpad.net/df-libreoffice/+bug/1284377

claims this still being unfixed in 4.2.1.

Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Yuv (yuv) wrote :

I am on libreoffice 4.2.3.3 and it is completely, utterly broken.
I have text with a footnote. In the footnote I have reference to the footnote number of another footnote. I copy paste the text. It creates a new footnote. The reference in the new footnote is to itself! With a 24 hours deadline looming...

this bug is still alive and well. I am on libreoffice 4.2.3.3 and it is completely, utterly broken. I have text with a footnote. In the footnote I have reference to the footnote number of another footnote. I copy paste the text. It creates a new footnote. The reference in the new footnote is to itself! With a 24 hours deadline looming...

I reverted to stock Ubuntu 13.10 LibreOffice Version: 4.1.3.2 Build ID: 410m0(Build:2).

This bug is not present anymore.

Though, it was still on the ppa version.

In the stock version of LibreOffice on Ubuntu 14.04 Beta, Version: 4.2.3.3 Build ID: 420m0(Build:3)

The bug is still present.

Ubuntu 13.10, LibreOffice Version: 4.1.3.2 Build ID: 410m0(Build:2):

The bug seems to be solved.

Ubuntu 14.04 Beta, LibreOffice Version: 4.2.3.3 Build ID: 420m0(Build:3):

The bug is still there. Same situation also on ubuntu 13.10 while I was using the ppa version of LibreOffice.

I can confirm that in Version: 4.2.3.3, Build ID: 6c3586f855673fa6a1576797f575b31ac6fa0ba3, Ubuntu 13.10 32 bit the bug is still valid and makes trouble; however, this issue is not comparable with original problem reported in this bug report and solved after nearly one year.

Unfortunately developers don't use cross-references and footnotes :(

tags: added: cherry-pick
Changed in df-libreoffice:
status: Fix Released → Confirmed

footnote/endnote cross-reference regression is tracked in bug 77342

Thank you for great job!
This bug is not appearing any more in 4.1.6.2

Changed in df-libreoffice:
status: Confirmed → Fix Released
no!chance (ralf-fehlau) wrote :

This bug appears again in Libreoffice 4.2. It is annoying!! Bugs over bugs and no QS!

@no!chance: Your comment is unfortunately of limited help as-is:
- Which exact version of LibreOffice are you using? From Ubuntu, from the ppa, from TDF? If ppa or Ubuntu, please always specify the full package version number (like 4.2.7-0ubuntu2~ppa2).
- Are you really seeing https://bugs.freedesktop.org/show_bug.cgi?id=63553 (which should be fixed in 4.1.5 and later 4.1.x)? Or rather https://bugs.freedesktop.org/show_bug.cgi?id=77342 (which should be fixed in 4.2.4 and later 4.2.x)?

I am using Libre Office Version: 4.3.3.2 Build ID: 430m0(Build:2) in Ubuntu 14.04 from the ppa and this bug appears to have been solved.

Thanks for the good work.

Jean-Sébastien

I am using Libre Office Version: 4.4.4.2 Build ID: 40m0(Build:2) in Xubuntu 15.04 from the ppa (4.4.4~rc2-0ubuntu2), and some my cross-references started to broke ('Error: Reference source not found') with today's update, unexpectedly and when I Update All at the Tools menu.

Should I uninstall the ppa version, and install the official repository one instead?

Thank you very much.

Jaime Peña Álvarez, you would be experiencing either a regression since the fix, or a different problem. Either way, please file a new report via a terminal:
ubuntu-bug libreoffice

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.