libreoffice Mysql connector fails over network

Bug #1276442 reported by Tim Passingham on 2014-02-05
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

I am running xubuntu 12.04, 32 bit, fully up to date.
 I installed libreoffice 4.2.0.4 from the ubuntu libreoffice standard ppa. This includes:

 libreoffice-mysql-connector 1.0.2+LibO4.2.0~rc4-0ubuntu1~precise4

In libreoffice 4.1.4 this mysql(native) connector worked locally and over my home network. In 4.2.0.4 it works locally but not over my home network,. Nothing else has changed. Mysql(JDBC) still works.

The reported error is:

[code]
SQL Status: HY000
Error code: 2002

Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
[/code]

This is odd, since I am trying to connect over my network.

The Libreoffice team have said they do not support mysql connector, but rely on distributions such as ubuntu.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1276442/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → libreoffice (Ubuntu)
tags: added: ppa
Tim Passingham (tim-8aw3u04umo) wrote :

Same problem with LibreOffice latest 4.2.1.1.

jph (jphorst) wrote :

I can also confirm this with LO 4.2.1.1.
It looks as if LO Base ignores the individual connection settings and always tries to connect to a socket on the local machine. This is a showstopper in our company. Since we run the mysql server on a central machine we had to downgrade to the 4.1 branch again.

Tim Passingham (tim-8aw3u04umo) wrote :

A workaround which is OK for me is to use Mysql(JDBC). It is slower, but it seems to work. Whether it is suitable for commercial use I couldn't say.

jph (jphorst) wrote :

Same problem with a new trusty installation with current 14.04 packages:
LO 4.2.1 and
libreoffice-mysql-connector 1.0.2+LibO4.2.1.-0ubuntu1

jph (jphorst) wrote :

Problem can be solved on trusty as well as on precise by uninstalling libreoffice-mysql-connector 1.0.2+LibO...
and manually installing mysql-connector-ooo-1.0.1-linux-x86_64.oxt (from http://extensions.openoffice.org/en/projectrelease/mysql-connector-openofficeorg-101-linux-x8664) as extension within libreoffice.

Obviously the ubuntu libreoffice 4.2 native mysql-connector is faulty.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Tim Passingham (tim-8aw3u04umo) wrote :

On my 32 bit system the 32 bit version fails to install as an extension. I'm not quite sure what the problem is. It looked a bit as if it expected mysql to be installed on the PC I'm connecting from (and possibly open office as well).

I'll continue with JDBC for now, but hope that ubuntu will fix the LibreOffice connector.

I can confirm that the solution suggested by jph (#6) works fine.

Apologies for my last post (#8), I wasn't as clear as I should have been.

What I meant was that the workaround in #6 didn't work for me. I could not get get the open office extension to install at all.

jph (jphorst) wrote :

Unfortunately my workaround #6 only works in limited cases.
The old 1.0.1 mysql connector does not seem to work well with mysql time fields and produces wrong results then.

jph - that sound familiar. I had similar problems moving from libreoffice 3 to 4.1. Some date/time field formats changed, and the mysql connector supplied as an extension by libreoffice didn't work. The ubuntu connector, however, did work until this more recent network problem.

jph (jphorst) wrote :

Problem also persists in current 14.04 trusty beta installation:

libreoffice-mysql-connector: 1.0.2+LibO4.2.3~rc2-0ubuntu1

jph (jphorst) wrote :

Problem also persists in current 14.04 trusty beta installation:

libreoffice-mysql-connector: 1.0.2+LibO4.2.3~rc3

jph (jphorst) wrote :

Whereas

libreoffice-mysql-connector: 1.0.2+LibO4.1.5~rc3-0ubuntu1~precise1~ppa1

works fine in the equivalent LibO 4.1.5 setup on lucid.

jph (jphorst) wrote :

.... sorry, I ment on precise (12.04) not lucid.

Giuseppe Barichello (swlibero) wrote :

Same problem here: Lo 4.2.4.2 on Debian testing.

Stephen Rynas (ascolais) wrote :

Just upgraded to Ubuntu 14.04 and lost my network connection to MYSQL. Based on what I read above, I obtained a new Native MSQL Connector here: https://code.google.com/a/apache-extras.org/p/aoo-my-sdbc/wiki/Downloads

I did a quick test, and the version from the website above made a connection.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released

Which version of ubuntu libreoffice will that fix be in?

Thanks.

I can confirm this works in ubuntu 14.04 64 bit libreoffice 4.3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers