eps import fails, graphics filter not found

Bug #1218890 reported by Pierre Sauter on 2013-08-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
High
libreoffice (Gentoo Linux)
Fix Released
Medium
libreoffice (Ubuntu)
Undecided
Björn Michaelsen
libreoffice (openSUSE)
Won't Fix
Medium

Bug Description

This bug showed up since 4.1.0.
I just upgraded to 4.1.1, and its still there.

$ lsb_release -rd
Description: Ubuntu 12.04.3 LTS
Release: 12.04

$ apt-cache policy libreoffice
libreoffice:
  Installed: 1:4.1.1~rc2-1ubuntu1~precise1~ppa2
  Candidate: 1:4.1.1~rc2-1ubuntu1~precise1~ppa2
  Version table:
 *** 1:4.1.1~rc2-1ubuntu1~precise1~ppa2 0
        500 http://ppa.launchpad.net/libreoffice/libreoffice-4-1/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

There is also an Upstream Bug:
https://bugs.freedesktop.org/show_bug.cgi?id=67602

But this is clearly an Ubuntu Building/Packaging problem, packages from www.libreoffice.org don't show the bug.

Created attachment 354498
libreoffice dialog when exporting an ODG to EPS.

I recently upgraded libreoffice to 4.1. I remember that exporting an ODG to EPS was no problem (I think imagemagick's convert was used then). However, that does not work. I get 'Graphics filter not found', however I don't know how to fix it. I can't find any use flags or libreoffice extensions. Any idea ?

Created attachment 354500
emerge --info

I see this too. But (even worse?), it also can't import eps, same error message.

How to reproduce:

Take any .eps file and open it. A dialog displays "Graphics filter not found" and the file is not opened.

This is a regression since 4.0. Reproducible on Linux but not Windows XP.

(It's good to be aware that there are also other unrelated EPS issues: #64161, #67465)

Marking as WFM

Bodhi Linux x64
Version 4.1.0.4 release

Attached you'll find a EPS and the resulting draw file that I created after opening it.

Seems like you are missing some dependencies there - how did you install LibreOffice? What distro? Did you purge whatever version you had prior?

If running Ubuntu we recommend sticking with the official ppa - if you installed from TDF (libreoffice.org) let us know so we are aware but purge LibreOffice completely and install from the official ppa.

Created attachment 83463
sample eps

Created attachment 83464
Resulting Draw File

I downloaded the LibreOffice x86 .deb release for comparison and the bug is not there.

It's most likely a bug in the Ubuntu package 1:4.1.0-0ubuntu1~precise1~ppa1 (x86). I'll report this issue to the Ubuntu packaging team.

Ill add our Canonical person just so he is aware.

Bjoern - looks like ubuntu specific

I'm reopening this for Bjoern or someone else to confirm the issue.

UNCONFIRMED is correct status - changing

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0

Open LO, open text-document.
Insert → Picture → From File
Chose a *.eps-picture.
Error occurs: Grapic-filter not found.

This works with LO 4.1.0.4 from LO-website. There is a package "grapic-filter". This package is not in the repository of OpenSUSE.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

I can see the problem. There is also a report from the upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=67602

I think we should investigate the package "libreoffice-filters-optional"

Not only a Ubuntu-packinging-problem. The same bug appears in packages of OpenSUSE.
https://bugzilla.novell.com/show_bug.cgi?id=834374
Isn't a problem of LO.

There is an upstream bug:
https://bugs.freedesktop.org/show_bug.cgi?id=67602
that makes this sound like a packaging problem.

Apparently the Ubuntu PPA version has the same problem and Suse as well:
https://bugzilla.novell.com/show_bug.cgi?id=834374

This also a problem in Gentoo

Attempts to EPS import and export both give the "Graphics filter not found" error.

Bug report here:
https://bugs.gentoo.org/show_bug.cgi?id=478648

Is there some advice that can be given to packagers on what needs to be done differently in 4.1 for the eps import/export filters to work?

Using Libreoffice Writer 4.1 (directly from ppa:libreoffice/ppa) on Ubuntu 12.04 64bit.
I tried opening an existing .odt text file with tiff images imported as links. The imported images would not show. Instead only an empty and flickering frame showed up.
Also, I could not import new tiff files, either embedded in the document, or as links. When I tried (Insert --> Picture --> From file) I would get a "Filter not found" message.

However, other image formats (I tried png and jpg) could be correctly imported.

I downgraded to version 4.0 from ppa:libreoffice/libreoffice-4-0 and now it all works just fine [Version 4.0.4.2 (Build ID: 400m0(Build:2)].

sudo apt-get remove libreoffice*
sudo apt-get autoremove
sudo add-apt repository sudo add-apt-repository ppa:libreoffice/libreoffice-4-0
sudo apt-get updatesudo
apt-get install libreoffice

Could you please attach an example tiff file which you can't import?

Created attachment 84169
Tiff file that could not be imported

Tiff import of your test file (Insert --> Picture --> From file) works fine on 4.1.0.4 using Win7 64bit.

is there any other Linux user who can test?

Thank you for your bug report, I CAN'T reproduce this bug running Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903 on Mac osx 10.8.4.

but
version: 4.1.0.4
Build ID: 410m0(Build:4) on Linux Mint 15
So it is a Linux only bug & a regression because you said it was working in version 4.0.x. (with I didn't test)

works for me on self built 4.1.0.4 and 4.0.4.2 and master versions

Bjoern, seems reporter is using Ubuntu PPA - perhaps a packaging bug?

description: updated

confirmed by multiple downstream bugs

Changed in df-libreoffice:
importance: Unknown → Critical
status: Unknown → Confirmed

(In reply to comment #10)
> confirmed by multiple downstream bugs

Could be I don't understand right, but ...

Nobody has ever confirmed this bug appears in the original packages from LO. All confirmations come from other packages: Ubuntu, SuSE ...

When I open LO 4.1.1.1 directly from LO I could import *.eps-files. When I try the same with 4.1.1.2 from SUSE I couldn't import *.eps-files.

Libreoffice 4.1.1.2 still doesn't work (btw, thanks for reporting upstream, Carl).

I believe Robert is correct. The official builds don't show the problem, but downstream builds since 4.04 do.

Is there something different required in the build environment to allow the eps import/export filters to be found?

I have just opened a document with connected *.tif-files. The same procedure. LO, installed from OpenSUSE-packages, doesn't work. It doesent show any *.tif-image and when I try to insert a new *tif-image the dialog "Graphics filter not found" appears.
The same version, installed from LO directly, works. There is a file libgraphicfilterlo.so. When I look at LO 4.1.1.2 from OpenSUSE it is 95,3 kb. When I look at LO 4.1.1.1 from LO directly, it's 141,4 kb.

A quick check with various versions shows:
- 4.1 on saucy: "import filter not found"
- 4.0 on raring: works
- 4.1 on raring: "import filter not found"

Debian is not hit by this in 4.0 and 4.1. Digging further, this seems to be an upstream regression with enable-mergedlibs, which Debian is not using, but Ubuntu does in both 4.0 and 4.1.
Suspicious commits:

38e95dc334047dfb9a7ae959deda4e4d2f39b3bf
eacf12eeb174e35a301570726bf74434a4dd4b94

by Peter Foley, thus CC'ing as I dont know his IRC nick.

Also: https://bugs.freedesktop.org/show_bug.cgi?id=67602 likely has the same root cause.

Likely same root cause as fdo#68210: mergedlibs broke between 4.0 and 4.1.

After rebuilding LO a few times, I've found that removing --enable-mergelibs from the configure command makes this problem go away.

I will report it upstream, but is there a good reason not to remove this option from the ebuild?

I can confirm that on gentoo, when --enable-mergedlibs is removed from the configure command, the eps import/export problem goes away.

It seems to be related to the --enable-mergelibs configure switch. It works when I disable it.

We want the mergelib because it causes significant startup speedup. We need to fix it to find the EPS import filter also in this case.

Let's solve this in upstream bugzilla.

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc86610d16a561ff1a0455d5fef157431f9271e3

fdo#68210: Make tiff import work again with merged-libs

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3a021c00d9b27e6bcafbfaf8bf7b36cdd40768e2

fdo#68210 related: make other filters work again too

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

*** Bug 67602 has been marked as a duplicate of this bug. ***

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in df-libreoffice:
importance: Critical → Unknown
status: Confirmed → Unknown
Changed in libreoffice (Gentoo Linux):
importance: Unknown → Medium
status: Unknown → New
Changed in libreoffice (openSUSE):
importance: Unknown → Medium
status: Unknown → Won't Fix
Changed in libreoffice (Ubuntu):
status: New → In Progress
Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4d60f0abadf048ae203914f5b4e8b828ff76f16&h=libreoffice-4-1

fdo#68210: Make tiff import work again with merged-libs

It will be available in LibreOffice 4.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Thanks for the quick fix Björn.

However in my test it seems that some tests are broken at the moment:

./workdir/unxlngi6.pro/CxxObject/filter/qa/cppunit/filters-tga-test.o: In function `TgaFilterTest::load(rtl::OUString const&, rtl::OUString const&, rtl::OUString const&, unsigned int, unsigned int, unsigned int)':
./filter/qa/cppunit/filters-tga-test.cxx:61: undefined reference to `itgGraphicImport'

Indeed, someone not only broke the build, he also made ensure that it'll stay broken with tests. :/

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88a97db7e630a70e68afcc80277174b9dd5ec159&h=libreoffice-4-1-2

fdo#68210: Make tiff import work again with merged-libs

It will be available already in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

This will be fixed in next release. Yay :-)

Changed in libreoffice (Gentoo Linux):
status: New → Fix Released

Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.1.2~rc2-0ubuntu1

---------------
libreoffice (1:4.1.2~rc2-0ubuntu1) saucy; urgency=low

  * merge from Debian
  * new upstream release candidate
    - fix fdo#68210, fdo#67602: trouble with mergedlibs and dynamic loading
      (LP: #1218890)
  * activate unity menus even earlier to reduce latency (LP: #1204592)
  * remove upstreamed and unused patch for lp#1085168
  * with mergedlibs, lp-solve is already needed by -core (LP: #1221014)

libreoffice (1:4.1.2~rc2-1) UNRELEASED; urgency=low

  * new upstream release candidate
    - fixes debug logging for python3 in pythonscript.py (closes: #719941)

  * debian/rules:
    - fix curl conditional to really add libcurl4-<whatever>-dev builddep....
    - disable graphite2 for armel and sparc for wheezy-backports
    - build using gcj-jdk for kfreebsd-* on wheezy-backports

libreoffice (1:4.1.1-1) unstable; urgency=low

  * LibreOffice 4.1.1 final (identical to rc2)

  * upload to unstable

  * debian/patches/translation-updates-and-bugfixes.diff: as name says
    from libreoffice-4-1-1 branch

  * debian/rules:
    - hardcode kfreebsd-* as openjdk arch until java-common setting it as
      default is uploaded
    - bump librdf0-dev build-dep to >= 1.0.16 to match reality; use
      internal one on wheezy
    - *really* build sysui with all languages again in build-arch so .desktop
      get the translations

  * merge from Ubuntu:
    - remove uuid build-dep again, just needed for crosscompile msi
      generation..
 -- Bjoern Michaelsen <email address hidden> Tue, 17 Sep 2013 14:42:46 +0200

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released

*** Bug 69902 has been marked as a duplicate of this bug. ***

Hi,

This bug has still the NEW status: are these patches only partial, preventing to mark this bug as fixed?

Best regards. JBF

it is a Linux specific bug. any Linux user can still confirm this?

Indeed this is now fixed.

Changed in df-libreoffice:
status: Confirmed → Fix Released

In Libreoffice 4.1.3.2 it doesn't seem to be fixed.
Just tested with opensuse-factory-build on opensuse 12.3.
Same with the original version downloaded from the LO-website.

Can we expect a general solution, because this is a real blocker for
business needs?

(In reply to comment #17)
> In Libreoffice 4.1.3.2 it doesn't seem to be fixed.
> Just tested with opensuse-factory-build on opensuse 12.3.
> Same with the original version downloaded from the LO-website.

i don't know about suse builds but the upstream builds from
libreoffice.org definitely do not use --enable-mergelibs
so you should file a separate bug if that doesn't work for you.

I'm sorry, it was obviously my fault, because I didn't test it with the example above.
This works with both - opensuse and upstream version.

My own testimage contained kind of compression, that is incompatible with LO.
Might be a task for improvement,but not a bug...

After upgrading to 4.1 (again from ppa:libreoffice/ppa) I can confirm that the problem has been corrected.

Donald Passing (analog-f) wrote :

Hi, I have the same problem under 4.1.04 with jpg-files. Knows anybody to fix it?

Donald Passing, as this bug is marked Fix Released, it would not be covering your problem. If you have bug in LibreOffice, please file a new report via a terminal:
ubuntu-bug libreoffice

*** Bug 67868 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.