presentation causes system to hang

Bug #1207057 reported by Ritesh Khadgaray on 2013-07-31
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

* Xorg will start chewing up a CPU when a LibreOffice presentation is opened

Test package from https://launchpad.net/~libreoffice/+archive/libreoffice-3-5/+sourcepub/3333599/+listing-archive-extra helps.

[Impact]
 * system freeze when open presentation file
 * Xorg will start chewing up CPU , when libreoffice presentation is opened

[Test Case]

 * Open presentation (from lp #1176923 ) , and move to page Page 10 for table edit
 * disabling anti-aliasing doesn't help.

[Regression Potential]

 * minimal, patch is from upstream

[Other Info]

 * upstream LibreOffice commit - http://cgit.freedesktop.org/libreoffice/core/commit/?h=master&id=3137258e346a9c16b2e61747fd926a1e7d358d02

 * test packages, these resolve the issue - https://launchpad.net/~libreoffice/+archive/libreoffice-3-5/+sourcepub/3333599/+listing-archive-extra

description: updated

_Source_ package as needed for SRU upload available at:

 https://launchpad.net/~bjoern-michaelsen/+archive/libreoffice-staging/+sourcepub/3400965/+listing-archive-extra

Note this package is a full distro build, so likely wouldnt complete a build in a ppa builder. The bug reference/version name in changelog is updated, otherwise its the same package as the:

 https://launchpad.net/~libreoffice/+archive/libreoffice-3-5/+sourcepub/3333599/+listing-archive-extra

Which is a (limited l10n) ppa build (with binaries) and has been available in the libreoffice-3-5 ppa for some time. Git branch at:

 http://anonscm.debian.org/gitweb/?p=pkg-openoffice/libreoffice.git;a=shortlog;h=refs/heads/ubuntu-precise-3.5

is up-to-date, but not yet tagged as I usually do that with sponsoring.

As I will be on vacation, I trust Benjamin Drung (or, failing that: Sebastian Bacher) with the review and upload.

Changed in libreoffice (Ubuntu):
status: New → In Progress
Benjamin Drung (bdrung) on 2013-08-19
Changed in libreoffice (Ubuntu Precise):
status: New → In Progress
Martin Pitt (pitti) wrote :

Bjoern is handling this, and other sponsors shouldn't really touch a LibO SRU without coordinating with Bjoern, so unsubscribing sponsors.

Martin Pitt (pitti) wrote :

Ignore the previous comment, that was meant for the other bugs.

Martin Pitt (pitti) wrote :

Do you have a source_changes to go along with this for uploading? I don't see one on people.c.c.

I uploaded a the *debian*, *.dsc, *_source.changes and a diff to:
http://people.canonical.com/~bjoern/precise/3.5.7/

fixed package is waiting in precise-proposed.

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Released
Changed in libreoffice (Ubuntu Precise):
status: In Progress → Fix Committed

Hello Ritesh, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libreoffice/1:3.5.7-0ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Bryan Quigley (bryanquigley) wrote :

Has no affect on my machine; stills lags for more than 3 minutes ( I then kill it). I'm on Gnome Shell, with a Radeon R600 card, and Mesa/Kernel HWE from Raring.

tags: added: verification-failed
removed: verification-needed

@Bryan: Does this file work fine for you on a newer version of LibreOffice (3.6.x/4.0.x/4.1.x)? As is this seems to be a "slow system is slow" issue, read: If you have a very computation-intense file and a slow (software-rendering) driver, it will take time obviously ...

The patch obviously doesnt magically make "Linux does infinite loops in 5 seconds" ...

Bryan Quigley (bryanquigley) wrote :

@Björn
Yup, it also affects LO 4.1.x in Trusty. The thing is the Radeon driver is usually not considered slow and it's a HD 3870, which is definitely not a slow card.

Well, testing this document on saucy with 4.1.2, I see no issues at all on an Intel driver. Since others reported this to be fixed by the patch (bug 1176923, comment 13 for example reports so for Intel) I assume this to be fixed _in_ _LibreOffice_ and the remaining issue is a different bug _in_ _the_ _Radeon_ _driver_ (as it only happens there).
Note that the test document itself seems to be quite badly broken, and thus the rendering is more likely to trigger cornercases in the drivers.

I would suggest to go ahead with this patch (as it seems to fix the issue on Intel) and create a new bug against the radeon driver to heal the remaining symptoms.

Bryan Quigley (bryanquigley) wrote :

@Björn
Sounds like a plan. Switching back to verification-needed so that someone with an intel card can test on 12.04.

tags: added: verification-needed
removed: verification-failed

Discussed this with seb128: pushing this to verification done as per comment 11 (which references an independent confirmation).

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for libreoffice has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:3.5.7-0ubuntu5

---------------
libreoffice (1:3.5.7-0ubuntu5) precise; urgency=low

  * rebase changes on ppa
  * backport theming fix for dark themes (LP: #628105)
  * paint to overlay directly (LP: #1207057)
 -- Bjoern Michaelsen <email address hidden> Thu, 22 Aug 2013 12:42:12 +0200

Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers