ensure no gconf deps for LibreOffice 5.1/x-series

Bug #1202924 reported by Jeremy Bicha on 2013-07-19
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Wishlist
libreoffice (Ubuntu)
Medium
Björn Michaelsen

Bug Description

libreoffice-core and libreoffice-gnome are two of the last few packages in the default Ubuntu and Ubuntu GNOME installs with a dependency on gconf.

I think some of the code that uses gconf is wrong as neither GNOME nor Unity set values any more there for things like default mail handler, font and proxy settings, and lockdown settings.

http://cgit.freedesktop.org/libreoffice/core/tree/shell/source/backends/gconfbe/gconfaccess.cxx

Even though GTK3 provides an interface to access gsettings directly through GTK, it's still possible to call out to gsettings manually via the command line interface.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Confirmed

Is GSetting is universally supported on the TDF baseline build machines?

Is GSetting is universally supported on the TDF baseline build machines?

(In reply to comment #4)
> Is GSetting is universally supported on the TDF baseline build machines?

How to find out? Do you refer to https://wiki.documentfoundation.org/Development/Tinderbox#List_of_registered_Tinderboxes ? What is "universally"? I doubt that LibreOffice currently stores its settings also in GConf under MS Windows.

(In reply to comment #4)
> Is GSetting is universally supported on the TDF baseline build machines?

How to find out? Do you refer to https://wiki.documentfoundation.org/Development/Tinderbox#List_of_registered_Tinderboxes ? What is "universally"? I doubt that LibreOffice currently stores its settings also in GConf under MS Windows.

Adolfo Jayme (fitojb) on 2013-07-22
summary: - Drop gconf dependency, port to gsettings
+ [Upstream] Drop gconf dependency, port to gsettings
Changed in libreoffice (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist

The machine that the TDF binaries are build on is relevant. CCing Caolan who should be aware of their setup.

The machine that the TDF binaries are build on is relevant. CCing Caolan who should be aware of their setup.

RHEL-6 is the current baseline, any work in the area needs to be able to build and work on RHEL-6. Don't think anyone is going to work on this on the near future.

RHEL-6 is the current baseline, any work in the area needs to be able to build and work on RHEL-6. Don't think anyone is going to work on this on the near future.

Adolfo Jayme (fitojb) on 2013-07-25
Changed in libreoffice (Ubuntu):
status: Triaged → Won't Fix

I was reading media coverage about the LibreOffice 4.1 release today and it says that Linux now uses harfbuzz. Harfbuzz is too new to be in RHEL 6 right?

LibreOffice isn't stuck with 2010 technology for the next 2-5 years, is it?

I was reading media coverage about the LibreOffice 4.1 release today and it says that Linux now uses harfbuzz. Harfbuzz is too new to be in RHEL 6 right?

LibreOffice isn't stuck with 2010 technology for the next 2-5 years, is it?

we bundle harfbuzz into LibreOffice for that case, but we try and keep that sort of bundling down as much as possible

we bundle harfbuzz into LibreOffice for that case, but we try and keep that sort of bundling down as much as possible

Anyway, there is a BIG difference between harfbuzz, which is used for text layouting, and gconf/gsettings, which is used to get 2 or 3 keys from the gnome configuration.

Anyway, there is a BIG difference between harfbuzz, which is used for text layouting, and gconf/gsettings, which is used to get 2 or 3 keys from the gnome configuration.

Another note: gsettings is part of gio, which is itself (source-wise) a part of glib2. There is no way we are going to bundle glib2, ever.

Another note: gsettings is part of gio, which is itself (source-wise) a part of glib2. There is no way we are going to bundle glib2, ever.

Changed in df-libreoffice:
status: Confirmed → Won't Fix

Will then libreoffice need to use gconf forever? (gconf development stopped some years ago :/)

Will then libreoffice need to use gconf forever? (gconf development stopped some years ago :/)

(In reply to Pacho Ramos from comment #12)
> Will then libreoffice need to use gconf forever?

No. Only until the time we switch our baseline to something that supports gsettings.

> (gconf development stopped some years ago :/)

So what? It still works, does it not?

(In reply to Pacho Ramos from comment #12)
> Will then libreoffice need to use gconf forever?

No. Only until the time we switch our baseline to something that supports gsettings.

> (gconf development stopped some years ago :/)

So what? It still works, does it not?

summary: - [Upstream] Drop gconf dependency, port to gsettings
+ disable gconf for LibreOffice 5.1/x-series
Changed in libreoffice (Ubuntu):
status: Won't Fix → New
importance: Wishlist → Medium
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in df-libreoffice:
importance: Wishlist → Unknown
status: Won't Fix → Unknown

(In reply to David Tardon from comment #13):
> So what? It still works, does it not?

Apparently it doesnt, at least on halfway recent system all these conf keys are unused. And the original intend of i#20364 i#20369 seems questionable from the start at least.

Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Won't Fix

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

Discussed on the ESC today, decided we should drop gconf integration, something more useful might or might not come along at some point:
>* Killing LibreOffice gconf integration (Bjoern)
> + gconf is obsoleted by gsetting
> + on most distros the settings in gconf will be outdated/unused
> + keeping this around as will likely just cause confusion as people will find subtile different settings without knowing why/from where
> + https://bugs.documentfoundation.org/show_bug.cgi?id=41678
> + used to be used for lockdown and some prop. tools integrated (Michael)
> + RH not using it (Caolan)
> + Stephan working on a dconf version instead.

summary: - disable gconf for LibreOffice 5.1/x-series
+ ensure no gconf deps for LibreOffice 5.1/x-series
Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed

Fix commited (as perhttps://bugs.documentfoundation.org/show_bug.cgi?id=41678#c16 )

Changed in df-libreoffice:
status: Won't Fix → Fix Released

And released: 5.1 is in xenial.

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.