Reopening copied draw .odg into Writer .odt frame changes picture

Bug #1181738 reported by Sasa Paporovic on 2013-05-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
High
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.0.2-0ubuntu1
  Candidate: 1:4.0.2-0ubuntu1
  Version table:
 *** 1:4.0.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen via a terminal:
cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1181738/+attachment/3680887/+files/Chart2%20for%20Realized%20Collaboration%20across%20borders.odg -O example.odg && lodraw --nologo example.odg && libreoffice --nologo --writer

In Draw select all -> Copy -> in Writer Insert -> Frame -> tab Type -> Width 7.52" -> Height 6.13" -> button OK -> click in the newly created frame -> Paste -> Save -> Close and reopen and the picture in Writer looks as it did when copied.

4) What happens instead is the picture has been modified.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libreoffice-core 1:4.0.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-22.33-generic 3.8.11
Uname: Linux 3.8.0-22-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Sun May 19 14:30:15 2013
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationDate: Installed on 2013-01-13 (125 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: libreoffice
UpgradeStatus: Upgraded to raring on 2013-04-18 (30 days ago)

Created attachment 75343
Example of vector graphics not displaying connectors anymore in Write. After saving appears the vector art from LibreOffice Draw) are converted to a picture and information is lost.

Problem description:
A drawing created in LibreOffice Draw, copied into LibreOffice Writer 4.0.0.3 (or similar version), does not properly display the drawing (in Writer) after saving, closing and re-opening the LibreOffice Writer document. Appears to be affecting connectors, textboxes and arrows. After saving appears the vector art from LibreOffice Draw) are converted to a picture and information is lost.

Steps to reproduce:
1. Create drawing in LibreOffice Draw (used vector graphics). Add connectors (connected to other shapes), textboxes and arrows since it appears to affect connectors, arrows, textboxes most often but may not be limited to only these objects.
2. Copy drawing into LibreOffice Writer.
3. Centered drawing in Writer and changed anchor to "As Character" and added some text above and below like a typical figure in text document.
4. Can close the LibreOffice Draw drawing document now (save the drawing just to be able to repeat steps later if neccessary).
5. Save & close the LibreOffice Writer document with the text and drawing.
6. Re-open LibreOffice Writer document with text and drawing.
7. Inpect the drawing for missing vectors or objects.

Current behavior:
After saving and re-opening a Writer document with vector drawings done in LibreOffice draw, the drawing is missing some vector art when the Writer document is re-opened. Eg. drawing or graphic is not displayed properly (missing vectors such as connectors, arrows and textboxes). After saving appears the vector art from LibreOffice Draw) are converted to a picture and information is lost.

Expected behavior:
Expecting the drawing in Writer to save and display properly when re-opened in Writer (with all vectors and art showing properly).

Operating System: Windows 7
Version: 4.0.0.3 release

this is definitely a duplicate - I will try to find it and mark this one as such.

Okay I really can't find it but I know that it exists. Marking this one as NEW and prioritizing but be aware that it's a dupe.

Major - data loss
High - default for major bugs

Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :
Sasa Paporovic (melchiaros) wrote :

This problem is reproducible.

Steps to reproduce:
1.Open the affected writer document
2.Delete the damaged graphic 2 from it completely.
3.Open graphic 2 draw document
4.Copy grahic 2 again in the writer document
5.Resize the txt size in the blocks of the graphic from 18 to 12
6.Save the writer document that has now again graphic 2 incooporated
7.Close LibreOffice
8.Open LibreOffice again
9.Open the writer document with File-> Last used document
10.See again the blocks in graphic 2 missing

Additional: In the original graphic 2 draw document the graphic is not damaged.

description: updated
summary: - libreoffice writer 4 is erasing draw graphics
+ Reopening copied draw .odg into Writer .odt frame changes picture

Sasa Paporovic, thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one. It would be nice if somebody having it could send the bug to the developers of the software by following the instructions verbatim at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about the status. Thanks in advance.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

Status -> Triaged
Importance -> Medium

description: updated
Changed in libreoffice (Ubuntu):
status: New → Confirmed

I have the same problem on Ubuntu Linux 13.04 raring 64bit. The launchpad report could be found at:

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1181738

An example file is available there, also a in deep description.

The hader of the report will be copied here(version informations are also in it):
----------------------------------------------------------------

1) lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.0.2-0ubuntu1
  Candidate: 1:4.0.2-0ubuntu1
  Version table:
 *** 1:4.0.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen via a terminal:
cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1181738/+attachment/3680887/+files/Chart2%20for%20Realized%20Collaboration%20across%20borders.odg -O example.odg && lodraw --nologo example.odg && libreoffice --nologo --writer

In Draw select all -> Copy -> in Writer Insert -> Frame -> tab Type -> Width 7.52" -> Height 6.13" -> button OK -> click in the newly created frame -> Paste -> Save -> Close and reopen and the picture in Writer looks as it did when copied.

4) What happens instead is the picture has been modified.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libreoffice-core 1:4.0.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-22.33-generic 3.8.11
Uname: Linux 3.8.0-22-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Sun May 19 14:30:15 2013
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationDate: Installed on 2013-01-13 (125 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: libreoffice
UpgradeStatus: Upgraded to raring on 2013-04-18 (30 days ago)

Sasa Paporovic (melchiaros) wrote :

Done.

On upstream bugtracker was already a report from the windows platform for it. I have commented and copied the header of this report there.

Sasa Paporovic (melchiaros) wrote :

Thank you for triaging Christopher.

Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed

Fixed in Xenial.

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.