LibreOffice: Translations for QuickList entries are not included in the .desktop files

Bug #1170035 reported by David Planella on 2013-04-17
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Undecided
Unassigned
Ubuntu Translations
High
Unassigned
libreoffice (Ubuntu)
High
Björn Michaelsen

Bug Description

As a follow-up to bug 1068101, LibreOffice QuickList entries are now translatable upstream, but the translations are not actually loaded.

Sweetshark mentions on IRC:

<Sweetshark> dpm: yes, it should work that way, maybe the translation stuff is broken, it needed some ugly hacks on top of an ugly perl script to add the unity entries to the desktop files.
 dpm: yep. seems that perl script is broken.
<Sweetshark> dpm: the perl script is at sysui/desktop/share/translate.pl if some volunteer wants to beat me to it, that would be highly welcome ;)
 dpm: fwiw, there still is some UnityQuicklist specialcasing in there: https://gerrit.libreoffice.org/gitweb?p=core.git;a=blob;f=sysui/desktop/share/translate.pl;h=48742b7f1e6d9417a25e71de80543ef2c357be01;hb=a43cc9ec8dde4f311bcf8ff96e6a26d56b2abdcf#l54

Upstream translations live at:

https://translations.documentfoundation.org/en_ZA/libo_ui/sysui/desktop/share.po/translate/#filter=incomplete&unit=29114532

David Planella (dpm) on 2013-04-17
Changed in ubuntu-translations:
importance: Undecided → High
status: New → Triaged
description: updated
David Planella (dpm) on 2013-04-17
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
tags: added: i18n saucy
summary: - Translations for LibreOffice QuickList entries are not loaded
+ LibreOffice: Translations for QuickList entries are not loaded
Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in libreoffice (Ubuntu):
importance: High → Low
tags: added: utopic

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1170035

tags: added: iso-testing
summary: - LibreOffice: Translations for QuickList entries are not loaded
+ LibreOffice: Translations for QuickList entries are not included in the
+ .desktop files
Changed in libreoffice (Ubuntu):
importance: Low → High
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
tags: added: rls-w-incoming
Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed
tags: added: rls-x-incoming
removed: rls-w-incoming

Fixed upstream and in Xenial with LibreOffice~5.1.0~rc3-0ubuntu2.

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Changed in df-libreoffice:
status: New → Fix Released
Adolfo Jayme (fitojb) on 2016-03-30
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers