Fonts displaying incorrectly

Bug #1167309 reported by Emily Maher on 2013-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Unknown
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Comparison of font displaying in OSX and Ubuntu (Ubuntu is correct)

Ubuntu Light font is compressed horizontally in Impress but the same presentation displays correctly on Ubuntu (presentation created originally in Ubuntu).

Created attachment 77736
Comparison of font displaying in OSX and Ubuntu (Ubuntu is correct)

Ubuntu Light font is compressed horizontally in Impress but the same presentation displays correctly on Ubuntu (presentation created originally in Ubuntu).

Emily Maher (emily-maher) wrote :
Changed in df-libreoffice:
importance: Unknown → Critical
status: Unknown → New

@fontconfig-guys: Do we do any fancy vendor-patching on fontconfig wrt this?

changing attachment to image/png.

@Emily: Was that a version of LibreOffice 4.0.x on both Ubuntu and OS X? And what release of Ubuntu are you using?

LibreOffice on OSX seems to be using fontconfig-2.8.0. Both Ubuntu Quantal and Raring use newer versions. So a solution might be updating fontconfig on OSX (and possibly: upstream any Ubuntu-vendor patching first).

lowering priority as for upstream, this doesnt fit in 'critical' (not a crasher or dataloss involved).

Hi Bjorn, thank you for your quick response :-)

I am using 4.0.2.2 on both OSX and Ubuntu 12.10, I will try your suggestion for OSX and let you know if it helps.

Understand regarding the prioritisation, I wasn't sure how to categorise it myself!

Hi again Bjorn, after a bit of asking around, if I understand correctly, fontconfig is bundled with LibreOffice 4 on OSX right? Would you be able to arrange a build of LibreOffice 4 for OSX with the updated fontconfig so that I could test your theory? I don't know my way around XCode, so I'm afraid I wont be of much help compiling this :)

@fontconfig: Disregard me, we are not using fontconfig on OS X.

Changed in fontconfig (Ubuntu):
status: New → Invalid

Wandered around a bit on this bug: While LibreOffice bundles fontconfig for some platforms, this is not used on OS X. This makes it a lot harder to triage. For LibreOffice 4 I hear we still use ATSUI (http://en.wikipedia.org/wiki/Apple_Type_Services_for_Unicode_Imaging) and given that the bug does not show up on Ubuntu, chances are equal right now that this is a bug in the Apple services or in the way we use them.

CCing Norbert, who did some good work in that area and might give some hints on how to further corner this one.

I will take a look at Windows how the font renders there, which might give some additional hints.

At least on Windows, the font looks good to my aesthetically challenged eyes.

Reading tml_s blog on 64-Bit builds[1] having to use CoreText instead of ATSUI, it might help to know if a build from:

 http://dev-builds.libreoffice.org/daily/master/MacOSX-X86_64@30/current/

renders the font better. Note that these builds are at a very early pre-alpha state, might eat your cat and do evil things with your presentations, so just use then to test if the font looks better there.

I have no OS X box here, so @Emily or anyone owning one giving it a try is highly appreciated. ;)

If those builds are also rendering it wrong (in the same way), we might indeed have a bug in LibreOffice itself here.

[1] http://tml-blog.blogspot.de/2013/04/64-bit-libreoffice-for-os-x.html

Download full text (42.2 KiB)

I've tried [1], but it crashes just after the LibreOffice loading screen. I'm running OSX 10.6.8, if that helps.

1: http://dev-builds.libreoffice.org/daily/master/MacOSX-X86_64@30/current/master~2013-04-11_07.22.41_LibreOfficeDev_4.1.0.0.alpha0_MacOS_x86-64.dmg

Process: soffice [8201]
Path: /Applications/LibreOfficeDev.app/Contents/MacOS/soffice
Identifier: org.libreoffice.script
Version: 4.1.0.0.alpha0 (???)
Code Type: X86-64 (Native)
Parent Process: launchd [98]

Date/Time: 2013-04-11 09:49:32.989 +0100
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 269993 sec
Crashes Since Last Report: 254
Per-App Interval Since Last Report: 98 sec
Per-App Crashes Since Last Report: 2
Anonymous UUID: 0FB4AF66-4AB6-4DF9-B846-AC87478401B6

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: 0x000000000000000d, 0x0000000000000000
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 libgcc3_uno.dylib 0x00000001085e3415 gcc3::toUNOname(char const*) + 53
1 libgcc3_uno.dylib 0x00000001085e31b8 gcc3::fillUnoException(gcc3::__cxa_exception*, _uno_Any*, _uno_Mapping*) + 56
2 libgcc3_uno.dylib 0x00000001085e4acc cpp_call(bridges::cpp_uno::shared::UnoInterfaceProxy*, bridges::cpp_uno::shared::VtableSlot, _typelib_TypeDescriptionReference*, int, _typelib_MethodParameter*, void*, void**, _uno_Any**) + 2396
3 libgcc3_uno.dylib 0x00000001085e412f bridges::cpp_uno::shared::unoInterfaceProxyDispatch(_uno_Interface*, _typelib_TypeDescription const*, void*, void**, _uno_Any**) + 767
4 libuno_cppuhelpergcc3.dylib.3 0x0000000100574e17 cppu::getCaughtException() + 983
5 libutllo.dylib 0x0000000102420063 utl::UCBContentHelper::IsDocument(rtl::OUString const&) + 115
6 fsstorage.uno.dylib 0x000000011f774bd0 FSStorageFactory::createInstanceWithArguments(com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&) + 496
7 fsstorage.uno.dylib 0x000000011f775222 non-virtual thunk to FSStorageFactory::createInstanceWithArguments(com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&) + 18
8 libfwklo.dylib 0x000000011e524314 framework::PresetHandler::getOrCreateRootStorageUser() + 964
9 libfwklo.dylib 0x000000011e524c67 framework::PresetHandler::connectToResource(framework::PresetHandler::EConfigType, rtl::OUString const&, rtl::OUString const&, com::sun::star::uno::Reference<com::sun::star::embed::XStorage> const&, LanguageTag const&) + 439
10 libfwklo.dylib 0x000000011e62e0ec framework::ModuleUIConfigurationManager::initialize(com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&) + 716
11 libuno_cppuhelpergcc3.dylib.3 0x00000001005760dc cppu::OSingleFactoryHelper::createInstanceWithArgumentsAndContext(com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&) + 124
12 libuno_cppuhelpergcc3.dylib.3 0x0000000100576ecd cppu:...

Changed in df-libreoffice:
importance: Critical → Medium
status: New → Incomplete

@Emily,

If you could attach some sample slides from the presentation, I can test the rendering.

Created attachment 77982
Ubuntu Light font displaying incorrectly

In Mac OSX the Ubuntu Light font compresses horizontally.

Hi Emir, I have attached a slide that was affected by the problem in OSX. Let me know if there is anything else I can send to help.

Many thanks.

Well,

I have tested the sample slide with the following builds:

-LO 4.0.2.2
-LODev 4.1 pre-alpha (64-bit with Core Text rendering)
-NeoOffice 3.3 (32-bit with Core Text rendering)

First of all, I can confirm the bug on LO 4.0.2.2. Indeed text appears condensed, and definitely not pleasing to look at.

Tor's latest experimental build with Core Text renders the fonts just fine, so it means we have a fix at hand. But, when I click on the text box for editing, text becomes condensed again, but, when I click elsewhere to change the focus from the text box to somewhere else, it reverts to its nicely rendered state.

Latest NeoOffice release renders the fonts without any errors, most probably as a result of their Mac-specific engineering efforts.

Changing bug state to "NEW".

Changed in df-libreoffice:
status: Incomplete → Confirmed

*** Bug 63856 has been marked as a duplicate of this bug. ***

no longer affects: fontconfig (Ubuntu)

Hi Emily - if the coretext work fixes this (and I'd encourage you to try out Beta2 which should have yet better support), it is rather unlikely (it's very invasive and somewhat risky) that we will back-port this to 4.0 or anything before 4.1. As such - if it's fixed in 4.1 - we should prolly close this.

Thanks for the bug report ! and please keep an eye on / test the 4.1 pre-releases...

It's still broken on 4.1.1.2. How do we find out if it's getting fixed? I really can't use Impress with this bug in place.

I'm sure you don't really care, but I'm done with LO as a result of this bug. It's been 8 months, and there's been no more movement on this problem in the core functionality of Impress.

(In reply to comment #15)
> I'm sure you don't really care, but I'm done with LO as a result of this
> bug. It's been 8 months, and there's been no more movement on this problem
> in the core functionality of Impress.

The problem still exists in LO 4.2.4 and I'm feel the same as Adam.
This bug ruins Impress and makes it impossible to use for serious presentations.

It might be helpful to have a look at the code from the guys of OO, because it's working with their presentation software.

This is a major bug - ability to display any kind of typeface correctly is a must for any office productivity software, and LibreOffice unfortunately lacks severely in this area, especially on OS X platform.

Raising importance to major if no objection.

Created attachment 103422
Document rendered on Mac with master

Ubuntu font are not by default on Mac OSX
Installing Ubuntu fonts from http://font.ubuntu.com/#charset-light
does _not_ install a 'Ubuntu Light' font. but a 'Ubuntu' font with a 'light' variation the same way that it has a Bold/Italic variations
My Mac does not list that as a 'Ubuntu Light' font had LO show the font name in italic as being 'substituted'.
The substitution chosen when the Ubuntu font is installed is Font Unbuntu, TypeFace Light.
This can be seen in the attached screenshot where the first bullet line is
in 'Unbuntu Light' (Substituted) and the rest is put explicitly in Ubuntu, typeface Light.
(The Title is in Ubuntu Regular)

Created attachment 103423
Aoo vs LO

Changed in df-libreoffice:
importance: Medium → High

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in df-libreoffice:
importance: High → Undecided
status: Confirmed → New
importance: Undecided → Unknown
status: New → Unknown

Synchronising bug status with upstream.

Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.