Calc in Raring, after update to 4.0.0~beta2-0ubuntu2, currency format changed in spreadsheets

Bug #1131893 reported by AO on 2013-02-22
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Undecided
Björn Michaelsen

Bug Description

Calc in Raring, after update to 4.0.0~beta2-0ubuntu2, currency format changed in spreadsheets.

Format is now 100,00 ""$ when it used to be 100,00 $.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libreoffice-calc 1:4.0.0~beta2-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Fri Feb 22 14:00:41 2013
MarkForUpload: True
ProcEnviron:
 LANGUAGE=fr_CA:fr
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Problem description: Cell rendering differs from Version 3.6.4.3

Steps to reproduce:
1. Create a new spreasheet with Version 3.6.4.3
2. Set value of cell A1 to 1000
3. Set the cell number formatting to

[>0]"+"0,00;[<0]-0,00;#

(French version, decimal separator is a comma)
4. Save document
5. Open it with Version 4.0.0.1beta

Current behavior:
Cell is rendered as +"1000,00

Expected behavior:
Cell should be rendered as +1000,00
[i.e. without the double quote character, as it is with version 3.6.4.3]

Additional comment: maybe the problem is in the format string itself (shouldn't contain the quotes characters), but it worked with version 3.6.4.3

Operating System: All
Last worked in: 3.6.4.3 release

I confirm this bug.
Platform :
Vista and Windows 7 64bits

*** Bug 58190 has been marked as a duplicate of this bug. ***

*** Bug 58268 has been marked as a duplicate of this bug. ***

*** Bug 58374 has been marked as a duplicate of this bug. ***

I have added attachments to bug 58374 ...
(*) typescript with messages from recent master
(*) image of dialog box Format Cells from 3.6.4.3
(*) image of dialog box Format Cells from 4.0.0beta1

Taking this.

Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9525bf5c0704c7a27b3ee6249d33d875abb51bc1&g=libreoffice-4-0

resolved fdo#58179 ImpSvNumberformatScan::RemoveQuotes: both ...

It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91d3c0ce2b808e917ee45f18f2c40a58329d2c19

resolved fdo#58179 ImpSvNumberformatScan::RemoveQuotes: both ...

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

*** Bug 57596 has been marked as a duplicate of this bug. ***

*** Bug 58512 has been marked as a duplicate of this bug. ***

With master commit id eaf3c60, pulled around 2012-12-19 12:20 UTC, the problem is gone.

*** Bug 59061 has been marked as a duplicate of this bug. ***

*** Bug 58602 has been marked as a duplicate of this bug. ***

*** Bug 58797 has been marked as a duplicate of this bug. ***

Created attachment 73134
screenshot

Screenshot of problem. if click on value, it will show as in red circle

AO (aofrl10n) wrote :
summary: - Calc in Raing after update to 4.0.0~beta2-0ubuntu2, currency format
+ Calc in Raring, after update to 4.0.0~beta2-0ubuntu2, currency format
changed in spreadsheets
description: updated

Alain-Olivier Breysse, thank you for reporting this and helping make Ubuntu better. Could you please attach an example document that demonstrates this problem?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
AO (aofrl10n) wrote :

Here you are Christopher, an example file and also a capture of how it opens on my system.
I had already noticed that when the first alpha version of LibreOffice 4 came out, and it's still happens with the released version .

AO (aofrl10n) wrote :
AO (aofrl10n) wrote :

Now with the C D E properly reformatted as currency.

zigi (ziegleka) wrote :

Hi,

  I think, it is related to this bug https://bugs.freedesktop.org/show_bug.cgi?id=58179.

I don't understand that you have made packages for beta2 release, at time when the upstream stable release was available and bring users such stupid and gratuitous problems. Now from upstream is available version 4.0.1 RC1.

Please release packages for stable version 4.0.0.

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
AO (aofrl10n) wrote :

Indeed this seems to have been fixed upstream over 2 months ago, so why pushing beta 2 into Raring when that version, beta 2, is already obsolete when the push is made?

@zigi: "I don't understand that you have made packages for beta2 release"
Sometimes even packagers have to take vacations ...
Please keep this offtopic discussion out of the bug comments.

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
zigi (ziegleka) wrote :

@Björn Michaelsen:

Of course, holidays are necessary, but it is better to delay the release and wait for a stable version, than bring users problems like this and save reported bugs. Let a be noted that in the Quantal are still packages of version 3.6.2 ~ rc2.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Fix Released

@zigi:
This is not the right place for that discussion. See also: https://lists.ubuntu.com/archives/ubuntu-devel/2013-March/036897.html
And raring is a development release, it needs early uploads, so we have time to identify and fix issues -- they unfortunately dont do that themselves.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.