LibreOffice 4beta2 .desktop files only have translations for Zulu

Bug #1131470 reported by Björn Michaelsen on 2013-02-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
High
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

see upstream for details

The .desktop files in /opt/lodev3.6/share/xdg (from package "lodev3.6" or "libreoffice3.6") only contain localisation sections for Zulu, no other translations are included for some reason.

Also, the Unity strings "New Document", "New Spreadsheet", etc. (which are included in the same files) are untranslated (or even untranslatable).

Confirmed with DEB x86 and x86-64; the Windows build seems to be unaffected. Can't test the Mac builds.

This was a regression in 3.6.0.0.beta3 (I just tested, 3.6.0.0.beta2 still seemed to have everything it should) and the problem is still present in 3.6.4.3.

(I noticed this only now because previously I had the desktop-integration from 3.5 branch installed.)

Translations still missing in 4.0.

I mean, 4.0.0 RC 1.

Andras - any chance you can look into this one ? :-) Much as we love Zulu - it seems like an odd regression ...

regression from b9c376111b7ed3137d7ff72286888e7373487142 - rewrite a horrible perl script to saner form ;-)

David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4a6f1853a2a15b938575406feada108443257536

fdo#58283 produce all translations for desktop files

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Andras - any chance of back-porting to -4-0 and -3-6 ? :-)

David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c4d36b7d6da9f9b578d903499844930f90c8faf&h=libreoffice-3-6

fdo#58283 produce all translations for desktop files

It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4ed8987530d5b6cf79075937bfb12010f3a02a21&h=libreoffice-4-0

fdo#58283 produce all translations for desktop files

It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Fixed in upstream 4.0.1

Changed in libreoffice (Ubuntu):
status: New → Fix Committed
Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Fix Released
tags: added: target-4.0.1
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package libreoffice - 1:4.0.1-0ubuntu1

---------------
libreoffice (1:4.0.1-0ubuntu1) raring; urgency=low

  [ Bjoern Michaelsen ]
  * new upstream release
    - fixes CRASH in action after Undo (LP: #785518)
    - fixes fontconfig warning (LP: #1034928)
    - fixes desktop file translations (LP: #1131470)
  * add transitionals for -presenter-console and -binfilter
  * add sessioninstaller for remaining wizards (LP: #780399)
  * merge from debian at 1:4.0.1~rc1-2
  * remaining delta on debian/control:
    - drop ${java-common-depends} from Recommends to Suggests on
      libreoffice-help-*
    - add libreoffice-gnome | libreoffice-kde Recommends on libreoffice
    - add libreoffice-style-human Suggests to libreoffice-common
    - add libreoffice-common self Conflicts with << 3.5.0
    - drop java-common-depends and java-runtime-depends from Recommends to
      Suggests on libreoffice-writer
    - add libreoffice-pdfimport Recommends on libreoffice-draw
    - drop libreoffice-core from Depends to Recommends on libreoffice-style-*
    - add libreoffice-style-human
    - add C/P/R against lo-menubar from libreoffice-gtk
    - alternatively Recommends libreoffice-style-human from libreoffice-gtk3
    - add C/R against libreoffice-core (<< 1:3.9999) from libreoffice-gnome
    - add Conflicts against libreoffice-common (<< 1:3.5.0) from python3-uno
    - add libreoffice-subsequentcheckbase
    - add libreoffice-presenter-console transitional
  * remaining delta on debian/patches:
    - add Ubuntu brand palette
    - add session-installer for Java Wizards
  * remaining delta on rules:
    - fix configure switch for human theme
    - use internal jfreereport because of huge component mismatch otherwise
    - white progressbar instead of Debian Purple (or Ubuntu orange)
    - adjust bug reporting destination for ppa builds
    - disable tests on armel, armhf, powerpc
    - enable parallel build and mergelibs
    - disable evolution
    - use internal liblangtag for now
    - disable help building on armel/armhf
    - Ubuntu backport fixes
    - reduced l10n for ppa builds
    - alternatively allow firefox-dev to xulrunner-dev as build-dep
    - warn early on GVFS and GIO in same build
    - generate transitionals
    - generate subsequentcheckbase
    - fix missing closing para wrt slide remote
    - move sessioninstaller from -gtk to -gnome for gio deps
    - move subsequentcheckbase jars to package
    - use --with-all-tarballs in addition to our flags for getting the source
      - this is so that ./configure doesnt stumble over other checks
        (e.g. still needing gnomevfs)
  * removed delta:
    - drop libreoffice-filter-mobiledev and ttf-sil-gentium-basic from Depends
      to Suggests on libreoffice
    - remove libreoffice-core postinst
    - fixed gnu make version
    - remove hotfixes get-orig-sources hack
    - some whitespace
  * silent some lintian noise for unversioned breaks:
    - promote Breaks to Conflicts against -binfilter as it will never return
    - promote Breaks to Conflicts from langpacks against en-US
    - remove Breaks against -style-industrial which is long gone
  * libreoffice-core already ...

Read more...

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.