Search and replace, with tracked changes on, changing only format of text, causes Writer to hang

Bug #1126858 reported by Christopher Barrington-Leigh on 2013-02-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Medium
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Create new text document with contents "Hello, World".
Turn on change tracking (under Edit).
Select Find and Replace (under Edit).
Put "Hello" (no quotes) in both the find and the replace boxes.
Click on "More".
Put cursor in Replace box.
Click on Format.
Set it to, say Italic (leave other options empty). Accept.

And now, for the fatal part: Click "Replace all".
If you just replace one, you'll see why the latter fails. The replacement value gets inserted beofre the original, so then it continues on and sees the original again... ad infinitum.

What should happen: If it just put its position after the original text when searching and replacing, it wouldn't have this problem.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.5.0-23.35-generic 3.5.7.2
Uname: Linux 3.5.0-23-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
Date: Fri Feb 15 21:37:14 2013
InstallationDate: Installed on 2012-12-13 (65 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

sam wytoski (sam-wytoski) wrote :

i have followed your steps through trying to recreate this bug.
using:
libreoffice-writer 1:3.6.2~rc2-0ubuntu4
Ubuntu 12.10 (quantal)
gnome 3.6.0 (Ubuntu 2012-10-04)
kernel 3.5.0-24-generic (#37-Ubuntu SMP Thu Feb 7 01:50:30 UTC 2013)
amd64

i was unable to recreate this bug with my system

Changed in libreoffice (Ubuntu):
status: New → Incomplete

I just tried again and find the same results I advertised.
Why does my first entry not specify the version of LibreOffice?
The "Help-About" box in LibreOffice says: Version 3.6.2.2 (Build ID: 360m1(Build:2))

So.. Since my report said "not installed" (ie I was just using the Libreoffice that came with the distro, rather than as its own package??)

So I installed LibreOffice, redid my test (same result)
And the Help-About box says the same thing, too.

Changed in libreoffice (Ubuntu):
status: Incomplete → Opinion
status: Opinion → Incomplete
status: Incomplete → New

Christopher Barrington-Leigh, thank you for reporting this and helping make Ubuntu better. Could you please demonstrate how to reproduce this bug with a screencast via https://help.ubuntu.com/community/Screencast ?

Changed in libreoffice (Ubuntu):
status: New → Incomplete

Righto. Here it is, just as described.

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid

Hi Christopher Penalver.

The application locks up and I have to destroy the process. Maybe could you explain why you are saying there's no infinite loop? I gave both a theory for why it happens and evidence of it happening, so more explanation from you to explain my mistake would be kind.

Christopher Barrington-Leigh, I beg your pardon as my previously rationale was incorrect. This issue is reproducible in Xubuntu as demonstrated in your screencast. Hence, the issue you are reporting is an upstream one. It would be nice if somebody having it could send the bug to the developers of the software by following the instructions verbatim at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about the status. Thanks in advance.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

 lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.0.2-0ubuntu1
  Candidate: 1:4.0.2-0ubuntu1
  Version table:
 *** 1:4.0.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status

Version: 4.2.0.0.alpha0+
Build ID: 979def88090633bfee0e0445b19999a1dac71ed
Microsoft Windows Vista Business x86 6.0.6002 Service Pack 2 Build 6002

Status -> Triaged
Importance -> Medium

Changed in libreoffice (Ubuntu):
status: Invalid → Confirmed
summary: - text: Search and replace, with tracked changes on, when changing only
- format of text, causes fatal infinite loop
+ Search and replace, with tracked changes on, changing only format of
+ text, causes Writer to hang
tags: added: raring

Create new text document with contents "Hello, World".
Turn on change tracking (under Edit).
Select Find and Replace (under Edit).
Put "Hello" (no quotes) in both the find and the replace boxes.
Click on "More".
Put cursor in Replace box.
Click on Format.
Set it to, say Italic (leave other options empty). Accept.

And now, for the fatal part: Click "Replace all".
If you just replace one, you'll see why the latter fails. The replacement value gets inserted beofre the original, so then it continues on and sees the original again... ad infinitum.

What should happen: If it just put its position after the original text when searching and replacing, it wouldn't have this problem.

Reproducible in:
Version: 4.2.0.0.alpha0+
Build ID: 979def88090633bfee0e0445b19999a1dac71ed
Microsoft Windows Vista Business x86 6.0.6002 Service Pack 2 Build 6002

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged

Still Reproducible in: 4.5.0.0.alpha0+
a8835936e9d3e19443c63b7b365174254741cf76

Still reproducible in

Version: 5.0.5.2
Build ID: 1:5.0.5~rc2-0ubuntu2
Locale: en-CA (en_CA.UTF-8)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.