[Upstream] I/O Error while opening file from WebDAV over GVFS from Nautilus

Bug #1100190 reported by Philipp Gassmann on 2013-01-16
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Medium
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Problem description:
Error when opening a file from Nautilus with LibreOffice when the file is WebDAV mounted with GVFS.

The Same file can be opened from the same location from within LibreOffice, with the Open File Dialogue. Then you get asked for the Username and Password and Libreoffice seems to access the file directly over HTTP.

Steps to reproduce:
1. Mount a DAV Folder with Nautilus.
URL in my Case: dav://admin@10.1.10.58:8080/alfresco/webdav/Sites/puzzletest/documentLibrary/Alfresco%20WebDAV%20Test/
2. Open a file with LibreOffice by doubleclick or context menu from Nautilus.
4. Error occurs.
Exact message:
(-) «General input/output error while accessing /home/pgassmann/.gvfs/WebDAV\ als\ admin\ auf\ 10.1.10.58%3A8080/Sites/puzzletest/documentLibrary/Alfresco\ WebDAV\ Test/Neu.odt.» [OK]

Working Variant:
1. = 1. above
2. Start LibreOffice
3. Open File dialogue from LibreOffice
4. Select the same file and click Open.
5. LibreOffice Dialogue: "Authentication Required", Enter user name and password for: "Alfresco DAV Server" on 10.1.10.58
6. Enter Username and password, click OK
7. File opens correctly

LibreOffice Version:
3.5.2-2ubuntu1

Involved Software:
LibreOffice, Nautilus, GVFS, Alfresco

Current behavior:
Opening file from Nautilus causes Error,
Opening from LibreOffice Open File dialogue asks for credentials and works correctly

Expected behavior:
Opening from Nautilus works.
Opening from Open File dialog works without asking for credentials.

Attachment: strace log from following actions:
LANG=C libreoffice --strace
successfully Open File from LibreOffice dialogue.
Trying to open file from Nautilus.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice 1:3.5.4-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.2.0-36.57-generic 3.2.35
Uname: Linux 3.2.0-36-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Wed Jan 16 10:05:05 2013
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MarkForUpload: True
SourcePackage: libreoffice
UpgradeStatus: Upgraded to precise on 2012-05-22 (238 days ago)

Created attachment 73097
strace log

Problem description:
Error when opening a file from Nautilus with LibreOffice when the file is WebDAV mounted with GVFS.

The Same file can be opened from the same location from within LibreOffice, with the Open File Dialogue. Then you get asked for the Username and Password and Libreoffice seems to access the file directly over HTTP.

Steps to reproduce:
1. Mount a DAV Folder with Nautilus.
URL in my Case: dav://admin@10.1.10.58:8080/alfresco/webdav/Sites/puzzletest/documentLibrary/Alfresco%20WebDAV%20Test/
2. Open a file with LibreOffice by doubleclick or context menu from Nautilus.
4. Error occurs.
Exact message:
(-) «General input/output error while accessing /home/pgassmann/.gvfs/WebDAV\ als\ admin\ auf\ 10.1.10.58%3A8080/Sites/puzzletest/documentLibrary/Alfresco\ WebDAV\ Test/Neu.odt.» [OK]

Working Variant:
1. = 1. above
2. Start LibreOffice
3. Open File dialogue from LibreOffice
4. Select the same file and click Open.
5. LibreOffice Dialogue: "Authentication Required", Enter user name and password for: "Alfresco DAV Server" on 10.1.10.58
6. Enter Username and password, click OK
7. File opens correctly

LibreOffice Version:
3.5.2-2ubuntu1

Involved Software:
LibreOffice, Nautilus, GVFS, Alfresco

Current behavior:
Opening file from Nautilus causes Error,
Opening from LibreOffice Open File dialogue asks for credentials and works correctly

Expected behavior:
Opening from Nautilus works.
Opening from Open File dialog works without asking for credentials.

Attachment: strace log from following actions:
LANG=C libreoffice --strace
Open File from LibreOffice dialogue.
Trying to open file from Nautilus.

Operating System: Ubuntu
Version: 3.5.2 release

Philipp Gassmann (phiphi.g) wrote :
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed

I guess I can confirm this bug also for LibreOffice 4.0.4.2 and for owncloud instead of Alfresco.

I get:

General input/output error while accessing
/home/christian/.gvfs/dav:host=cloud.balticfinance.com,ssl=true,prefix=%2Fowncloud%2Ffiles%2Fwebdav.php/Shared/somefolder/test.ods.

Using the Open File dialogue from LibreOffice gives me the same results as in the original bug report.

In addition (I'm not sure if this is the same bug), I can't create a new file on the WebDav share. I get:

Error saving the document Untitled1:
https://cloud.balticfinance.com/owncloud/files/webdav.php/Shared/somefolder/test/test2.ods does not exist.

followed by a:

Error saving the document Untitled1:
General Error.
General input/output error.

And then by a frozen LibreOffice - restarting Ubuntu or killing the soffice.bin process are the only options to get out of here.

Can confirm on Ubuntu 13.04 with LibreOffice 4.0.2.2
and owncloud 5.0.9
is there anything one could further help?a

Can confirm on Ubuntu 13.04 with LibreOffice 4.0.2.2
and owncloud 5.0.9
is there anything one could further help?a

The situation changed with LibreOffice 4.1.0.4.

It works now, but it is still useless for productive work.

LibreOffice now opens documents on an WebDav connection, but it asks for the connection passowrd once per session.
So if you open this document, work with it, close it open another document, close it and so on you end up constantly having to type in your password.

If you keep one document open - to not end the current session you don't need to reenter the password.

I'm not sure if this is still the same bug or a new bug, but for us it is still more or less useless as people get very frustrated with having to enter the password constantly.

Changed in df-libreoffice:
status: New → Confirmed

Note: I am seeing the same bug, but in a slightly different setup:

* Ubuntu 13.04 up to date
* The server is jackrabbit stable
* If I mount it from nautilus with "connect to server" it fails most I/O operations with "I/O Error", including things like 'ls -l', as stat of each node fails.
* If I mount it as "sudo mkdir /media/jackrepo; sudo mount -t davfs 'http://localhost:8080/repository/default' /media/jackrepo" is works like a charm, including stat (ls -l) or opening fragments of a video

So I don't think the bug is at Libreoffice, but at the gvfs layer instead

l0co (l0co) wrote :

> So I don't think the bug is at Libreoffice, but at the gvfs layer instead

I don't think so. Our customer working on Windows (no gvfs) reports the same problem for Libre Office 4.1.3.2. The Windows version of Libre Office cannot open a proper https:// webdav link, that is accessible on the same machine from other application (like web browser). We give the direct https:// link to the libre office command line, from the webdav server served by our application, there are no other layers involved. Everything was working by years, but not after LO upgrade to >= 4 version.

summary: - I/O Error while opening file from WebDAV over GVFS from Nautilus
+ [Upstream] I/O Error while opening file from WebDAV over GVFS from
+ Nautilus
Patrick Hetu (patrick-hetu) wrote :

I found that adding the line: X-GIO-NoFuse=true in the .desktop solves the problem.

I can confirm the behavior described from Christian Krützfeldt on Ubuntu 14.10 / LibreOffice 4.3.3.2

I am asked for my password everytime i open any document with LibreOffice on the WebDAV share mounted via Nautilus.

This is pretty annoying if you are using two factor authentication (generate a one-time password for your WebDAV connections) like for example Google is offering.

I can confirm this bug too on Ubuntu 14.04 and LibreOffice 4.2.7.2

Using owncloud webdav.

Error description:
receiving "general input/output error" when trying to load a document from a Nautilus davs folder.

Workaround:
Open the document in LibreOffice using "File/Open".

However it is not very user friendly for network users.

JKOOL (jkool) wrote :

Confirm its still an issue with Ubuntu 14.04LTS and LO 4.2.8.2

Markus Windisch (d-spam-a) wrote :

I can't believe this is still a problem. I found a "solution": use dolphin instead. Dolphin has some other issues, though. I really wonder how people can constantly work with Linux. You have to be really lucky (not using Webdav or something).

Now I'm sitting here copying my files from webdav to the local drive like it's 1990 and an FTP-Server.

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug

3. Leave a comment with your results.

4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16

Tareef (tareef) wrote :

Confirm its still an issue with Fedora 23 and LO 5.0.6.2

Guillermo Lo Coco (glococo) wrote :

I confirm the GVFS issue with SMB shares.

https://bugs.documentfoundation.org/show_bug.cgi?id=72504
https://ask.libreoffice.org/en/question/69586/error-opening-odb-from-url-share-linux/
http://askubuntu.com/questions/768533/odb-base-error-opening-from-smb-share

GVFS shares are much more flexible and today I can't open an ODB from an SMB share.

(Ubuntu 16.04, LO Build ID: 1:5.1.2-0ubuntu1

Confirmed and still broken in 5.3.4 using NextCloud over DAVS. Work around is very clunky for end users for sure. I had a suspicion that the issue was related to the GVFS file name mapping. But I replicated the file name on a physical part of the disk and it worked. So this confirms the issue is actually with GVFS in some way.

Created attachment 133933
Strace log on failure

I perceive strace is showing the issue:

poll([{fd=13, events=POLLIN}, {fd=14, events=POLLIN}], 2, 8118) = 1 ([{fd=14, revents=POLLIN}])
access("/run/user/413/gvfs/dav:host=content.largo.com,ssl=true,prefix=%2Fremote.php%2Fwebdav/Private Documents/About.odt", F_OK) = 0
access("/run/user/413/gvfs/dav:host=content.largo.com,ssl=true,prefix=%2Fremote.php%2Fwebdav/Private Documents/About.odt", F_OK) = 0
lstat("/run/user/413/gvfs/dav:host=content.largo.com,ssl=true,prefix=%2Fremote.php%2Fwebdav/Private Documents/About.odt", {st_mode=S_IFREG|0700, st_size=76746, ...}) = 0
open("/run/user/413/gvfs/dav:host=content.largo.com,ssl=true,prefix=%2Fremote.php%2Fwebdav/Private Documents/About.odt", O_RDWR|O_EXCL) = -1 EOPNOTSUPP (Operation not supported)
access("/run/user/413/gvfs/dav:host=content.largo.com,ssl=true,prefix=%2Fremote.php%2Fwebdav/Private Documents/About.odt", F_OK) = 0
lstat("/run/user/413/gvfs/dav:host=content.largo.com,ssl=true,prefix=%2Fremote.php%2Fwebdav/Private Documents/About.odt", {st_mode=S_IFREG|0700, st_size=76746, ...}) = 0

to me, it looks like it thinks this is a local disk and it's trying to get an exclusive lock?

Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3a4dacfa0aae3cf40aa7b123672c6bc197efe0f

tdf#59424 unset open flag O_EXCL if O_CREAT is not set

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.

Polite ping: is this bug fixed? if so, please close it as RESOLVED FIXED

Confirmed an issue on Ubuntu 17.10 and Libreoffice 5.4.1.2. When opening a document through Webdav the Libreoffice splash appears but nothing else happens. When opening through a fuse filesystem mounted throuh rclone this error dialogue appears: "General input/output error while accessing /path/to/file.doc"

A polite ping to Tomaž Vajngerl: is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks

(In reply to Dave Richards from comment #10)
> open("/run/user/413/gvfs/dav:host=content.largo.com,ssl=true,
> prefix=%2Fremote.php%2Fwebdav/Private Documents/About.odt", O_RDWR|O_EXCL) =
> -1 EOPNOTSUPP (Operation not supported)

H. C. commented the following in bug 109520 comment 7:

> Libreoffice opens the file with O_RDWR. Gvfs mounts only support opening
> files with O_TRUNC or O_APPEND. But not O_RDWR by itself.
>
> See...
>
> https://bugzilla.gnome.org/show_bug.cgi?id=748106
> https://bugzilla.gnome.org/show_bug.cgi?id=777152
>
> You will get an "operating not permitted" error which shows up in
> libreoffice as "general input/output error".

*** Bug 112024 has been marked as a duplicate of this bug. ***

*** Bug 109520 has been marked as a duplicate of this bug. ***

** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3
. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.