Ubuntu

[Regression] Libreoffice 3.5.7 could not open CODIT.xls, Libreoffice 3.5.4 could: CSV box

Reported by Mozaic on 2012-12-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Invalid
Medium
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

1) Go to http://travail-emploi.gouv.fr/espaces,770/travail,771/dossiers,156/travail,309/recodification-du-code-du-travail,1090/outils-pour-s-approprier-le,1098/l-outil-cod-it,7726.html
2) Downlaod CODIT version octobre 2012 (xls - 13.7 Mo) (http://travail-emploi.gouv.fr/IMG/xls/codit_2octobre2012.xls)
3) Try to open it with LibreOffice 3.5.7.2 (from ppa : http://ppa.launchpad.net/libreoffice/libreoffice-3-5/ubuntu )
4) I have a box to import the text (like CSV, see the screencast)

Expected:
 To have the same behavior with LibreOffice 3.5.4.2: open the document correctly.

DistroRelease: Ubuntu 12.04.1
Package: libreoffice-core 1:3.5.7-0ubuntu1~precise3
Uname: Linux-generic 3.2.0.34.37 x86_64
Architecture: amd64
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
SourcePackage: libreoffice

Mozaic (mozaic) wrote :
Mozaic (mozaic) wrote :
description: updated

Mozaic, thank you for taking the time to report this bug and trying to help make Ubuntu better. However, the LibreOffice PPA is not a software package provided by the official Ubuntu repositories. Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of the software package. Thanks!

If you are interested in learning more about software repositories and Ubuntu the following pages should be informative:

1. http://www.ubuntu.com/project/about-ubuntu/components - information about Ubuntu repositories
2. https://help.ubuntu.com/community/Repositories - information regarding managing repositories

Changed in libreoffice (Ubuntu):
status: New → Invalid
Mozaic (mozaic) wrote :

@ penalvch: http://www.ubuntu.com/project/about-ubuntu/components -> 404 error

I prefere to create a new bug and i follow it to Björn Michaelsen who creat this ppa (https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1037111). If my memory is good, Björn Michaelsen work for Canonical, no ??

Changed in libreoffice (Ubuntu):
status: Invalid → New
Mozaic (mozaic) wrote :

Tested with official LibreOffice DEB (3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b) on Ubuntu 12.04.1 and i reproduce, i try to create a bug on bugs.freedesktop.org

Mozaic, quoting from https://launchpad.net/~libreoffice/+archive/ppa :
"For questions and bugs with software in this PPA please contact LibreOffice Packaging."

Changed in libreoffice (Ubuntu):
status: New → Won't Fix

1) Go to http://travail-emploi.gouv.fr/espaces,770/travail,771/dossiers,156/travail,309/recodification-du-code-du-travail,1090/outils-pour-s-approprier-le,1098/l-outil-cod-it,7726.html
2) Downlaod CODIT version octobre 2012 (xls - 13.7 Mo) (http://travail-emploi.gouv.fr/IMG/xls/codit_2octobre2012.xls)
3) Try to open it with LibreOffice 3.5.7.2 (from website http://fr.libreoffice.org/telecharger/)
4) I have a box to import the text (like CSV, see the screencast)

Expected:
 To have the same behavior with LibreOffice 3.5.4.2 (from Ubuntu, install by default): open the document correctly.

DistroRelease: Ubuntu 12.04.1
3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
 Linux-generic 3.2.0.34.37 x86_64
Architecture: amd64

Created attachment 71402
Screencast of the box

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New

vulcain:

As per http://wiki.documentfoundation.org/ReleasePlan#3.5_release the 3.5.x branch is no longer supported. Please update to a supported branch, and if this problem is reproducible, feel free to reopen this report.

Not reproducible in:
Microsoft Windows Vista Business x86
6.0.6002 Service Pack 2 Build 6002
Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)

Changed in df-libreoffice:
status: New → Invalid

In VirtualBox (Ubuntu 12.04) i make try to install LibO from http://downloadarchive.documentfoundation.org/libreoffice/old/ (after, i delet the Libreoffice's Ubuntu and install only LibO_3.X.Y_Linux_x86-64_install-deb_en-US.tar.gz, no lanpack or helpack). Result:

LibreOffice 3.5.4.2 Build ID: 165a79a-7059095-e13bb37-fef39a4-9503d18
Ok

LibreOffice 3.5.5.3 Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21
Ok

LibreOffice 3.5.6.2 Build ID: e0fbe70-5879838-a0745b0-0cd1158-638b327
No

LibreOffice 3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
No

I confirm, that we could open the file with:
* Libo 3.6.2.2 (Build ID:360m1 (build2)) from Ubuntu 12.10.It's the pakage from Ubuntu
* LibreOffice 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7) on Ubuntu 12.04.1
* Apache OpenOffice.org 3.4.1 AOO341m1 (Build:9593) - Rev 1372282 2012-08-13 06:23:26 (Mon, 13 Aug 2012 - Linux x86_64 on Ubuntu 12.10

Introduced between 3.5.5 and 3.5.6.

Mozaic (mozaic) wrote :

Don't reproduce with version 1:3.5.7-0ubuntu3~ppa1

\o/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.