Bit Fields appear as Varchar using libreoffice-mysqlconnector

Bug #1086357 reported by Allan Kelly on 2012-12-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

After changing from using ODBC to MySQL Connector extension to connect to MySQL databases, I noticed some columns defined as Bit fields did not behave correctly. Field data would not modify.

Editing the tables in Libreoffice I have found that columns which are defined as Bit in MySQL are shown as Field Type text VARCHAR .

Ubuntu 12.04
libreoffice 1:3.5.4-0ubuntu1.1 (LibreOffice 3.5.4.2 Build ID: 350m1(Build:2))
libreoffice-mysql-connector 1.0.1+LibO3.5.4-0ubuntu1.1
mysql-client 5.5.28-0ubuntu0.12.04.2
mysql-server 5.5.28-0ubuntu0.12.04.2
---
ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
NonfreeKernelModules: nvidia
Package: libreoffice 1:3.5.4-0ubuntu1.1
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.2.0-34.53-generic 3.2.33
Tags: precise running-unity
Uname: Linux 3.2.0-34-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Allan Kelly (wolasallank) wrote :

Problem also occurs on my testing Ubuntu 12.10 system
libreoffice 1:3.6.2~rc2-0ubuntu4
libreoffice-mysql-connector 1.0.1+LibO3.6.2~rc2-0ubuntu4
mysql-client 5.5.28-0ubuntu0.12.10.1
mysql-server 5.5.28-0ubuntu0.12.10.1

Allan Kelly, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect BUGNUMBER
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Allan Kelly (wolasallank) wrote :

Tried the command. Browser window opened requesting authorisation. I selected allow for an hour.
Email with subject OAuth token generated in Launchpad received, presumably authorisation successful.

A popup was shown "No Additional Information Collected"

Command output:

allan-u@AMD-Desktop:~$ apport-collect 1086357
The authorization page:
 (https://launchpad.net/+authorize-token?oauth_token=xxxxxxxxxxxxxxxxxx&allow_permission=DESKTOP_INTEGRATION)
should be opening in your browser. Use your browser to authorize
this program to access Launchpad on your behalf.
Press any key to continue or wait (5) seconds...
Waiting to hear from Launchpad about your decision...
Created new window in existing browser session.
Package libreoffice not installed and no hook available, ignoring
allan-u@AMD-Desktop:~$ apport-collect 1086357
Package libreoffice not installed and no hook available, ignoring
allan-u@AMD-Desktop:~$

Where do we go from here?

apport information

tags: added: apport-collected precise running-unity
description: updated
Allan Kelly (wolasallank) wrote :

Found what I had to run to fix
"Package libreoffice not installed and no hook available, ignoring"

apport collect seems to have run successfully now.

Changed in libreoffice (Ubuntu):
status: Incomplete → New
Allan Kelly (wolasallank) wrote :

Since 2012 I have worked around this issue by using ODBC to connect to MySQL from LibreOffice.

However I have now upgraded to Ubuntu 16.04 which no longer has the ODBC package libmyodbc so I have had to revert to the mysql connector to allow connecting tC MySQL tables using LibreOffice Base

Columns defined Bit(1) in MySQL still show incorrectly as VarChar in LibreOffice Base and cannot be maintained via LibreOffice Base.

I have found a workable alternative. In Base, if I edit the table column and change the column type Yes/No Boo, the table column type updates to TinyInt. The column still provides the flag capability in my queries and can now be updated in Base via Tables or Forms.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers