localc crashes when trying to open attached .ods file

Bug #1079112 reported by Ulf Mehlig on 2012-11-15

This bug report will be marked for expiration in 53 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

2) apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.6.2~rc2-0ubuntu3
  Candidate: 1:3.6.2~rc2-0ubuntu3
  Version table:
     1:3.6.2~rc2-0ubuntu4 0
        400 http://archive.ubuntu.com/ubuntu/ quantal-proposed/main i386 Packages
 *** 1:3.6.2~rc2-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in Calc via a terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1079112/+attachment/3434164/+files/test.ods && localc --nologo test.ods

is the file opens successfully.

4) What happens is it crashes consistently.
Back trace: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1079112/+attachment/3435230/+files/backtrace.txt

WORKAROUND: Open with Gnumeric.

apt-cache policy gnumeric
gnumeric:
  Installed: 1.10.17-1.1ubuntu1
  Candidate: 1.10.17-1.1ubuntu1
  Version table:
 *** 1.10.17-1.1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/universe i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: libreoffice (not installed)
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Thu Nov 15 07:21:45 2012
EcryptfsInUse: Yes
InstallationDate: Installed on 2010-12-09 (706 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MarkForUpload: True
SourcePackage: libreoffice
UpgradeStatus: Upgraded to quantal on 2012-10-25 (20 days ago)

Ulf Mehlig (umehlig) wrote :

Ulf Mehlig, thank you for reporting this and helping make Ubuntu better. However, your crash report is missing. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer. One may execute at a terminal:
cd /var/crash && sudo rm * && sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-dbg uno-libs3-dbg ure-dbg && sudo service apport start force_start=1

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now reproduce the crash, then open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'. Please follow https://wiki.ubuntu.com/LibreOfficeBugWrangling when you file this crash report so the necessary information is provided.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently.

Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

Changed in libreoffice (Ubuntu):
status: New → Invalid

Cut from Bug Description.

description: updated

Ulf Mehlig, thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions verbatim at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about the status. Thanks in advance.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

Marking Triaged Medium due to sidebar with Ulf Mehlig as he has no free space on his HDD, and issue is reproducible.

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: Invalid → Triaged
summary: - localc crashes when trying to open a specific (possibly damaged) .ods
- file
+ localc crashes when trying to open attached .ods file

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in libreoffice (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers