LibreOffice Calc main menu bar disappears

Bug #1069909 reported by Peter Velosy on 2012-10-22
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

I recently opened some Excel documents with this version of LibreOffice Calc. At random times the main menu bar became invisible (see attached screenshot), minimizing/restoring the window didn't help either. I only experienced this issue when opening one of the Excel files sent to me, I'm also attaching a file that triggered this behaviour.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: libreoffice-calc 1:3.6.2~rc2-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
Date: Mon Oct 22 18:36:16 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

Peter Velosy (petervelosy) wrote :
Peter Velosy (petervelosy) wrote :

So this is the Excel file that triggered the problem. On the attached screenshot you can see that the window's main bar doesn't display the menu if you hover the mouse over it. Actions causing the window to repaint don't help either. Until now I was unable to identify the action that triggers this behaviour, it seems to be quite random...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2012-10-23
tags: added: lovclmenubar
Apfelfrisch (n-refle) wrote :

Same here with any csv-files that opened with "Text-Import".

Apfelfrisch (n-refle) wrote :

P.s. This happends only when i open the file direkly via doubleclick. Open the file from Calc->file->open works fine here.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
Sauli (saulik) wrote :

The menus seems to disappear with native Libreoffice calc files too. This started after upgrade to Ubuntu 12.10.
First everything may work fine but after a while the problem appears. Closing the spreadsheet and reopening it often helps.

The bug appears with old (pre 12.10) files as well as with brand new files.

I believe this may be related to an other new 12.10 calc bug where the menu actions don't work even the menu bar is visible and accessible. After opening a menu and selecting any action nothing happens.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers