soffice.bin crashed with SIGSEGV in lucene::index::IndexFileNames::fileNameFromGeneration()

Bug #1062448 reported by Paul Larson
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Fix Released
High
Björn Michaelsen
Quantal
Won't Fix
High
Björn Michaelsen
Raring
Fix Released
High
Björn Michaelsen
ubuntu-meta (Ubuntu)
Fix Released
High
Oliver Grawert
Quantal
Fix Released
High
Oliver Grawert
Raring
Fix Released
Undecided
Unassigned

Bug Description

PandaBoard, launching openoffice after installation from 20121005 image and update. When I try to launch any of the libreoffice apps, the splashscreen comes up, but then it crashes.

Reproducible every time I try to start it.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: libreoffice-core 1:3.6.1~rc2-1ubuntu5
ProcVersionSignature: Ubuntu 3.5.0-212.19-omap4 3.5.4
Uname: Linux 3.5.0-212-omap4 armv7l
ApportVersion: 2.6.1-0ubuntu1
Architecture: armhf
Date: Fri Oct 5 12:30:58 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta armhf+omap4 (20121005)
ProcCmdline: /usr/lib/libreoffice/program/soffice.bin --writer --splash-pipe=6
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: libreoffice
StacktraceTop:
 ?? () from /usr/lib/libreoffice/program/../program/libclucene.so
 lucene::index::IndexFileNames::fileNameFromGeneration(char const*, char const*, long long) () from /usr/lib/libreoffice/program/../program/libclucene.so
 ?? ()
 ?? ()
Title: soffice.bin crashed with SIGSEGV in lucene::index::IndexFileNames::fileNameFromGeneration()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Paul Larson (pwlars) wrote :
Paul Larson (pwlars)
visibility: private → public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

Does the problem persist when you uninstall libreoffice-pdfimport libreoffice-presenter-console libreoffice-mysql-connector libreoffice-presentation-minimizer?

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

Same root cause as the ftbfs for 3.6.2 which moved the help index generation for extensions from first start into the build.

Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

FFE documentation:

proposed changes:
With 3.6.2 this fails already during the build. To evade the ftbfs, the extensions are not build on armel/armhf.

rationale:
The real solution is fixing https://bugs.launchpad.net/ubuntu/+source/clucene-core/+bug/1042192, but it is too late for that now. Not building the extensions at least gives us a libreoffice build with the core components.

Revision history for this message
Kate Stewart (kate.stewart) wrote :

FFE approved. Since this is a default package, need to have something to fix at least on the release.

Changed in libreoffice (Ubuntu Quantal):
importance: Undecided → High
status: Confirmed → Triaged
Revision history for this message
Paul Larson (pwlars) wrote :

libreoffice-mysql-connector was not installed by default, but I removed all the others and the problem does go away

Oliver Grawert (ogra)
Changed in ubuntu-meta (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Oliver Grawert (ogra)
milestone: none → ubuntu-12.10
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.287

---------------
ubuntu-meta (1.287) quantal; urgency=low

  * Refreshed dependencies (LP: #1062448)
  * Removed libreoffice-pdfimport from desktop-recommends [armel armhf]
  * Removed libreoffice-presentation-minimizer from desktop-recommends
    [armel armhf]
  * Removed libreoffice-presenter-console from desktop-recommends [armel
    armhf]
 -- Oliver Grawert <email address hidden> Tue, 09 Oct 2012 19:30:35 +0200

Changed in ubuntu-meta (Ubuntu Quantal):
status: Triaged → Fix Released
tags: removed: rls-q-incoming
Changed in libreoffice (Ubuntu Quantal):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in libreoffice (Ubuntu Quantal):
status: Triaged → Won't Fix
Revision history for this message
Brian Murray (brian-murray) wrote :

This fix exists in Raring.

Changed in ubuntu-meta (Ubuntu Raring):
status: New → Fix Released
Revision history for this message
Apport retracing service (apport) wrote : No launchpad retracing

Unsetting the need retracing tag. The crash report is too old to be processed by Apport, we did not have the ability to process crashes for the ARM platform until now.

tags: removed: need-armhf-retrace
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :

No issues with lucene to be found on errors.ubuntu.com on raring or later, so closing until further notice.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
Changed in libreoffice (Ubuntu Raring):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers