Linux Libertine & Libreoffice 3.5 distorted printing

Bug #1018069 reported by staedtler-przyborski on 2012-06-26
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

Linux Libertine 5.1.3 and Libreoffice 3.5.x (I've tested 3.5.3 and 3.5.4) don't play well together. On screen everthing looks nice, but on printout the distances between the letters are completly distored. The printout is hard to read and looks ugly. I've seen this on all our machines (at the moment 7) where Ubuntu 12.04 is installed. Printer is always a Brother MFC 8640N

Older Ubuntu releases e.g. 10.04 and 11.10 (with older Libreoffice, OpenOffice and Linux Libertine, ) print as they should, as did every Ubuntu release in the past.

Solution is to use the Linux Libertine G variant from here http://www.numbertext.org/linux/index.html. Which is a 'graphite' version of Linux Libertine. Now printings of Linuxlibertine are fine again.

It looks like Libreoffice 3.5.x uses the graphite engine with Linux Libertine, regardless if the font is fittet for graphite or not.
---
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120421)
Package: libreoffice 1:3.5.4-0ubuntu1.1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
Tags: precise running-unity
Uname: Linux 3.2.0-31-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fonts-linuxlibertine (Ubuntu):
status: New → Confirmed
FriedChicken (domlyons) wrote :

Confirmed although my situation is a little different:

I had some documents created b LibreOffice on Windows. On Windows LibreOffice bundles Linux Libertine Graphite and calls the fonts "Linux Libertine G" and "Linux Biolinum G".

Opening these documents in LibreOffice on Ubuntu breaks the whole design (not only small differences, what would be normal): LibreOffice (or fontconfig?) doesn't seem to be able to map "Linux Libertine G" and "Linux Biolinum G" to "Linux Libertine" and "Linux Biolinum". So it applies some default fonts (but not "Linux Libertine" and "Linux Biolinum" although they are my LibreOffice default fonts). The font replacement in LibreOffice also does not help as it can only replace known fonts.

Manually installing the Graphite font package solved this problem This is why I did not open a new bug, as there seems to be a common solution and therefore probably also a common cause.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
FriedChicken (domlyons) wrote :

LibreOffice should have the Linux Libertine Graphite package as dependency to keep compatibility to LibreOffice on Windows, which bundles the Graphite fonts.

Therefore I set this also as a bug for LibreOffice.

staedtler-przyborski, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect BUGNUMBER
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

As well, could you please provide an example document, that when printed, demonstrates the problem?

no longer affects: fonts-linuxlibertine (Ubuntu)
Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected precise running-unity
description: updated

example document which shows distortion when printed attached

tags: added: regression-release
affects: libreoffice (Ubuntu) → cups (Ubuntu)
Changed in cups (Ubuntu):
status: Incomplete → New
Till Kamppeter (till-kamppeter) wrote :

Can you please follow the instructions of the sections "CUPS error_log" and "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems. Thanks.

Changed in cups (Ubuntu):
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

The bug description clearly describes a solution, using Linux Libertine Graphite, so it is not a cups bug. Moving back to LibreOffice.

affects: cups (Ubuntu) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: Incomplete → New

staedtler-przyborski, thank you for reporting this and helping make Ubuntu better. This is unreproducible in Xubuntu 12.10 via the terminal:
cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1018069/+attachment/3337618/+files/Urlaubsvertretung%204-2012.odt -O example.odt && lowriter --nologo example.odt

Exporting to PDF and opening in Adobe Reader, or printing to a HP Officejet 5610v All-in-One showed the correct spacing. Please answer the following questions:
+ Could you please take a picture of the offending printout and attach to this report?
+ Does this issue occur if you export to PDF? If so, could you please attach the offending PDF?
+ The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Quantal Quetzal. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Could you please make the test this and comment if this is reproducible?

Thank you for your understanding.

lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.6.2~rc2-0ubuntu3
  Candidate: 1:3.6.2~rc2-0ubuntu3
  Version table:
 *** 1:3.6.2~rc2-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy fonts-linuxlibertine
fonts-linuxlibertine:
  Installed: 5.1.3-1
  Candidate: 5.1.3-1
  Version table:
 *** 5.1.3-1 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/universe i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.5.1-1precise1
  Candidate: 9.5.1-1precise1
  Version table:
 *** 9.5.1-1precise1 0
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: New → Incomplete

I've tested a document now at home with both Ubuntu 12.04 and libreoffice 3.5.4 (up-do-date with proposed), Ubuntu 12.10 and libreoffice 3.6.2rc2 (up-to-date with proposed), printer was a HP Officejet 6100.

In both cases printout using Libertine O (the non graphite version of the font, installed by default by Ubuntu) was okay, PDF generated by LO too.

Seems I have to dig deeper with the Brother MFC8640N as printer. As soon I'm in bureau (monday perhaps) I try what happens there when I print to PDF and what happens when using Ubuntu 12.10 ( I try to set up a non-production PC with 12.10 for testing)

I've tested now a document (see attach) with Ubuntu 12.04 and libreoffice 3.5.4 and linux libertine O 5.1.3 with different printers

HP officejet 6100: OK (inkjet using PCL as language)
HP Officejet 8000 OK (inkjet using PCL as language)
Brother MFC 8640N FAIL (Laser using PS as language)
Kyocera FS C5025N FAIL (Laser using PS as language)

Seems the problem sit's inside Postcript usage ...

I tried printing to PS file and opening in Evince, but still unreproducible.

apt-cache policy evince
evince:
  Installed: 3.6.0-0ubuntu2
  Candidate: 3.6.0-0ubuntu2
  Version table:
 *** 3.6.0-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main i386 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: Incomplete → New

Still pending results of comment https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1018069/comments/9 :
>"+ Could you please take a picture of the offending printout and attach to this report?"

Changed in libreoffice (Ubuntu):
status: New → Incomplete

>"+ Could you please take a picture of the offending printout and attach to this report?"

Later this evening I provide a scanned printout. Sorry had to delete my second example - too much private information ...

Attached is example.png a scan of two printouts (Laser Kyocera FS C5025 versus Ink HP officejet 8000) for direct comparing

attached is example.odt (same as parkett.odt from #11 but without privacy informations) which was used for printout.

staedtler-przyborski, thank you for attaching the files. Regarding your Bug Description:
>"It looks like Libreoffice 3.5.x uses the graphite engine with Linux Libertine, regardless if the font is fittet for graphite or not."

+ I'm interested in how you found this. Could you please explain how you found that LO uses the graphite engine with the font Linux Libertine O?
+ As well, do you know if the font Linux Libertine O is fitted for graphite?
+ Also, should Linux Libertine O be fitted for graphite?

Marking Medium based on the picture of the problem printout.

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
status: Confirmed → Incomplete

+ I'm interested in how you found this. Could you please explain how you found that LO uses the graphite engine with the font Linux Libertine O?

It's pure intuition ;-). More serious : after I've found out that Libertine G (with Graphite) works, Libertine O (without Graphite) doesn't and LO included in the meanwhile Graphite as engine it was a counting 1+1+1=3 (in this case only 2 ;-).

Previous LO (and OOo) worked nice with our printers and libreoffice (my company uses it for all 'official' documents as superior Times replacement). Now I have to convert all existing templates (and 'reused' documents ...) to Libertine G. Not really a problem, but 1. I'm afraid I have to convert them again ... and 2. it takes more time to install Libertine G seperately on all our production machines (currently in transition from Ubuntu 10.04 to 12.04) than simply installing Libertine O from repository.

+ As well, do you know if the font Linux Libertine O is fitted for graphite?

AFAIK it is not see http://linuxlibertine.sourceforge.net/

+ Also, should Linux Libertine O be fitted for graphite?

Naturally, best would be if Libertine G from http://numbertext.org/linux/ get's merged into Libertine O from here http://linuxlibertine.sourceforge.net/

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed

You may want to know using Linux Libertine O 5.3 OTF or TTF doesn't solve the distored printing. Also Libreoffice 3.6.0.2 (latest available for Ubuntu 12.0) doesn't change anything for this bug (or abend, or issue, as you like)

BTW. Abiword is not affected, documents from there using Linux Libertine O print fine.

jhoechtl (johann-hoechtl) wrote :

This problem is unresolved as of February 2013. The solution to this problem is easy: Ubutnu should include Linux Libertine G instead of Linux Libertine O as the default package.

Same here with OpenOffice 3.2.1 under MacOS. PDF export works fine, print to HP Color Laserjet 200 corrupted.

epictete (p-latreyte) wrote :

Hello, under Ubuntu 16.04 and LibreOffice 5.1.2.2, Linux Biolinum is well displayed on the monitor but isn't printed correctly (see the first version on the left side of the attached picture file) with replacement of some characters by some other (strange) ones.

Actually the bug is solved (as previously discovered by staedtler-przyborski! thanks a lot to him!) by changing the police from Linux Biolinum to Linux Biolinum G (Graphite).

The second version on the right side of the picture in the attached file is printed with Linux Biolinum G.

P.S. I wasn't able to find somewhere on the site the command for providing the characteristics of my system (as staedtler-przyborski has done in his first post.

epictete (p-latreyte) wrote :

Exactly the same bug under Linux Mint 18 Cinnamon 3.0 LibreOffice 5.1.4.2.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers