I'm not able to install galician language in Ubuntu 16.04

Bug #1578821 reported by Marcos Lans on 2016-05-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Gunnar Hjalmarsson
Xenial
High
Gunnar Hjalmarsson
libreoffice-dictionaries (Debian)
New
Unknown
libreoffice-dictionaries (Ubuntu)
Medium
Mattia Rizzolo

Bug Description

[Impact]

Installing the Galician language via Language Support fails. The reason is that there is currently two hunspell spellchecking packages in the archive:

* hunspell-gl-es, provided by the hunspell-gl-es source package
* hunspell-gl, provided by the libreoffice-dictionaries source package

Even if hunspell-gl-es conflicts to hunspell-gl, having both of them available in the archive is not compatible with the way the writing aids is pulled via Language Selector. The proposed upload in this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/lo-dicts-symlinks

drops the hunspell-gl binary from libreoffice-dictionaries.

[Test Case]

 * Open Language Support
 * Try to install Galician

[Regression Potential]

Low.

[Original description]

Hi

I just installed Ubuntu 16.04. So as I try to install galician language I get this notification:

Transaction failed: Package dependencies cannot be resolved
 The following packages have unmet dependencies:

hunspell-gl-es:

Then nothing happens. Several fellows got the same issue.

Marcos Lans (markooss) on 2016-05-05
description: updated
description: updated
Marcos Lans (markooss) on 2016-05-05
description: updated
Manuel Xosé Lemos (mxlemos) wrote :

Same problem here.

Changed in ubuntu-translations:
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

The explanation is probably that hunspell-gl, provided by libreoffice-dictionaries, is present in 16.04, and hunspell-gl-es conflicts with the former. Suppose we should drop hunspell-gl for now.

A workaround until this has been fixed is to install the Galician translations from a terminal window:

sudo apt install language-pack-gl language-pack-gnome-gl

Then you can run the check-language-support command, and manually install the listed packages, except for hunspell-gl.

affects: ubuntu-translations → libreoffice-dictionaries (Ubuntu)
Changed in libreoffice-dictionaries (Ubuntu):
importance: Undecided → High
Marcos Lans (markooss) wrote :

Thanks Gunnar, that workaround works for me.

Antón Méixome (meixome) wrote :

Works fine, Gunnnar

Thanx for your help, and yes, for now is better not install hunspell-gl because hunspell-gl-es is more accurate and update.

Changed in libreoffice-dictionaries (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Confirmed → In Progress
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

hunspell-gl will stay in xenial-release, so we need an exception in language-selector.

Changed in libreoffice-dictionaries (Ubuntu Xenial):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → In Progress
Changed in libreoffice-dictionaries (Ubuntu):
importance: High → Medium
Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
status: New → Fix Committed
Changed in language-selector (Ubuntu Xenial):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.167

---------------
language-selector (0.167) yakkety; urgency=medium

  * language_support_pkgs.py:
    Hack to exclude hunspell-gl from the installation candidates
    (LP: #1578821).

 -- Gunnar Hjalmarsson <email address hidden> Wed, 11 May 2016 01:44:00 +0200

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released

Hello Marcos, or anyone else affected,

Accepted language-selector into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/language-selector/0.165.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in language-selector (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I installed language-selector-{common,gnome} 0.165.2 from xenial-proposed, and could successfully install Galician from Language Support.

tags: added: verification-done
removed: verification-needed
Marcos Lans (markooss) wrote :

Hi Chris,

I've just run a fresh install of Ubuntu 16.04 then I've enabled Proposed repository and I installed
language-selector-{common,gnome} 0.165.2 from xenial-proposed and I was able successfully install Galician Language again. :)

So I don't know where and how tag can be changed to verification-done.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for testing, Marcos.

On 2016-05-12 09:57, Marcos Lans wrote:
> So I don't know where and how tag can be changed to
> verification-done.

It's right below the bug description. But I already did that. ;)

Mattia Rizzolo (mapreri) wrote :

So, language-selector now has a workaround, which I think is more than enough to have this issue not affect anyone anymore.

Now, concerning lo-dicts, I think the best way forward is instead have hunspell-gl-es stop existing. This is feasible only if the maintainer agrees with me, otherwise dropping the binary from lo-dicts (or making it transitive) is just cool.

For that, there is nothing that can be done in xenial, so marking that invalid; in yakkety I'd really prefer if the package could stay in sync, so moving back to confirmed, and adding a debian task.

Changed in libreoffice-dictionaries (Ubuntu Xenial):
status: In Progress → Invalid
assignee: Gunnar Hjalmarsson (gunnarhj) → nobody
Changed in libreoffice-dictionaries (Ubuntu):
status: In Progress → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Yeah, I realized only tardily that the language-selector workaround was needed in Xenial.

Saw the Debian bug, and agree it would be the better option in the long run. Only 'problem' is that then I'll need to modify my proposed upload at bug #1574745, since it currently includes dropping of hunspell-gl. But it makes sense, so I'm going to do so.

Mattia Rizzolo (mapreri) wrote :

well, I'm taking care of bug #1574745 right now (most probably just including your patch that I'm currently testing), so you can sit tight with that :)

Gunnar Hjalmarsson (gunnarhj) wrote :

Great! But a separate upload is needed to Xenial in any case, so at least that needs to be changed.

Please let me know if you find some redundant link or something...

Mattia Rizzolo (mapreri) wrote :

I think they are fine, and indeed uploaded the patch you sent in the Debian bug as-is.
Maybe there are some redundant, but I didn't spot any (anyway, to notice them would mean knowing what those languages are, at least).
What for me was more important (Spanish in LO) is fixed, anyway.

Changed in libreoffice-dictionaries (Debian):
status: Unknown → New
Gunnar Hjalmarsson (gunnarhj) wrote :

Considering how this will be fixed in Debian, we will need to replace the hunspell-gl exception in language-selector with a hunspell-gl-es exception, so I reopen the language-selector task for the development release.

Changed in language-selector (Ubuntu):
importance: High → Medium
status: Fix Released → Confirmed
Changed in libreoffice-dictionaries (Ubuntu):
assignee: Gunnar Hjalmarsson (gunnarhj) → nobody
no longer affects: libreoffice-dictionaries (Ubuntu Xenial)

On Fri, May 13, 2016 at 07:47:14PM -0000, Gunnar Hjalmarsson wrote:
> Considering how this will be fixed in Debian, we will need to replace
> the hunspell-gl exception in language-selector with a hunspell-gl-es
> exception, so I reopen the language-selector task for the development
> release.

Consider that I'm going to keep the old binary as a transitional
package, anyway, so probably the workaround won't be needed anymore at
all and can just be dropped once lo-dicts is fixed?
(note that I don't know what the exception does).

--
regards,
                        Mattia Rizzolo

GPG Key: 66AE 2B4A FCCF 3F52 DA18 4D18 4B04 3FCD B944 4540 .''`.
more about me: https://mapreri.org : :' :
Launchpad user: https://launchpad.net/~mapreri `. `'`
Debian QA page: https://qa.debian.org/developer.php?login=mattia `-

Gunnar Hjalmarsson (gunnarhj) wrote :

Well, there is a reason to except hunspell-gl-es, even if it's not as important as the current exception: The users will be prompted to uninstall hunspell-gl-es via "apt autoremove", and if they do, and without the exception, they would be prompted by language-selector to install it again, and so on... (There is currently a similar exception for hunspell-sv-se.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.165.2

---------------
language-selector (0.165.2) xenial; urgency=medium

  * language_support_pkgs.py:
    Hack to exclude hunspell-gl from the installation candidates
    (LP: #1578821).

 -- Gunnar Hjalmarsson <email address hidden> Wed, 11 May 2016 01:44:00 +0200

Changed in language-selector (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for language-selector has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Mattia Rizzolo (mapreri) wrote :

This was really a "problem" of language-selector, but I'm dealing with the lo-dicts part of merging in hunspell-gl-es.
Will eventually complete it.

Changed in libreoffice-dictionaries (Ubuntu):
assignee: nobody → Mattia Rizzolo (mapreri)
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.