Missing symlinks to match locales

Bug #1574745 reported by Gunnar Hjalmarsson on 2016-04-25
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libreoffice-dictionaries (Debian)
Fix Released
Unknown
libreoffice-dictionaries (Ubuntu)
High
Mattia Rizzolo
Xenial
High
Gunnar Hjalmarsson

Bug Description

[Impact]

Dictionaries like

/usr/share/hunspell/es_ANY.aff
/usr/share/hunspell/es_ANY.dic

and

/usr/share/hyphen/hyph_sv.dic

are not recognized by LibreOffice, since their names don't include country codes. The proposed uploads in this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/lo-dicts-symlinks

renames such files, and also adds symlinks in some cases for locales with other country codes but the 'main' locale for a language.

[Test Case]

Example:

* Install the Swedish language via Language Support

* Start libreoffice with a Swedish locale
  LC_CTYPE=sv_SE.UTF-8 libreoffice --writer

* Find that hyphenation is not available

[Regression Potential]

There is a drawback with this fix: For e.g. Spanish and Arabic users the symlinks will add items in the spellcheck menus of other applications but LibreOffice, where it would have worked without those symlinks. OTOH, this is the way it has been handled in Ubuntu up to 15.10, so the fix basically restores the previous behavior.

Other than that, the regression risk is low. This is only about files (including symlinks) in the /usr/share/{hunspell,hyphen,mythes} directories with limited affect on the system.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice-dictionaries (Ubuntu):
status: New → Confirmed
Changed in libreoffice-dictionaries (Debian):
status: Unknown → New
Graham Inggs (ginggs) on 2016-04-28
Changed in libreoffice-dictionaries (Ubuntu Xenial):
importance: Undecided → High
status: New → Confirmed
Mattia Rizzolo (mapreri) wrote :

discussing this on the debian bug, i'll take care of the debian part and subsequently make sure it's synced on yakkety.
@gunnarhj: feel free to assign yourself for the SRU one, somehow lp doesn't let me assign it to you.

Changed in libreoffice-dictionaries (Ubuntu):
assignee: nobody → Mattia Rizzolo (mapreri)
Changed in libreoffice-dictionaries (Ubuntu Xenial):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
Changed in libreoffice-dictionaries (Ubuntu):
assignee: Mattia Rizzolo (mapreri) → Gunnar Hjalmarsson (gunnarhj)
status: Confirmed → In Progress
Changed in libreoffice-dictionaries (Ubuntu Xenial):
status: Confirmed → In Progress
description: updated
Changed in libreoffice-dictionaries (Ubuntu):
milestone: ubuntu-16.04.1 → none
Changed in libreoffice-dictionaries (Ubuntu Xenial):
milestone: none → ubuntu-16.04.1
Mattia Rizzolo (mapreri) wrote :

uploaded to debian, should hit NEW, and once cleared be autosynced in Ubuntu.

Changed in libreoffice-dictionaries (Ubuntu):
assignee: Gunnar Hjalmarsson (gunnarhj) → Mattia Rizzolo (mapreri)
status: In Progress → Fix Committed
Changed in libreoffice-dictionaries (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice-dictionaries - 1:5.1.3-1

---------------
libreoffice-dictionaries (1:5.1.3-1) unstable; urgency=medium

  [ Rene Engelhard ]
  * [51037a1] Imported Upstream version 5.1.3.

  [ Mattia Rizzolo ]
  * [8f7583d] d/control.in: Bump Standards-Version to 3.9.8, no changes needed.
  * [4578b2a] d/helper.py: unblacklist hunspell-ru, we had the ack to take over
    the binary from src:hunspell-ru.
    https://<email address hidden>
  * [ffc3fba] provide the en-au hyphenation dictionaries as a symlink to the
    British one. LP: #105879
  * [17155c1] d/copyright: update after the new release.

  [ Gunnar Hjalmarsson ]
  * [fca7241] d/rules: rename dictionary files to include the country code in
    the file name; is → is_IS. This way they are recognized by LibreOffice.
  * [67f5f1b] d/*.links: add symlinks so more dictionaries are recognized based
    on the locale. Closes: #822617, LP: #1574745

 -- Mattia Rizzolo <email address hidden> Fri, 13 May 2016 15:40:05 +0000

Changed in libreoffice-dictionaries (Ubuntu):
status: Fix Committed → Fix Released
Graham Inggs (ginggs) on 2016-05-16
Changed in libreoffice-dictionaries (Ubuntu Xenial):
status: In Progress → Fix Committed

Hello Gunnar, or anyone else affected,

Accepted libreoffice-dictionaries into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice-dictionaries/1:5.1.0-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I upgraded my hunspell-*, hyphen-* and mythes-* packages from libreoffice-dictionaries to version 1:5.1.0-1ubuntu2.1 from xenial-proposed. Can confirm renaming and additional symlinks as expected. Swedish hyphenation is now available in LibreOffice.

tags: added: verification-done
removed: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I noticed a few worrying lo-dicts bugs at Debian. Some testing on Ubuntu re
<https://bugs.debian.org/824800>:

$ dpkg-query -W hunspell-es myspell-es
hunspell-es 1:5.1.0-1ubuntu2
myspell-es 1.11-11
$ sudo apt install hunspell-es
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  hunspell
The following packages will be upgraded:
  hunspell-es
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/242 kB of archives.
After this operation, 80,9 kB of additional disk space will be used.
(Reading database ... 307265 files and directories currently installed.)
Preparing to unpack .../hunspell-es_1%3a5.1.3-1_all.deb ...
Unpacking hunspell-es (1:5.1.3-1) over (1:5.1.0-1ubuntu2) ...
dpkg: error processing archive /var/cache/apt/archives/hunspell-es_1%3a5.1.3-1_all.deb (--unpack):
 trying to overwrite '/usr/share/hunspell/es_ES.aff', which is also in package myspell-es 1.11-11
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/hunspell-es_1%3a5.1.3-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
$ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  hunspell-es myspell-es
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
$ sudo apt full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  hunspell-es
The following packages will be upgraded:
  myspell-es
1 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 201 kB of archives.
After this operation, 1 202 kB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.
$

Guess that's something we could live with, but <https://bugs.debian.org/824796> and <https://bugs.debian.org/824400> appear to be more tricky. Changing back to "verification-needed" for now.

@Mattia, would appreciate your help to consider this SRU once again. Right now I feel there is a need to add a couple of Breaks/Replaces.

tags: added: verification-needed
removed: verification-done
Mattia Rizzolo (mapreri) wrote :

Except that I wonder how can you have myspell-es 1.11-11, that's the version in wily.
For that one imho a Conflicts: is the best solution (so, commit d3eac80). I haven't actually checked if they are different, but I'm not going to take that package over, so it's either a conflict, or dropping the package.

for hunspell-lt the interesting bug is not https://bugs.debian.org/824796 bug https://bugs.debian.org/824401 (the former is a follow up on the other one, as you can see). I don't think this actually affect xenial, as hunspell-lt has a conflicts on myspell-lt, but separately they can be installed without troubles, I'll let you double check, but I think there is nothing that should be done. Worst case, you can cherry-pick fd810ac, maybe.

For hunspell-kmr I'm still unsure on the path, but I'm working on it.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your input, Mattia. Yeah, apparently I had installed an older myspell-es version for my test case.

Uploaded a new variant to the PPA.

https://launchpad.net/~gunnarhj/+archive/ubuntu/lo-dicts-symlinks

* Made hunspell-es conflict to myspell-es (not sure it's necessary,
  but it mirrors upstream)
* Made hyphen-lt conflict to openoffice.org-hyphenation-lt (the
  ispell-lt changes in <https://bugs.debian.org/824401> won't affect
  Xenial)
* Dropped the ku_TR.* links

So now, the million-dollar question: Is there anything else? ;)

Changed in libreoffice-dictionaries (Ubuntu Xenial):
status: Fix Committed → In Progress
tags: removed: verification-needed
Mattia Rizzolo (mapreri) wrote :

looks like everything to me. I asked ginggs if he could sponsor this last one...

Gunnar Hjalmarsson (gunnarhj) wrote :

Would be great, thanks! (Otherwise I may be able to do it myself after tonight. Have applied for upload rights for a few more packages, including this one.)

Yeah, let's hope this will be the last. :)

Graham Inggs (ginggs) on 2016-05-23
Changed in libreoffice-dictionaries (Ubuntu Xenial):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Hello Gunnar, or anyone else affected,

Accepted libreoffice-dictionaries into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libreoffice-dictionaries/1:5.1.0-1ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Gunnar Hjalmarsson (gunnarhj) wrote :

I downgraded all my lo-dicts provided hunspell-*, hyphen-* and mythes-* packages (including hunspell-kmr and hyphen-lt) to version 1:5.1.0-1ubuntu2, and installed myspell-ku and openoffice.org-hyphenation-lt. Then I upgraded to version 1:5.1.0-1ubuntu2.2 from xenial-proposed, and can confirm that the presence of myspell-ku and openoffice.org-hyphenation-lt didn't prevent a smooth upgrade.

My confirmation in comment #6 applies to version 1:5.1.0-1ubuntu2.2 too.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice-dictionaries - 1:5.1.0-1ubuntu2.2

---------------
libreoffice-dictionaries (1:5.1.0-1ubuntu2.2) xenial; urgency=medium

  * Modifications due to possible file conflicts which were identified
    through Debian bug reports (see comment #7-9 in LP: #1574745):
    - d/helper.py, d/control:
      Add conflicts fields to hunspell-es and hyphen-lt to address
      conflicts which surfaced as a result of the file renaming.
    - d/hunspell-kmr.links:
      Drop ku_TR.* links for now, since they conflict with files
      installed by myspell-ku.

 -- Gunnar Hjalmarsson <email address hidden> Sun, 22 May 2016 04:40:00 +0200

Changed in libreoffice-dictionaries (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libreoffice-dictionaries has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.