[SRU] librcc segfaults on latest saucy

Bug #1183580 reported by Alex Meyer on 2013-05-23
212
This bug affects 39 people
Affects Status Importance Assigned to Milestone
librcc (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

REQUEST FOR STABLE RELEASE UPDATE IN SAUCY:

I updated my system this morning and opened mocp in a UXTerm. Instead of opening, mocp immediately segfaulted. I deleted my ~/.moc folder, hoping that my profile had become corrupted and that a fresh start would solve the problem. Unfortunately, the problem persists.

This is part of the backtrace:

#0 __strcmp_sse2 () at ../sysdeps/x86_64/multiarch/../strcmp.S:212
#1 0x00007faafc8a320a in rccGetDefaultLanguage (ctx=0x198d700) at lng.c:115

This was fixed upstream and the patch got uploaded to Trusty.

[TEST CASE]

In Saucy:

Install moc
This will pull librcc0 as dependency
Start mocp
Instead of the interface you will see a segfault

Then install fixed package from https://launchpad.net/~amoog/+archive/ppa/+sourcepub/3665738/+listing-archive-extra

Start mocp again
You will now see mocp's interface

[REGRESSION POTENTIAL]
The only reverse depends of librcc seems to be moc, which doesn't work at all currently. So the potential for a worsening of the situation is very low.

Alex Meyer (binaryhermit) wrote :

apport information

tags: added: apport-collected
description: updated

apport information

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in moc (Ubuntu):
status: New → Confirmed
cunnilinux (cunnilinux) wrote :

downgraded moc & moc-ffmpeg-plugin back to 2.5.0~alpha4+svn20120224-1ubuntu1 from raring.
that did not help too. it still segfaults.

cunnilinux (cunnilinux) wrote :

seems like the problem is somewhere in librcc0.

after downgrading librcc0 package to 0.2.9-3ubuntu2 from raring,
mocp (2.5.0~alpha4+svn20120224-1ubuntu1 from saucy) works.

Hans Joachim Desserud (hjd) wrote :

Duplicate bug 1186400 contains a stack trace which also implies the underlying problem is related to rcc.

Reprofiling as librcc, since this bug affects other programs using it.

summary: - mocp segfaults upon open on latest saucy
+ librcc segfaults on latest saucy
no longer affects: moc (Ubuntu)
Changed in librcc (Ubuntu):
status: New → Confirmed
TK (tkrishan) wrote :

The Debian binary of librcc0 0.2.9-3.1 also functions well for me with thunar (Bug #1207995) as well as the previous Ubuntu build of 0.2.9-3ubuntu2.

http://packages.debian.org/sid/librcc0

I can confirm that replacing the library with the Debian one fixes this issue.

Elimar Riesebieter (riesebie) wrote :

I've built 0.2.10 which fixes this problem as well. Rebuilding 0.2.9 didn't.

Stego (stegomon) wrote :

mocp crashes on me, too.
system: Ubuntu 13.10 saucy with x86_64 Linux 3.11.0-12-generic on Gnome Shell 3.8
i hope this issue will get solved soon!

Changed in librcc (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Juan Moyano (wincus) wrote :

I'm using Ubuntu 13.10.

Downloaded the debian package from here [1] and installed it with dpkg. Moc now works.

Don't know if this can cause side effects......

[1] http://packages.debian.org/sid/librcc0

Dimitri John Ledkov (xnox) wrote :

librcc is in sync with debian, so exactly the same source is used in both debian/sid and Ubuntu 13.10 and up. So if there are errors caused by librcc compilation in Ubuntu, it's an issue in ubuntu or one of it's reverse-dependecies. E.g. it's an ubuntu specific problem.

Moses Moore (moses-mozai) wrote :

curl -s 'http://archive.ubuntu.com/ubuntu/pool/main/libr/librcc/librcc_0.2.9.orig.tar.gz' |md5sum
98bf20d610f6bcd77893fc374f72a3af -
curl -s 'http://ftp.de.debian.org/debian/pool/main/libr/librcc/librcc_0.2.9.orig.tar.gz' |md5sum
98bf20d610f6bcd77893fc374f72a3af -

curl -s 'http://archive.ubuntu.com/ubuntu/pool/main/libr/librcc/librcc_0.2.9-3.1.debian.tar.gz' |md5sum
83a408a78da2d3e2735fe6ba6696d455 -
curl -s 'http://ftp.de.debian.org/debian/pool/main/libr/librcc/librcc_0.2.9-3.1.debian.tar.gz' |md5sum
83a408a78da2d3e2735fe6ba6696d455 -

Confirming Dmitrijs 's statement. Source packages do seem to be identical, and yet the library files that are built are different sizes:

ls -l /usr/lib/librcc.so.0.2.9 /tmp/librcc.so.0.2.9
-rw-r--r-- 1 root root 108584 May 23 05:24 /usr/lib/librcc.so.0.2.9
-rw-r--r-- 1 moses moses 105180 May 20 13:15 /tmp/librcc.so.0.2.9

... different byte sizes could be something insignificant, but still odd.

TK (tkrishan) wrote :

Please see comment #10; I can confirm Juan Moyano's comment. There must be something different in the binaries even if the source code is the same.

I've been using the Debian binary since August 4, 2013 without any issues.

So, now that this broken librcc0 package has made it in to the release version, and a solution has been found and verified, is there a reason that the package maintainer can't just put the Debian binary in place of the Ubuntu one? I don't mean to sound snarky, I'm not too familiar with the Ubuntu package maintenance process but that seems like an obvious solution.

Dimitri John Ledkov (xnox) wrote :

Ubuntu _never_ takes binary package from anywhere. Only source packages are uploaded into ubuntu, which are then compiled from scratch.

Please let me know if rebuilding the source package _one over again_ on ubuntu resolves the problem.

Ah, I see.

Well, building librcc0 from ubuntu source doesn't seem to do the job, I get the same segmentation fault on startup. Hopefully I was doing the correct thing (per random internet instructions):

apt-get build-dep librcc0
apt-get source librcc0
cd librcc0-0.2.9/
dpkg-buildpackage -us -uc -nc
cd ../
sudo dpkg -i librcc0_0.2.9-3.1_amd64.deb

osirisgothra (osirisgothra) wrote :

(i386 [32-bit] user's instructions, amd64 [64-bit] users will have to alter the link below a bit) I was able to get mocp back up and running pretty simply,
1. sudo apt-get purge librcc0 <note any pkgs that are uninstalled with it, for me it was just moc, and moc-ffmpeg-plugin>
2. then, download manually: https://launchpad.net/ubuntu/precise/i386/librcc0
3. install it (either some ui program or 'dpkg -i librcc0-0.2.9-3ubuntu1-i386.deb' (or amd64 for those 64-bit users)
4. reinstall moc and any other packages previously uninstalled when purging librcc0

thanks to comments above for giving me the idea to do this (13.10 i386, working good now so definitely something in librcc0 since I didn't have to uninstall *any* other packages :) -- hopefully this will be fixed soon, just make sure you dont accidently upgrade it before that happens or else you will be back to square one, it will probably happen with upgrades so you might want to HOLD that package until then.

Hope this helps.
- osirisgothra

hodak (hodak.pl) wrote :

@osirisgothra worked for me, thank's very much

NeverMind (agathe-durieux) wrote :

Method old school, but efficient.

mkdir 123
cd 123

wget http://ftp.de.debian.org/debian/pool/main/libr/librcc/librcc0_0.2.9-3.1_i386.deb
OR
wget http://ftp.de.debian.org/debian/pool/main/libr/librcc/librcc0_0.2.9-3.1_amd64.deb

ar p librcc0_0.2.9-3.1*.deb data.tar.gz | tar zx
sudo mv usr/lib/librcc.so.0.2.9 /usr/lib/librcc.so.0.2.9

Have a nice day !

Lawson (darklord) wrote :

@osirisgothra - It worked for me too, thank you.

Dave Gilbert (ubuntu-treblig) wrote :

On current trusty (i.e. hasn't changed much) it still does it:

(gdb) where
#0 __strcmp_sse2 () at ../sysdeps/x86_64/multiarch/../strcmp.S:212
#1 0x00007faafc8a320a in rccGetDefaultLanguage (ctx=0x198d700) at lng.c:115

        for (i=0;ctx->languages[i];i++) {
115 if (!strcmp(ctx->languages[i]->sn, stmp)) {
(gdb) p stmp
$1 = "en\000\000\000\000\000\000\200ޘ\001\000\000\000\000\001"
(gdb) p ctx
$2 = (rcc_context) 0x198d700
(gdb) p ctx->languages[0]
$3 = (rcc_language_ptr) 0x198dfc8
(gdb) p ctx->languages[0]->sn
$4 = 0x0

so seems to be a relatively simple case of landing a NULL into a strcmp.

Aaron Patterson (apatters) wrote :

Workaround in #23 worked for me, thank you.

James M. Cooper (jmichc) wrote :

I probably should not ask this, but is there any chance at all that this will get fixed during Saucy's life-cycle?

tags: added: trusty
Andreas Moog (ampelbein) wrote :

I've uploaded a possible fix to my PPA, https://launchpad.net/~amoog/+archive/ppa . Once the packages have been built, please test them and give feedback here. If your problems are fixed by the ppa packages, I'll upload to the official archive.

It wokred Perfectly ,after purge all and re-install moc , during
installation sequence
librcc0 was downloded from https://launchpad.net/~amoog/+archive/ppa
and it worked perfectly
Thank you.

On 일, 11월 17, 2013 at 8:57 오후, Andreas Moog
<email address hidden> wrote:
> I've uploaded a possible fix to my PPA,
> https://launchpad.net/~amoog/+archive/ppa . Once the packages have
> been
> built, please test them and give feedback here. If your problems are
> fixed by the ppa packages, I'll upload to the official archive.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1251900).
> https://bugs.launchpad.net/bugs/1183580
>
> Title:
> librcc segfaults on latest saucy
>
> Status in “librcc” package in Ubuntu:
> Triaged
>
> Bug description:
> I updated my system this morning and opened mocp in a UXTerm.
> Instead
> of opening, mocp immediately segfaulted. I deleted my ~/.moc folder,
> hoping that my profile had become corrupted and that a fresh start
> would solve the problem. Unfortunately, the problem persists.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: moc 1:2.5.0~alpha4+svn20120224-1ubuntu1
> ProcVersionSignature: Ubuntu 3.9.0-2.7-generic 3.9.3
> Uname: Linux 3.9.0-2-generic x86_64
> ApportVersion: 2.10.2-0ubuntu1
> Architecture: amd64
> Date: Thu May 23 16:25:14 2013
> InstallationDate: Installed on 2013-05-11 (11 days ago)
> InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Release amd64
> (20130423.1)
> MarkForUpload: True
> SourcePackage: moc
> UpgradeStatus: No upgrade log present (probably fresh install)
> ---
> ApportVersion: 2.10.2-0ubuntu1
> Architecture: amd64
> DistroRelease: Ubuntu 13.10
> InstallationDate: Installed on 2013-05-11 (11 days ago)
> InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Release amd64
> (20130423.1)
> MarkForUpload: True
> Package: moc 1:2.5.0~alpha4+svn20120224-1ubuntu1
> PackageArchitecture: amd64
> ProcVersionSignature: Ubuntu 3.9.0-2.7-generic 3.9.3
> Tags: saucy
> Uname: Linux 3.9.0-2-generic x86_64
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/librcc/+bug/1183580/+subscriptions
>

Jung-Kyu Park (bagjunggyu) wrote :

It wokred Perfectly ,after purge all and re-install moc , during
installation sequence
librcc0 was downloded from
https://launchpad.net/~amoog/+archive/ppa<https://launchpad.net/%7Eamoog/+archive/ppa>
and it worked perfectly on 14.04 trusty tahr
Thank you.

2013/11/17 bagjunggyu <email address hidden>

> It wokred Perfectly ,after purge all and re-install moc , during
> installation sequence
> librcc0 was downloded from https://launchpad.net/~amoog/+archive/ppa
> and it worked perfectly
> Thank you.
>
> On 일, 11월 17, 2013 at 8:57 오후, Andreas Moog <email address hidden>
> wrote:
>
> I've uploaded a possible fix to my PPA,
> https://launchpad.net/~amoog/+archive/ppa . Once the packages have been
> built, please test them and give feedback here. If your problems are fixed
> by the ppa packages, I'll upload to the official archive.
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1251900). https://bugs.launchpad.net/bugs/1183580Title: librcc segfaults on latest saucy Status in “librcc” package in
> Ubuntu: Triaged Bug description: I updated my system this morning and
> opened mocp in a UXTerm. Instead of opening, mocp immediately segfaulted. I
> deleted my ~/.moc folder, hoping that my profile had become corrupted and
> that a fresh start would solve the problem. Unfortunately, the problem
> persists. ProblemType: Bug DistroRelease: Ubuntu 13.10 Package: moc
> 1:2.5.0~alpha4+svn20120224-1ubuntu1 ProcVersionSignature: Ubuntu
> 3.9.0-2.7-generic 3.9.3 Uname: Linux 3.9.0-2-generic x86_64 ApportVersion:
> 2.10.2-0ubuntu1 Architecture: amd64 Date: Thu May 23 16:25:14 2013
> InstallationDate: Installed on 2013-05-11 (11 days ago) InstallationMedia:
> Lubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1) MarkForUpload:
> True SourcePackage: moc UpgradeStatus: No upgrade log present (probably
> fresh install) --- ApportVersion: 2.10.2-0ubuntu1 Architecture: amd64
> DistroRelease: Ubuntu 13.10 InstallationDate: Installed on 2013-05-11 (11
> days ago) InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Release
> amd64 (20130423.1) MarkForUpload: True Package: moc
> 1:2.5.0~alpha4+svn20120224-1ubuntu1 PackageArchitecture: amd64
> ProcVersionSignature: Ubuntu 3.9.0-2.7-generic 3.9.3 Tags: saucy Uname:
> Linux 3.9.0-2-generic x86_64 UpgradeStatus: No upgrade log present
> (probably fresh install) UserGroups: adm cdrom dip lpadmin plugdev
> sambashare sudo To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/librcc/+bug/1183580/+subscriptions
>
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package librcc - 0.2.9-3.1ubuntu1

---------------
librcc (0.2.9-3.1ubuntu1) trusty; urgency=low

  * debian/patches/fix-segfault.patch: (LP: #1183580)
    - Add patch from upstream to fix a segfault in rccGetDefaultLanguage
 -- Andreas Moog <email address hidden> Sun, 17 Nov 2013 12:04:59 +0100

Changed in librcc (Ubuntu):
status: Triaged → Fix Released
Andreas Moog (ampelbein) wrote :

librcc (0.2.9-3.1ubuntu0.1) saucy-proposed; urgency=low

  * debian/patches/fix-segfault.patch: (LP: #1183580)
    - Add patch from upstream to fix a segfault in rccGetDefaultLanguage

 -- Andreas Moog <email address hidden> Sun, 17 Nov 2013 12:04:59 +0100

description: updated
summary: - librcc segfaults on latest saucy
+ [SRU] librcc segfaults on latest saucy
Andreas Moog (ampelbein) on 2013-11-18
Changed in librcc (Ubuntu Saucy):
importance: Undecided → High
James Page (james-page) wrote :

Uploaded to saucy-proposed for SRU Team review.

Andreas - for future reference it would be nice to see a URL to the upstream commit in the Origin: field of the patch headers :-)

Makes it easier to trace patch heritage.

Thanks!

Hello Alex, or anyone else affected,

Accepted librcc into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/librcc/0.2.9-3.1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in librcc (Ubuntu Saucy):
status: New → Fix Committed
tags: added: verification-needed

Hello everybody,

I installed version 0.2.9-3.1ubuntu0.1 of librcc (from the saucy proposed sources) on my 13.10 (64bit amd) machine and it perfectly worked for the "music on console"-player mocp. So it looks like the bug is fixed. I'm not sure whether this "test" is enough to add the "verification-done"-tag. Is it?
Anyway, thanks for the fix!

HAYASHI mizuki (mhayashi19) wrote :

I changed my package repository to use propsed source as instrcted, and installed librcc0.
moc is working correctly (as before) and no trouble happens now.
So the commited changes seems to fix the bug.
Thank you very much for mentenor, developer and of course FLOSS great community!

My environment is ...
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy
Memory: 3.9Gib
Processor: Intel® Atom™ CPU D510 @ 1.66GHz × 4
Graphic: Intel® IGD x86/MMX/SSE2
OS: 32bit
Installed Package: librcc0 0.2.9-3.1ubuntu0.1 i386

Changed in librcc (Ubuntu Saucy):
assignee: nobody → HAYASHI mizuki (mhayashi19)
Changed in librcc (Ubuntu Saucy):
assignee: HAYASHI mizuki (mhayashi19) → nobody
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package librcc - 0.2.9-3.1ubuntu0.1

---------------
librcc (0.2.9-3.1ubuntu0.1) saucy-proposed; urgency=low

  * debian/patches/fix-segfault.patch: (LP: #1183580)
    - Add patch from upstream to fix a segfault in rccGetDefaultLanguage
 -- Andreas Moog <email address hidden> Mon, 18 Nov 2013 11:52:46 +0000

Changed in librcc (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for librcc has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers