libqtbamf version 0.2.1-0ubuntu1 failed to build on i386

Bug #765915 reported by Matthias Klose on 2011-04-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libqtbamf (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

libqtbamf version 0.2.1-0ubuntu1 failed to build on amd64

Complete Log: http://people.ubuntu.com/~amoog/libqtbamf_0.2.1-0ubuntu1.amd64.build.gz

Log excerpt:

dpkg-gensymbols -plibqtbamf1 -Idebian/libqtbamf1.symbols -Pdebian/libqtbamf1
dpkg-gensymbols: warning: some new symbols appeared in the symbols file: see diff output below
dpkg-gensymbols: warning: some symbols or patterns disappeared in the symbols file: see diff output below
dpkg-gensymbols: warning: debian/libqtbamf1/DEBIAN/symbols doesn't match completely debian/libqtbamf1.symbols
--- debian/libqtbamf1.symbols (libqtbamf1_0.2.1-0ubuntu1_amd64)
+++ dpkg-gensymbolsydFqCR 2011-06-21 15:00:08.773767625 +0000
@@ -1,7 +1,7 @@
 libQtBamf.so.1 libqtbamf1 #MINVER#
- (optional=templinst)_Z17qRegisterMetaTypeI13QDBusArgumentEiPKcPT_@Base 0.1
- (optional=templinst)_Z17qRegisterMetaTypeI15QDBusObjectPathEiPKcPT_@Base 0.1
- (optional=templinst)_Z17qRegisterMetaTypeI5QListIjEEiPKcPT_@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_Z17qRegisterMetaTypeI13QDBusArgumentEiPKcPT_@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_Z17qRegisterMetaTypeI15QDBusObjectPathEiPKcPT_@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_Z17qRegisterMetaTypeI5QListIjEEiPKcPT_@Base 0.1
  (optional=templinst)_Z21qMetaTypeDeleteHelperI13QDBusArgumentEvPT_@Base 0.1
  (optional=templinst)_Z21qMetaTypeDeleteHelperI15QDBusObjectPathEvPT_@Base 0.1
  (optional=templinst)_Z21qMetaTypeDeleteHelperI5QListIjEEvPT_@Base 0.1
@@ -18,8 +18,8 @@
  _ZN10BamfWindowD0Ev@Base 0.1
  _ZN10BamfWindowD1Ev@Base 0.1
  _ZN10BamfWindowD2Ev@Base 0.1
- _ZN10QByteArrayD1Ev@Base 0.1
- _ZN10QByteArrayD2Ev@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# _ZN10QByteArrayD1Ev@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# _ZN10QByteArrayD2Ev@Base 0.1
  _ZN10QDBusErrorD1Ev@Base 0.1
  _ZN10QDBusErrorD2Ev@Base 0.1
  _ZN11BamfControl11qt_metacallEN11QMetaObject4CallEiPPv@Base 0.1
@@ -57,6 +57,8 @@
  _ZN11BamfMatcherD0Ev@Base 0.1
  _ZN11BamfMatcherD1Ev@Base 0.1
  _ZN11BamfMatcherD2Ev@Base 0.1
+ _ZN11QStringListD1Ev@Base 0.2.1-0ubuntu1
+ _ZN11QStringListD2Ev@Base 0.2.1-0ubuntu1
  _ZN12BamfUintList11qt_metacallEN11QMetaObject4CallEiPPv@Base 0.1
  _ZN12BamfUintList11qt_metacastEPKc@Base 0.1
  _ZN12BamfUintList16staticMetaObjectE@Base 0.1
@@ -163,29 +165,29 @@
  _ZN34OrgAyatanaBamfApplicationInterfaceD1Ev@Base 0.1
  _ZN34OrgAyatanaBamfApplicationInterfaceD2Ev@Base 0.1
  (optional=templinst)_ZN5QHashI7QStringP8BamfViewE11deleteNode2EPN9QHashData4NodeE@Base 0.1
- (optional=templinst)_ZN5QHashI7QStringP8BamfViewE13detach_helperEv@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QHashI7QStringP8BamfViewE13detach_helperEv@Base 0.1
  (optional=templinst)_ZN5QHashI7QStringP8BamfViewE13duplicateNodeEPN9QHashData4NodeEPv@Base 0.1
  (optional=templinst)_ZN5QHashI7QStringP8BamfViewE6removeERKS0_@Base 0.1
  (optional=templinst)_ZN5QListI7QStringE13detach_helperEi@Base 0.1
- (optional=templinst)_ZN5QListI7QStringE13detach_helperEv@Base 0.1
- (optional=templinst)_ZN5QListI7QStringED1Ev@Base 0.1
- (optional=templinst)_ZN5QListI7QStringED2Ev@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListI7QStringE13detach_helperEv@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListI7QStringED1Ev@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListI7QStringED2Ev@Base 0.1
  (optional=templinst)_ZN5QListI8QVariantE18detach_helper_growEii@Base 0.1
  (optional=templinst)_ZN5QListI8QVariantE6appendERKS0_@Base 0.1
  (optional=templinst)_ZN5QListI8QVariantED1Ev@Base 0.1
  (optional=templinst)_ZN5QListI8QVariantED2Ev@Base 0.1
- (optional=templinst)_ZN5QListIP10BamfWindowE13detach_helperEi@Base 0.1
- (optional=templinst)_ZN5QListIP10BamfWindowE13detach_helperEv@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListIP10BamfWindowE13detach_helperEi@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListIP10BamfWindowE13detach_helperEv@Base 0.1
  (optional=templinst)_ZN5QListIP10BamfWindowE18detach_helper_growEii@Base 0.1
  (optional=templinst)_ZN5QListIP10BamfWindowED1Ev@Base 0.1
  (optional=templinst)_ZN5QListIP10BamfWindowED2Ev@Base 0.1
- (optional=templinst)_ZN5QListIP15BamfApplicationE13detach_helperEi@Base 0.1
- (optional=templinst)_ZN5QListIP15BamfApplicationE13detach_helperEv@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListIP15BamfApplicationE13detach_helperEi@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListIP15BamfApplicationE13detach_helperEv@Base 0.1
  (optional=templinst)_ZN5QListIP15BamfApplicationE18detach_helper_growEii@Base 0.1
  (optional=templinst)_ZN5QListIP15BamfApplicationED1Ev@Base 0.1
  (optional=templinst)_ZN5QListIP15BamfApplicationED2Ev@Base 0.1
- (optional=templinst)_ZN5QListIP8BamfViewE13detach_helperEi@Base 0.1
- (optional=templinst)_ZN5QListIP8BamfViewE13detach_helperEv@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListIP8BamfViewE13detach_helperEi@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZN5QListIP8BamfViewE13detach_helperEv@Base 0.1
  (optional=templinst)_ZN5QListIP8BamfViewE18detach_helper_growEii@Base 0.1
  (optional=templinst)_ZN5QListIP8BamfViewED1Ev@Base 0.1
  (optional=templinst)_ZN5QListIP8BamfViewED2Ev@Base 0.1
@@ -230,6 +232,7 @@
  _ZNK11BamfMatcher12applicationsEv@Base 0.1
  _ZNK11BamfMatcher13active_windowEv@Base 0.1
  _ZNK11BamfMatcher18active_applicationEv@Base 0.1
+ _ZNK11BamfMatcher18register_favoritesERK11QStringList@Base 0.2.1-0ubuntu1
  _ZNK11BamfMatcher19application_for_xidEj@Base 0.1
  _ZNK11BamfMatcher20running_applicationsEv@Base 0.1
  _ZNK11BamfMatcher22application_is_runningERK7QString@Base 0.1
@@ -253,7 +256,7 @@
  _ZNK32OrgAyatanaBamfIndicatorInterface10metaObjectEv@Base 0.1
  _ZNK34OrgAyatanaBamfApplicationInterface10metaObjectEv@Base 0.1
  (optional=templinst)_ZNK5QHashI7QStringP8BamfViewE3keyERKS2_@Base 0.1
- (optional=templinst)_ZNK5QHashI7QStringP8BamfViewE3keyERKS2_RKS0_@Base 0.1
+#MISSING: 0.2.1-0ubuntu1# (optional=templinst)_ZNK5QHashI7QStringP8BamfViewE3keyERKS2_RKS0_@Base 0.1
  (optional=templinst)_ZNK5QHashI7QStringP8BamfViewE8findNodeERKS0_Pj@Base 0.1
  _ZNK8BamfView10metaObjectEv@Base 0.1
  _ZNK8BamfView12user_visibleEv@Base 0.1
dh_makeshlibs: dpkg-gensymbols -plibqtbamf1 -Idebian/libqtbamf1.symbols -Pdebian/libqtbamf1 returned exit code 1
make: *** [binary-fixup/libqtbamf1] Error 1

Related branches

Matthias Klose (doko) on 2011-04-19
Changed in libqtbamf (Ubuntu):
importance: Undecided → High
Changed in libqtbamf (Ubuntu):
milestone: none → oneiric-alpha-3
Andreas Moog (ampelbein) wrote :

The linked branch should fix this FTBFS by updating the symbols file.

Changed in libqtbamf (Ubuntu Oneiric):
status: New → Triaged
Sebastien Bacher (seb128) wrote :

there is a newer version in oneiric and it seems to build fine so closing this bug

Changed in libqtbamf (Ubuntu Oneiric):
status: Triaged → Invalid
Sebastien Bacher (seb128) wrote :

the submitter says on the merge request that the issue is still there in a pbuilder

Changed in libqtbamf (Ubuntu Oneiric):
status: Invalid → Triaged
Andreas Moog (ampelbein) on 2011-06-21
summary: - libqtbamf version 0.2-0ubuntu2 failed to build on i386
+ libqtbamf version 0.2.1-0ubuntu1 failed to build on i386
description: updated
Aurélien Gâteau (agateau) wrote :

Most of the changes are Qt internal stuff which should be safe to ignore, but a new method ( BamfMatcher::register_favorites(const QStringList& favorites)) was introduced in r377, so the symbol file need to be updated.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libqtbamf - 0.2.1-0ubuntu2

---------------
libqtbamf (0.2.1-0ubuntu2) oneiric; urgency=low

  * update symbols file to fix FTBFS (LP: #765915)
 -- Andreas Moog <email address hidden> Sun, 19 Jun 2011 17:59:05 +0000

Changed in libqtbamf (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers