Ubuntu patch breaks libproxy

Bug #354475 reported by DimStar
6
Affects Status Importance Assigned to Milestone
libproxy (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned

Bug Description

We got reports upstream of libproxy: libproxy is not working on Ubuntu.
A user, even when having a Gnome configuration set, get's a warning wpad disabled and the lib falls back to direct, bypassing his proxy.

I would say this part of your 50_px-wpad-fallback-env-var.patch is wrong:
@@ -591,7 +608,12 @@ px_proxy_factory_get_proxies (pxProxyFac
  }

  // If the config plugin returned an invalid config type or malformed URL, fall back to 'wpad://'
- if (!(!strncmp(config->url, "http://", 7) ||
+ if (!do_wpad_fallback)
+ {
+ fprintf(stderr, "*** Config plugin returned invalid URL type and WPAD fallback disabled! Falling back to direct...\n");
+ goto do_return;
+ }
+ else if (!(!strncmp(config->url, "http://", 7) ||
     !strncmp(config->url, "socks://", 8) ||
     !strncmp(config->url, "pac+", 4) ||
     !strcmp (config->url, "wpad://") ||

The only check here seems to be if do_wpad_fallback is enabled, if not give an error and fall back to direct://, without checkling if the config otherwise would have been valid.

I suggest this to && linked with the rest of the original IF.

Related branches

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote : Re: [Bug 354475] [NEW] Ubuntu patch breaks libproxy

DimStar wrote:
> We got reports upstream of libproxy: libproxy is not working on Ubuntu.
> A user, even when having a Gnome configuration set, get's a warning
> wpad disabled and the lib falls back to direct, bypassing his proxy.

Thanks for the notice Dominique! I'll look at it this weekend.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Sorry for the delay.

I think this updated patch solves the problem.

Changed in libproxy (Ubuntu):
assignee: nobody → Emilio Pozuelo Monfort (pochu)
importance: Undecided → High
status: New → In Progress
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Debdiff to fix this bug.

Revision history for this message
Steve Langasek (vorlon) wrote :

Release team ack, please upload.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

waiting for sponsorship

Changed in libproxy (Ubuntu):
assignee: Emilio Pozuelo Monfort (pochu) → nobody
status: In Progress → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

thank you for your work there

Changed in libproxy (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

Uploaded.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libproxy - 0.2.3-0ubuntu5

---------------
libproxy (0.2.3-0ubuntu5) jaunty; urgency=low

  * debian/patches/50_px-wpad-fallback-env-var.patch:
    - Fix logic to not bypass the config plugin when the env variable
      isn't set. We don't do wpad fallback if the env variable isn't set,
      but there's not reason to ignore the config file if one is provided.
      LP: #354475.

 -- Emilio Pozuelo Monfort <email address hidden> Sat, 11 Apr 2009 14:39:28 +0200

Changed in libproxy (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers