pam_mount not honoring options from user config file

Bug #670865 reported by Alberto Donato on 2010-11-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libpam-mount (Debian)
Fix Released
Unknown
libpam-mount (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libpam-mount

I'm using a .pam_mount.conf.xml in my home dir to automatically mount encfs at login on Ubuntu 10.10

My config file is:
<?xml version="1.0" encoding="utf-8" ?>
<pam_mount>
 <volume fstype="fuse" path="encfs#/home/%(USER)/.crypt" mountpoint="/home/%(USER)/Documents/private" options="nosuid,nodev,allow_root" />
</pam_mount>

The mount works, but the allow_root option is not honored.
Mounting manually with encfs accepts the option and user_allow_other is enabled in fuse.conf, so this is not an issue related to fuse.

The same setup worked fine with 10.04.

tags: added: regression-release
tags: added: udd-find
removed: regression-release
Changed in libpam-mount (Debian):
status: Unknown → New
Alberto Donato (ack) wrote :

Enabling debug il pam_mount I can see the command executed is

  $ mount.fuse encfs#/home/ack/.crypt /home/ack/Documents/private -onosuid,nodev,allow_root

which gives the same behaviour as described previously:

  encfs on /home/ack/Documents/private type fuse.encfs (rw,nosuid,nodev,default_permissions,user=ack)

Adding a space between -o and options gives this:

  encfs on /home/ack/Documents/private type fuse.encfs (rw,nosuid,nodev,allow_other,default_permissions,user=ack)

This seems to be a fuse-utils bug.

Alberto Donato (ack) wrote :

A note: mount.fuse has an hand-made command line parsing (no getopt), so it doesn't recognize -o as an option if no space is put between option and argument.
Without space, all options are ignored and defaults are used (hence no allow_other).

Alberto Donato (ack) wrote :

Attached is a patch to fix the problem in libpam-mount, at least until fuse-utils handle the option correcly.

Alberto Donato (ack) wrote :

Sorry, attached correct patch.

tags: added: patch
Changed in libpam-mount (Debian):
status: New → Fix Released
Anders (eddiedog988) on 2014-03-13
Changed in libpam-mount (Ubuntu):
status: New → Confirmed
Changed in libpam-mount (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.