libpam-ccreds linked against libdb4.7

Bug #731918 reported by Ballock on 2011-03-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libpam-ccreds (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libpam-ccreds

libpam-ccreds' source build-depend on libdb-dev, which does not specify which version needs to be used for compilation.

Apparently for lucid's buildserver the version of libdb-dev was 4.7, while the default libdb version required anywhere in main is libdb4.8

The reult of that is that on a clean, fresh install of lucid when you add libpam-ccreds, your system is presented with an additional libdb4.7, while you already had your libdb4.8.

Ballock (ballock) wrote :

This seems to still hold true for Precise beta1 - libpam-ccreds is linked against libdb4.8, while in main there's just libdb5.1.
It seems to be related to bug #731942.

Why is it that universe packages link to a different Berkeley DB than the main packages?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers