Please sync libowfat 0.27-1 from Debian unstable (main)

Bug #92939 reported by Michael Vogt on 2007-03-16
8
Affects Status Importance Assigned to Milestone
libowfat (Debian)
Fix Released
Unknown
libowfat (Ubuntu)
Medium
Unassigned

Bug Description

New revision 0.27-1 which was just uploaded to Debian (main) fixes this. Please sync the package into Hardy.

Changes:
 libowfat (0.27-1) unstable; urgency=low
 .
   * new upstream version (closes: #435478).
   * debian/control: Conflicts: libdjbdns1-dev (closes: #447312).
   * debian/control: add Vcs-Git: http://smarden.org/git/libowfat.git/.
   * debian/implicit: update to a09db2e42c8b6a2d820754d741558e5894944746.

--------------------------

Found the following problem during a install test:

Selecting previously deselected package libowfat-dev.
Unpacking libowfat-dev (from .../libowfat-dev_0.24-1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libowfat-dev_0.24-1_i386.deb (--unpack):
 trying to overwrite `/usr/include/diet/dns.h', which is also in package libdjbdns1-dev
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Changed in libowfat:
status: New → Confirmed
Changed in libowfat:
status: Unknown → New
Changed in libowfat:
importance: Undecided → Medium
Changed in libowfat:
assignee: nobody → rainct
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

libowfat (0.26-0ubuntu1) hardy; urgency=low

  * new upstream version (Closes: #435478)
  * add a debian/watch file
  * debian/control:
     - Push standards version up to 3.7.3
     - Add Section and Homepage fields
     - Conflict with libdjbdns1-dev (LP: #92939)
     - Modify Maintainer value to match the DebianMaintainerField
       specification.
  * debian/rules:
     - clean: don't ignore errors, check if Makefile exists instead
     - replace "shell pwd" call with $(CURDIR)
  * debian/libowfat-dev.docs: Remove TODO, add CHANGES

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Sun, 09 Dec 2007 11:40:37 +0100

Changed in libowfat:
status: In Progress → Confirmed
Luke Yelavich (themuso) on 2007-12-12
Changed in libowfat:
assignee: rainct → themuso
status: Confirmed → In Progress
Luke Yelavich (themuso) wrote :

You are aware that since the upstream tarball is .tar.bz2, whenever Debian gets this new upstream version, we are going to have MD5sum issues with tarballs.

I'd suggest contacting the debian maintainer and asking them how soon they are likely to get this new version uploaded. If it won't be for a while, we can get it in now, and request that Debian uses our .orig.tar.gz file. Otherwise, if it is going to be uploaded in the near future, I suggest we wait for that.

Changed in libowfat:
status: In Progress → Incomplete
Siegfried Gevatter (rainct) wrote :

As the Debian Maintainer doesn't answer (and there's a six months old "new version"-request), I updated my changes for the newest version (0.27) and filled an NMU.

Siegfried Gevatter (rainct) wrote :

The Maintainer finally released a new version. Changing this bug to a sync request.

description: updated
Changed in libowfat:
status: Incomplete → New
description: updated
Changed in libowfat:
status: New → Fix Released
Emilio Pozuelo Monfort (pochu) wrote :

Sync request ACK'd

Changed in libowfat:
assignee: themuso → nobody
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

[Updating] libowfat (0.24-1 [Ubuntu] < 0.27-1 [Debian])
 * Trying to add libowfat...
  - <libowfat_0.27-1.dsc: downloading from http://ftp.uk.debian.org/debian/>
  - <libowfat_0.27.orig.tar.gz: downloading from http://ftp.uk.debian.org/debian/>
  - <libowfat_0.27-1.diff.gz: downloading from http://ftp.uk.debian.org/debian/>
I: libowfat [universe] -> libowfat-dev_0.24-1 [universe].

Changed in libowfat:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.