Ubuntu

Remove binary "opensync-plugin-syncml" from lucid

Reported by Sense Egbert Hofstede on 2010-02-20
136
This bug affects 24 people
Affects Status Importance Assigned to Milestone
libopensync-plugin-syncml (Ubuntu)
Undecided
Unassigned

Bug Description

The package 'opensync-plugin-syncml' depens on the library libsyncml0, which is old and already superseded by libsyncml2, which is also in the repositories but not a dependency of any package as of now.

Because libsyncml0 depends on the package libsoup2.2-8, which is no longer available in the repositories, it cannot be installed and thus 'opensync-plugin-syncml' cannot be installed.

I propose to rebuild 'opensync-plugin-syncml' against the newer 'libsyncml2' and to remove 'libsyncml0' from the repositories.

ProblemType: Bug
Architecture: amd64
Date: Sat Feb 20 16:41:46 2010
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: opensync-plugin-syncml (not installed)
ProcEnviron:
 LANGUAGE=nl_NL.UTF-8
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: libopensync-plugin-syncml
Uname: Linux 2.6.32-14-generic x86_64

tags: added: packaging
Ilya Barygin (randomaction) wrote :

libopensync-plugin-syncml fails to build as it requires libsoup2.2 too. In addition, it refuses to build against new interface of libsyncml. This could be solved by moving to libopensync-plugin-syncml 0.39, but this new version requires libopensync1exp7-dev from opensync 0.39.

So it seems that the way forward is to move opensync and all its plugins to newer versions, but this will require careful analysis, especially since we are already in the Feature Freeze.

Sense Egbert Hofstede (sense) wrote :

If we can't get the newer release of OpenSync in Lucid I would propose to remove this package as it's uninstallable.

Jane Atkinson (irihapeti) wrote :

I installed the earlier version of libsoup manually and was then able to install libopensync-plugin-syncml.

Would it be a possibility to leave libsoup-2.2 in the repositories so as to be able to install libsyncml0?

Siegie (siegie) wrote :

It seems to be just a dependency problem.
I can confirm that it works with libsoup-2.2 from the karmic repo's

Nizar Kerkeni (nizarus) wrote :

$ sudo apt-get install opensync-plugin-syncml
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  opensync-plugin-syncml: Depends: libsyncml0 (>= 0.4.5) but it is not going to be installed
E: Broken packages

$ sudo apt-get install libsyncml0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libsyncml0: Depends: libsoup2.2-8 (>= 2.2.98) but it is not installable
E: Broken packages

Michael Bienia (geser) wrote :

Please remove the binary "opensync-plugin-syncml" from lucid.

It is currently uninstallable, a rebuild attempt failed, and according to previous comments some more packages need to get updated to get it at least build again. A comment from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530626#10 backs this up:
"[libsyncml] 0.5.3 is in experimental. It is not compatible with the 0.22 opensync syncml plugin." Lucid has libsyncml 0.5.4-2.

opensync-plugin-syncml has no rdepends.

summary: - opensync-plugin-syncml depends on uninstallable, old libsyncml0
+ Remove binary "opensync-plugin-syncml" from lucid
Daniel Holbach (dholbach) wrote :

There's a newer version of it in sid: http://packages.debian.org/source/sid/libopensync-plugin-syncml but I don't know how well it works, etc.

Michael Bienia (geser) wrote :

That newer version requires a newer version of opensync which would also require to update several other opensync-plugin-* packages. And I don't think we should be trying to update opensync at this phase of development.

Jane Atkinson (irihapeti) wrote :

This is disappointing for people who use syncml-based phones. But perhaps there aren't very many of us.

Can someone explain to me why it would be a problem to leave the old libraries in the repositories?

Ivan Zorin (iaz) wrote :

First, I would like to confirm this bug.
Second, to whom, who propose to [completely] remove opensync/opensync-syncml related packages (no package - no problem, heh) - i think, that this is pretty bad solution of this bug, IMHO. Ubuntu provides great desktop environment, where each time with each next release user should less concern about how to make trivial things [with portable devices] - e.g., in Lucid iPod support will be right "out-of-the-box", and this is great; so, I suppose, that one of the next steps - provide quality and easy support of synchronization for Evolution between mobile devices with SyncML feature (practically any phone has this feature today), and removing packages, which provide SyncML support, from repos, in such case - wrong move.

mikbini (mikbini) wrote :

I agree with Ivan Zorin. Moreover I'd like to add that opensync-syncml worked with 9.10 and thus this would be a loss of functionality for users (like me) that depend on it.

Michael Bienia (geser) wrote :

Updating opensyncml-plugin-syncml includes also updating some other packages, and without testing these updated packages it will become really hard to get them updated that short before release. And it looks like testing needs hardware which is supported so it's not that easy to test if upgrading all affected packages won't introduce regressions.

Jane Atkinson (irihapeti) wrote :

I understand that updating is going to cause problems. I have been playing with Debian Testing and I've found that the updated syncML plugin (0.39) doesn't work with the other 0.22 plugins.

However, what's the reason we can't leave the existing 0.22 version in the repository? Could the obsolete dependencies be given a slightly altered name to keep them separate from the later versions?

Steve Langasek (vorlon) wrote :

Binary removed:

2010-04-13 03:39:31 INFO Removing candidates:
2010-04-13 03:39:31 INFO opensync-plugin-syncml 0.22-2 in lucid amd64
2010-04-13 03:39:31 INFO opensync-plugin-syncml 0.22-2 in lucid armel
2010-04-13 03:39:31 INFO opensync-plugin-syncml 0.22-2 in lucid i386
2010-04-13 03:39:31 INFO opensync-plugin-syncml 0.22-2 in lucid ia64
2010-04-13 03:39:31 INFO opensync-plugin-syncml 0.22-2 in lucid powerpc
2010-04-13 03:39:31 INFO opensync-plugin-syncml 0.22-2 in lucid sparc
2010-04-13 03:39:31 INFO Removed-by: Steve Langasek
2010-04-13 03:39:31 INFO Comment: unbuildable and uninstallable; LP: #524938
2010-04-13 03:39:31 INFO 6 packages successfully removed.
2010-04-13 03:39:31 INFO Transaction committed.
2010-04-13 03:39:31 INFO The archive will be updated in the next publishing cycle.

As for the question of keeping it in the archive with the old libraries: strictly speaking there's nothing that prohibits us from doing this *if* someone uploads a separate source package for the old binary so that it continues to be security-supportable, but someone would have to commit to actually doing the upload. In the meantime, removing the unbuildable, uninstallable binary is a reasonable thing to do.

Changed in libopensync-plugin-syncml (Ubuntu):
status: New → Fix Released
BeowulfOF (beowulfof) wrote :

Is there a ppa that supports the features for lucid? It is horrible that such a feature should be missing silently.

JF (jfuchs) wrote :

I agree that just removing a good feature that is good for many to synchronise their mobile phones is not a good idea. Also it is a long long term support version, which I think should absolutely have this feature (maybe also out of the box) !

Please give us the possibility to sync our mobile phone again !! :)

Jane Atkinson (irihapeti) wrote :

@Beniamino
It's possible, though probably not recommended, to get the Karmic versions of the packages libsoup-2.2, libsyncml0 and opensync-plugin-syncml and install them manually. That's what I've done.

I hope that eventually a later version becomes available through backports or a PPA. I don't have the technical expertise to run a PPA, otherwise I might offer to.

I realise that I'm going to have some other problems then, because one of the plugins I'm currently using (sunbird/lightning) has more or less been abandoned. Nothing is ever simple, it seems. :)

Thanks a lot for your help Irihapeti. I still need to sync my mobile phone via USB and your hints worked. I hope the package maintainer will fix this soon.

Stephan Müller (megandy) wrote :

I think it's a bad solution to mark this bug as fixed by removing functionality which is used by a lot of users. This is not "human" style, because a lot of newbies like me are not able to sync their phones anymore and do not know how to fix this.

However
@Irihapeti: I'd like to use your solution but don't know how. Would you be so kind to provide a small manual how to accomplish to install the Karmic version? And how to install syncml manually?

Thank you in advance!

Jane Atkinson (irihapeti) wrote :

@Stephan Müller

Go to http://packages.ubuntu.com and use the search engine to find the packages libsoup-2.2, libsyncml0 and opensync-plugin-syncml and download them.

Install them in that order by double-clicking on them. Alternatively, if you have them all in one directory with no other debs present, it should be possible to cd to that directory in a terminal and issue the command: sudo dpkg -i *.deb (but I haven't tried it myself, so I can't be sure it will work).

tattwood833 (tom-tomattwood) wrote :

sorry, sorry sorry,

Don't quite understand how to do this, can you take me through it in really simple steps?

http://ubuntuforums.org/showthread.php?p=9263987

thanks....

tom x

alan singer (alan-singer) wrote :

Sorry, but what does "fix released" mean? Is it available to ordinary users, and if so, where can it be obtained? (e.g. which repositories?).

Thanks for your help.

Asus Eeepc 1101ha running Lucid + Nokia E71 phone

Jane Atkinson (irihapeti) wrote :

@alan singer

There are some instructions for obtaining opensync-plugin-syncml here:
http://ubuntuforums.org/showthread.php?t=1474031
starting at the fifth message.

Irihapeti

alan singer (alan-singer) wrote :

@Irihapeti

Yes, I had already followed the trail in Ubuntu forums, stupid of me to have entered what I did before reading all the comments in this thread.

By the way, it's such a pleasure to read correct, clear and unambiguous English: trying "non-standard" procedures in Ubuntu (Karmic packages in Lucid) is always a risky business, so it's good to have instructions which inspire confidence!

Have already downloaded the 3 Karmic packages and will proceed to installation presently.

Many thanks again,

Alan

@Irihapeti

Thank you for your help. I was able to install the Karmic versions of the packages libsoup-2.2, libsyncml0 and opensync-plugin-syncml. I'll try to connect my new syncML phone to my google calendar tomorrow.

@all

The bug is not fixed yet.
I don't know the rules for this bug tracking system.
I am not sure whether I am allowed to reopen this bug but I did so anyway.

Kind regards
Hendrik

Changed in libopensync-plugin-syncml (Ubuntu):
status: Fix Released → Incomplete
Daniel (daniel-jacobs) on 2010-08-12
tags: added: regression-release
Changed in libopensync-plugin-syncml (Ubuntu):
status: Incomplete → Confirmed
Jonathan Riddell (jr) wrote :

Setting back to fixed. If you have a problem other than a request to remove this package please open a new bug

Changed in libopensync-plugin-syncml (Ubuntu):
status: Confirmed → Fix Released
Bart de Koning (bratdaking) wrote :

Sorry guys, but this is what I call a very bad fix, this is a complete regression of functionality . With an easy fix available. Just load in the old packages into the repositories because of backward compatability. There is no clash of functionality if both older and newer are installed...

libsoup2.2
libsyncml0

Steve Langasek wrote above:
someone uploads a separate source package for the old binary so that it continues to be security-supportable, but someone would have to commit to actually doing the upload.

So how do we do that? Can you just get the source packages out of Karmic, and put them into Lucid, or is there an easy link method available?

@Jonathan Riddell:
I would suggest to change the name and open it again, because the bug is actually not covering a removal, but rather a loss of functionality. Copy and pasting the contents to a new bug is a bit of a waste...

Stephan Müller (megandy) wrote :

I agree with the opinion stated in the preceding comment. Currently it's simply impossible to use the long term Ubuntu to sync with a mobile phone. This is a very sad situation. Especially because a lot of "community functions" have been built in, but support for mobile devices has deteriorated.

Oliver Joos (oliver-joos) wrote :

I also miss opensync-plugin-syncml. But I understand the current problem.

@Jonathan: the current bug description proposes another solution than its title. To prevent further confused discussion, could we extend the description by some explanation like Michaels comment #8? And perhaps some statement about Opensync in Maverik Meerkat? Is someone working on this?

As a workaround for now I can recommend http://syncevolution.org It is very robust and is at least able to sync calendar, addressbook and notes with Evolution. And if you find a problem with your phone model, you can help improving it on http://bugs.meego.com

Matthias Klose (doko) wrote :

syncevolution fails to build in maverick, see bug #644546

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.