openobex-1.3 does not correctly work with non-English chars in phone filesystem

Bug #238481 reported by Constantin on 2008-06-09
4
Affects Status Importance Assigned to Milestone
Fedora
Fix Released
Low
libopenobex (Ubuntu)
Undecided
Unassigned

Bug Description

When mounting mobile phone via obexfs with non-English language set to default in phone, the folders & files with non-English chars are not accessible, because of the bug in openobex. I have found a patch, recompile the library, and it works now.
Some months ago i have reported to Red Hat team about this, and now they have fixed it in current Fedora.
But I have switched to Ubuntu Hardy and now I see the same problem.

Attached file (Red Hat patch) solves the problem

Description of problem:
incorrect work with non-English characters in phone filesystem

Version-Release number of selected component (if applicable):
1.3

How reproducible:

when the phone with non-English language is mounted via obexfs, the non-English
named directories are not accessible

Steps to Reproduce:
1. obexfs -i <mountpoint>
2. cd <mountpoint>

Actual results:

Russian directories are not accessible

Expected results:

Additional info:
I have found some patch:
http://<email address hidden>/msg00587.html

rebuilt rpms from srpm -

and now my Sony Ericsson K700i with Russian language correctly works with obexfs

The proposition is to include this patch to rpm package

another (later) patch version:
http://<email address hidden>/msg00595.html
does NOT work correctly (sometimes fusermounted filesystem is not accessible
after directory change)

Created attachment 292829
this is the patch, I have found

openobex-1.3-11.fc8 has been submitted as an update for Fedora 8

openobex-1.3-11.fc8 has been pushed to the Fedora 8 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update openobex'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5065

Constantin (constantin-) wrote :
Changed in libopenobex (Ubuntu):
status: New → Confirmed
Changed in fedora:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.