obex-check-device crashed with SIGSEGV in __GI_____strtoul_l_internal()

Bug #1539694 reported by oscar.burgos.a on 2016-01-29
24
This bug affects 8 people
Affects Status Importance Assigned to Milestone
libopenobex (Debian)
Fix Released
Unknown
libopenobex (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned

Bug Description

* Impact
obex-check-device segfaults when called with the wrong number of arguments, which is done sometimes on device insertion

* Test case
$ /usr/sbin/obex-check-device "one"

shouldn't segfault

* Regression potential
it changes the invalid number of argument case, shouldn't impact on anything else

---------------------------------------

Ubuntu Xenial Xerus (development branch)
Release: 16.04
the ubuntu software center doesn't run
I think that the update from ubuntu 14.10ls to 16.04ls fail in my pc

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: libopenobex1 1.7.1-3
ProcVersionSignature: Ubuntu 3.19.0-47.53~14.04.1-generic 3.19.8-ckt10
Uname: Linux 3.19.0-47-generic i686
ApportVersion: 2.19.4-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Fri Jan 29 16:44:34 2016
Dependencies:
 gcc-5-base 5.3.1-7ubuntu1
 libc6 2.21-0ubuntu5
 libgcc1 1:5.3.1-7ubuntu1
 libusb-0.1-4 2:0.1.12-28
ExecutablePath: /usr/sbin/obex-check-device
InstallationDate: Installed on 2016-01-20 (8 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta i386 (20150805)
ProcCmdline: /usr/sbin/obex-check-device 0bda
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0xb754196e <__GI_____strtoul_l_internal+110>: movsbl (%eax),%edx
 PC (0xb754196e) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libopenobex
StacktraceTop:
 __GI_____strtoul_l_internal (nptr=0x0, endptr=0x0, base=16, group=0, loc=0xb76c8d00 <_nl_global_locale>) at strtol_l.c:297
 __strtoul (nptr=0x0, endptr=0x0, base=16) at strtol.c:109
 main ()
Title: obex-check-device crashed with SIGSEGV in __GI_____strtoul_l_internal()
UpgradeStatus: Upgraded to xenial on 2016-01-25 (4 days ago)
UserGroups:

oscar.burgos.a (oscar-burgos-a) wrote :
tags: removed: need-i386-retrace
information type: Private → Public
Changed in libopenobex (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libopenobex (Ubuntu):
status: New → Confirmed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libopenobex - 1.7.1-5ubuntu1

---------------
libopenobex (1.7.1-5ubuntu1) yakkety; urgency=medium

  * debian/patches/strtoul_segfaut.patch:
    - backported fedora patch for obex-check-device segfaulting when
      being called with the wrong number of arguments
      (lp: #1539694)

 -- Sebastien Bacher <email address hidden> Mon, 23 May 2016 18:42:48 +0200

Changed in libopenobex (Ubuntu):
status: Confirmed → Fix Released

Hello oscar.burgos.a, or anyone else affected,

Accepted libopenobex into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libopenobex/1.7.1-5ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libopenobex (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Changed in libopenobex (Debian):
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

the update doesn't segfault when called manually and https://errors.ubuntu.com/problem/c0d51143c01823e96ed9b16da94c7e292cd697f6 has no report with the new version

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libopenobex - 1.7.1-5ubuntu0.1

---------------
libopenobex (1.7.1-5ubuntu0.1) xenial; urgency=medium

  * debian/patches/strtoul_segfaut.patch:
    - backported fedora patch for obex-check-device segfaulting when
      being called with the wrong number of arguments
      (lp: #1539694)

 -- Sebastien Bacher <email address hidden> Mon, 23 May 2016 18:42:48 +0200

Changed in libopenobex (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libopenobex has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.