Incompatible builds of libodb and libodb-mysql

Bug #1588330 reported by Boris Kolpackov on 2016-06-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libodb (Ubuntu)
Undecided
Dimitri John Ledkov
Xenial
Undecided
Dimitri John Ledkov
Yakkety
Undecided
Dimitri John Ledkov
Zesty
Undecided
Dimitri John Ledkov
libodb-boost (Ubuntu)
Undecided
Dimitri John Ledkov
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Dimitri John Ledkov
libodb-pgsql (Ubuntu)
Undecided
Dimitri John Ledkov
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Dimitri John Ledkov
libodb-qt (Ubuntu)
Undecided
Dimitri John Ledkov
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Dimitri John Ledkov
libodb-sqlite (Ubuntu)
Undecided
Dimitri John Ledkov
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Dimitri John Ledkov

Bug Description

Only release all packages together!

[Impact]

* libodb stack changes abi when build with new enough g++ (due to c++11 abi tagging)
* things that are compiled with new abi are ok (libodb-mysql); linking against mixed build things does not work (e.g. 3rd party apps, like odb-tests building against new libodb-mysql and old libodb)

[Solution]
* In debian, simply binNMUs were done without bumping the ABI =/

* Whilst libodb-boost and libodb-qt do not appear to be affected, imho it is best to rebuild them too.

[Testcase]
* download odb-tests
* autoreconf -fi
* Build and link with following configs (./configure; make clean; make)
+ ./configure --with-database=sqlite
+ ./configure --with-database=mysql
+ ./configure --with-database=pgsql

There appears to be some incompatibility between libodb and libodb-mysql in that the latter cannot resolve symbols from the former. More details are in this odb-users mailing list thread:

http://www.codesynthesis.com/pipermail/odb-users/2016-May/003277.html

My suspicion (discussed in the second post of the above thread) is that libodb is built in the C++11 mode while the rest of the ODB runtimes (libodb-mysql and libodb-pgsql were confirmed by the users) -- C++98. I, however, couldn't find the package build logs (neither on Ubuntu nor on Debian) to confirm this.

Boris Kolpackov (boris-z) wrote :

I believe the problem is caused by the GCC dual ABI fiasco that is described
here:

https://gcc.gnu.org/onlinedocs/libstdc++/manual/using_dual_abi.html

My current guess is that some libodb* packages (I think libodb) were built
with an older version of the compiler and are still using the old ABI.

Can someone trigger the rebuild of all ODB packages?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libodb (Ubuntu):
status: New → Confirmed
Stephen Albert (potat) wrote :

It looks like the same issue exists with libodb-sqlite as well.

Fedora also had this issue, they fixed it by rebuilding the package.

Dimitri John Ledkov (xnox) wrote :

I'm failing to reproduce this problem on xenial.

Please show the version of the packages installed (e.g. output of $ dpkg -l);
Please share the source code / reproducer that you are trying to compile;
Together with the full build log of the failure (e.g. make &> build.log)

Changed in libodb (Ubuntu):
status: Confirmed → Incomplete
Dimitri John Ledkov (xnox) wrote :

Nevermind, got a reproducer with odb-tests, investigating further.

Changed in libodb (Ubuntu):
status: Incomplete → Confirmed
no longer affects: libodb-mysql (Ubuntu)
Changed in libodb-sqlite (Ubuntu):
status: New → Confirmed
description: updated
Changed in libodb (Ubuntu Zesty):
assignee: nobody → Dimitri John Ledkov (xnox)
milestone: none → ubuntu-17.02
Changed in libodb-boost (Ubuntu Zesty):
assignee: nobody → Dimitri John Ledkov (xnox)
milestone: none → ubuntu-17.02
Changed in libodb-pgsql (Ubuntu Zesty):
assignee: nobody → Dimitri John Ledkov (xnox)
milestone: none → ubuntu-17.02
Changed in libodb-qt (Ubuntu Zesty):
assignee: nobody → Dimitri John Ledkov (xnox)
milestone: none → ubuntu-17.02
Changed in libodb-sqlite (Ubuntu Zesty):
assignee: nobody → Dimitri John Ledkov (xnox)
milestone: none → ubuntu-17.02
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb - 2.4.0-1build1

---------------
libodb (2.4.0-1build1) zesty; urgency=medium

  * No change rebuild for c++11 abi. LP: #1588330

 -- Dimitri John Ledkov <email address hidden> Thu, 09 Feb 2017 13:22:38 +0000

Changed in libodb (Ubuntu Zesty):
status: Confirmed → Fix Released
Changed in libodb (Ubuntu Yakkety):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in libodb (Ubuntu Xenial):
assignee: nobody → Dimitri John Ledkov (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-qt - 2.4.0-2build1

---------------
libodb-qt (2.4.0-2build1) zesty; urgency=medium

  * No change rebuild for c++11 abi. LP: #1588330

 -- Dimitri John Ledkov <email address hidden> Thu, 09 Feb 2017 16:07:41 +0000

Changed in libodb-qt (Ubuntu Zesty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-boost - 2.4.0-1build1

---------------
libodb-boost (2.4.0-1build1) zesty; urgency=medium

  * No change rebuild for c++11 abi. LP: #1588330

 -- Dimitri John Ledkov <email address hidden> Thu, 09 Feb 2017 16:07:28 +0000

Changed in libodb-boost (Ubuntu Zesty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-pgsql - 2.4.0-1build1

---------------
libodb-pgsql (2.4.0-1build1) zesty; urgency=medium

  * No change rebuild for c++11 abi. LP: #1588330

 -- Dimitri John Ledkov <email address hidden> Thu, 09 Feb 2017 16:07:35 +0000

Changed in libodb-pgsql (Ubuntu Zesty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-sqlite - 2.4.0-1build1

---------------
libodb-sqlite (2.4.0-1build1) zesty; urgency=medium

  * No change rebuild for c++11 abi. LP: #1588330

 -- Dimitri John Ledkov <email address hidden> Thu, 09 Feb 2017 16:07:47 +0000

Changed in libodb-sqlite (Ubuntu Zesty):
status: Confirmed → Fix Released
Dimitri John Ledkov (xnox) wrote :

[ubuntu/xenial-proposed] libodb 2.4.0-1build0~16.04.1 (Waiting for approval)

Changed in libodb (Ubuntu Xenial):
status: New → In Progress
Dimitri John Ledkov (xnox) wrote :

[ubuntu/yakkety-proposed] libodb 2.4.0-1build0~16.10.1 (Waiting for approval)

Changed in libodb (Ubuntu Yakkety):
status: New → In Progress

Hello Boris, or anyone else affected,

Accepted libodb into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb/2.4.0-1build0~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in libodb (Ubuntu Yakkety):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Boris, or anyone else affected,

Accepted libodb into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb/2.4.0-1build0~16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb-boost (Ubuntu Xenial):
status: New → In Progress
Changed in libodb-boost (Ubuntu Yakkety):
status: New → In Progress

Proposed package libodb-2.4 amd64 2.4.0-1build0~16.04.1 now successfully builds against libodb-mysql-2.4 amd64 2.4.0-1ubuntu1, but as others mentioned the other packages need to be rebuilt too.

tags: added: verification-done
removed: verification-needed
Dimitri John Ledkov (xnox) wrote :

Not all packages have been published and rebuild; therefore please do not set this to verification-done as publishing incomplete set of rebuilds will now cause !libodb-mysql to fail to link.

tags: added: verification-needed
removed: verification-done
Brian Murray (brian-murray) wrote :

Hello Boris, or anyone else affected,

Accepted libodb-boost into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb-boost/2.4.0-1build0~16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb-boost (Ubuntu Yakkety):
status: In Progress → Fix Committed
Changed in libodb-pgsql (Ubuntu Yakkety):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Boris, or anyone else affected,

Accepted libodb-pgsql into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb-pgsql/2.4.0-1build0~16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb-qt (Ubuntu Yakkety):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Boris, or anyone else affected,

Accepted libodb-qt into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb-qt/2.4.0-2build0~16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb-sqlite (Ubuntu Yakkety):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Boris, or anyone else affected,

Accepted libodb-sqlite into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb-sqlite/2.4.0-1build0~16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb-sqlite (Ubuntu Xenial):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Boris, or anyone else affected,

Accepted libodb-sqlite into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb-sqlite/2.4.0-1build0~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb-qt (Ubuntu Xenial):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Boris, or anyone else affected,

Accepted libodb-qt into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb-qt/2.4.0-2build0~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb-pgsql (Ubuntu Xenial):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Boris, or anyone else affected,

Accepted libodb-pgsql into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb-pgsql/2.4.0-1build0~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libodb-boost (Ubuntu Xenial):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Boris, or anyone else affected,

Accepted libodb-boost into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libodb-boost/2.4.0-1build0~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dimitri John Ledkov (xnox) wrote :

Tested xnial with:

ii libodb-2.4 2.4.0-1build0~16.04.1 amd64 Common ODB Runtime Library
ii libodb-boost-2.4 2.4.0-1build0~16.04.1 amd64 Boost ODB runtime library
ii libodb-boost-dev 2.4.0-1build0~16.04.1 amd64 Boost ODB runtime library (development)
ii libodb-dev 2.4.0-1build0~16.04.1 amd64 Common ODB Runtime Library (development)
ii libodb-mysql-2.4 2.4.0-1ubuntu1 amd64 ODB Runtime Library for MySQL
ii libodb-mysql-dev 2.4.0-1ubuntu1 amd64 ODB Runtime Library for MySQL (development)
ii libodb-pgsql-2.4 2.4.0-1build0~16.04.1 amd64 ODB Runtime Library for PostgreSQL
ii libodb-pgsql-dev 2.4.0-1build0~16.04.1 amd64 ODB Runtime Library for PostgreSQL (development)
ii libodb-qt-2.4 2.4.0-2build0~16.04.1 amd64 Qt ODB runtime library
ii libodb-qt-dev 2.4.0-2build0~16.04.1 amd64 Qt ODB runtime library (development)
ii libodb-sqlite-2.4 2.4.0-1build0~16.04.1 amd64 ODB Runtime Library for SQLite
ii libodb-sqlite-dev 2.4.0-1build0~16.04.1 amd64 ODB Runtime Library for SQLite (development)
ii odb 2.4.0-4build1 amd64 C++ Object-Relational Mapping (ORM)

all is good.

Dimitri John Ledkov (xnox) wrote :

Tested yakkety with:
ii libodb-2.4 2.4.0-1build0~16.10.1 amd64 Common ODB Runtime Library
ii libodb-boost-2.4 2.4.0-1build0~16.10.1 amd64 Boost ODB runtime library
ii libodb-boost-dev 2.4.0-1build0~16.10.1 amd64 Boost ODB runtime library (development)
ii libodb-dev 2.4.0-1build0~16.10.1 amd64 Common ODB Runtime Library (development)
ii libodb-mysql-2.4 2.4.0-2 amd64 ODB Runtime Library for MySQL
ii libodb-mysql-dev 2.4.0-2 amd64 ODB Runtime Library for MySQL (development)
ii libodb-pgsql-2.4 2.4.0-1build0~16.10.1 amd64 ODB Runtime Library for PostgreSQL
ii libodb-pgsql-dev 2.4.0-1build0~16.10.1 amd64 ODB Runtime Library for PostgreSQL (development)
ii libodb-qt-2.4 2.4.0-2build0~16.10.1 amd64 Qt ODB runtime library
ii libodb-qt-dev 2.4.0-2build0~16.10.1 amd64 Qt ODB runtime library (development)
ii libodb-sqlite-2.4 2.4.0-1build0~16.10.1 amd64 ODB Runtime Library for SQLite
ii libodb-sqlite-dev 2.4.0-1build0~16.10.1 amd64 ODB Runtime Library for SQLite (development)

description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb - 2.4.0-1build0~16.10.1

---------------
libodb (2.4.0-1build0~16.10.1) yakkety; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb-mysql, et.al. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Tue, 14 Feb 2017 10:33:46 +0000

Changed in libodb (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libodb has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-boost - 2.4.0-1build0~16.10.1

---------------
libodb-boost (2.4.0-1build0~16.10.1) yakkety; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Wed, 15 Feb 2017 16:44:23 +0000

Changed in libodb-boost (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-pgsql - 2.4.0-1build0~16.10.1

---------------
libodb-pgsql (2.4.0-1build0~16.10.1) yakkety; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Feb 2017 13:03:07 +0000

Changed in libodb-pgsql (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-qt - 2.4.0-2build0~16.10.1

---------------
libodb-qt (2.4.0-2build0~16.10.1) yakkety; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Feb 2017 13:06:28 +0000

Changed in libodb-qt (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-sqlite - 2.4.0-1build0~16.10.1

---------------
libodb-sqlite (2.4.0-1build0~16.10.1) yakkety; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Feb 2017 13:13:59 +0000

Changed in libodb-sqlite (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb - 2.4.0-1build0~16.04.1

---------------
libodb (2.4.0-1build0~16.04.1) xenial; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb-mysql, et.al. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Tue, 14 Feb 2017 10:33:46 +0000

Changed in libodb (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-boost - 2.4.0-1build0~16.04.1

---------------
libodb-boost (2.4.0-1build0~16.04.1) xenial; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Wed, 15 Feb 2017 16:44:23 +0000

Changed in libodb-boost (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-pgsql - 2.4.0-1build0~16.04.1

---------------
libodb-pgsql (2.4.0-1build0~16.04.1) xenial; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Feb 2017 13:03:07 +0000

Changed in libodb-pgsql (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-qt - 2.4.0-2build0~16.04.1

---------------
libodb-qt (2.4.0-2build0~16.04.1) xenial; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Feb 2017 13:06:28 +0000

Changed in libodb-qt (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libodb-sqlite - 2.4.0-1build0~16.04.1

---------------
libodb-sqlite (2.4.0-1build0~16.04.1) xenial; urgency=medium

  * No change rebuild for c++11 ABI transition to fix incompatible builds
    with libodb. LP: #1588330.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Feb 2017 13:13:59 +0000

Changed in libodb-sqlite (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers