libnss-db use private gibc (2.8) functions

Bug #298616 reported by Matthias Klose on 2008-11-16
2
Affects Status Importance Assigned to Milestone
libnss-db (Debian)
New
Unknown
libnss-db (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: libnss-db

libnss-db gets a depedency on glibc-private when built with 2.8:

  00000000 DF *UND* 00000000 GLIBC_PRIVATE _nss_files_parse_protoent
  00000000 DF *UND* 00000000 GLIBC_PRIVATE _nss_files_parse_rpcent
  00000000 DF *UND* 00000000 GLIBC_PRIVATE _nss_files_parse_servent
  00000000 DF *UND* 00000000 GLIBC_PRIVATE _nss_files_parse_grent
  00000000 DF *UND* 00000000 GLIBC_PRIVATE _nss_files_parse_etherent
  00000000 DF *UND* 00000000 GLIBC_PRIVATE _nss_files_parse_pwent
  00000000 DF *UND* 00000000 GLIBC_PRIVATE _nss_files_parse_spent
  00000000 DF *UND* 00000000 GLIBC_PRIVATE _nss_netgroup_parseline

the current pacackage in jaunty allows these for now.

Matthias Klose (doko) on 2008-11-16
Changed in libnss-db:
importance: Undecided → High
status: New → Triaged
Changed in libnss-db:
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.